04-01-2017 08:13 AM
42 12
tools
  1. mbpunjabi's Avatar
    Hi Everyone

    I am having this annoying problem going on with my G4 (H815T). I am using 1GB mobile data on a du SIM, all applications and web browsing work except facebook. The facebook application only seems to work on wifi and it will not connect if mobile data is on (regardless of 2G 3G 4G). I put the SIM on my older G2 phone to check whether its carrier related but it works perfectly there. Its only seldom when it works just for a bit then it wont.

    Things tried:
    - Uninstalling reinstalling app
    - Updating app and phone
    - Clearing data, cache, system cache
    - Switching off phone, removing SIM and battery for 30 seconds and then reinserting
    - Virus check

    If I am logged in, it will not work, and if I am not logged in, I get this error written when I try to login:

    "Sorry, unable to login to Facebook. Please check your network connection or try again later. (HttpNetworkException: proxy HTTP status 400)"

    Any help please?

    Posted via the Android Central App
    daralu07 likes this.
    10-31-2015 11:34 PM
  2. LoicNapaul's Avatar
    i have the exact problem. just bought my LG G4 yesterday. Please help
    daralu07 likes this.
    11-01-2015 01:44 AM
  3. daralu07's Avatar
    Hi there, I have the SAME problem, just with my LG G3, for about 3 days. I cant figure out whats all that about, because, as you said, everything works perfect on wifi... tried to unistall, clear cache but still nothing. Who else can we ask to ?

    thanks
    11-01-2015 01:15 PM
  4. Sharry Phillips's Avatar
    Same problem samsung galaxy s4 HELP I did all the first guy did

    Posted via the Android Central App
    11-01-2015 09:51 PM
  5. NEMANJA GLAVINIC's Avatar
    I have the same problem on my Note 3.
    11-02-2015 01:11 AM
  6. zokiru's Avatar
    Having the same problem, Galaxy S4 on Straight Talk here. Problem started about a day ago. I'm guessing this is a glitch with the app itself lol. Hopefully they will fix it soon.

    Posted via the Android Central App
    11-02-2015 03:42 AM
  7. Felesroo's Avatar
    Also having this problem on Nexus 4 for about 48 hours. All other data works fine. Facebook app will not refresh data.
    11-02-2015 06:02 AM
  8. Tatarenko's Avatar
    Hi all there!
    Technically, 400 status code is Bad Request response from server so most likely problem is on Facebook server.
    But in any case - did you checked if internet is working on your devices at all? E.g. if google.com is loding correctly in browser etc.?
    11-02-2015 07:56 AM
  9. daralu07's Avatar
    everything works fine (just that app doesn't). So i can surf through browser chrome or internet, each site opened normally fast on mobile data, beside this app. I can also use other apps and work great, but this one...
    Tried to remove completely facebook app and facebook messenger app (i think the other one is unnecessery, if i wrote it well), but when instal it again, that **** still happens.

    Posted via the Android Central App
    11-02-2015 09:19 AM
  10. mbpunjabi's Avatar
    Okay guys so after really intense searching and implementing different trials, i found a solution which worked for me, I hope this would help all of you.
    So you go into mobile data, then APN settings. Go into both the WAP and Internet APNs, and I noticed that there was a proxy and port set. I cleared both of them, and wola! it works!

    I dont know whether it relates to the error shown by the facebook app upon login, but the error did mention the word "proxy" so I tried that out and worked. Clearing the proxy did not affect anything else, neither connections nor speed for other apps or browsing

    Do try it out and check if it works!

    Posted via the Android Central App
    11-02-2015 10:55 AM
  11. daralu07's Avatar
    I tried that, but on my lg g3 i dont have settings as you called above, just apn settings automaticaly set from my network operator. I cant delete theme (or clear), but you were right, they are set to some port. I did the acces point reset to default, but still cant login to facebook app anybody else tried this method? Thanks anyway for giving a shot..

    Posted via the Android Central App
    11-02-2015 12:50 PM
  12. Beat_Lu's Avatar
    Just perfect! Thanks for your help.

    After I deleted the proxy and proxyport in the APN settings, the Facebook app can connect again via mobile data. My phone: SONY Xperia Z3 compact, Android 5.1.1, FB App 53.0.0.29.18

    Regards from Switzerland,
    Beat
    Trovac likes this.
    11-03-2015 12:50 AM
  13. Joshue Orr's Avatar
    I have the same problem. I use straight talk with a AT&T phone. So I have specific settings for my data to work. If I change the ports and proxy nothing works. It worked fine until a few days ago. It's really annoying.
    11-03-2015 09:35 AM
  14. johnfreepj's Avatar
    just go to settings
    then MORE
    Mobile Networks
    Access Point Names

    then select internet

    then delete APN

    restart Phone

    then request APN Settings from the service provider

    Install the settings

    restart the phone again

    this worked for me. try your luck
    11-03-2015 09:47 AM
  15. Tatarenko's Avatar
    Did you try to use Facebook without application? Just through your browser? Is it working normally?
    11-04-2015 02:22 AM
  16. daralu07's Avatar
    Yeah of course, it is working normaly via internet browser. But I prefer app, why they made it if didnt work...

    Posted via the Android Central App
    11-04-2015 06:58 AM
  17. binary71's Avatar
    i use net10 and all i did was delete the proxy settings as the user above advised and it worked. Just go to your APN settings and delete the proxy server and proxy port number and it works like a charm. nothing else on my phone was affected by doing this. thanks for the help guys.
    NemanjaSER likes this.
    11-04-2015 04:12 PM
  18. daralu07's Avatar
    Maybe this sounds stupid, but i dont have an option to delete the proxy server. I found everything like you said in APN settings, but dont know how to delete it or unable it, whatever. I contacted my provider, waiting for an answer. Maybe someone with lg g3 or g4 knows what i am talking about.

    Posted via the Android Central App
    11-05-2015 06:10 AM
  19. NemanjaSER's Avatar
    Hi all, i have same prob. Go to settings>More networks>Mobile networks>Access Point Names> Mts wap (this is my network in my land - Serbia)>Proxy>delete all numbers inside. After that all works fine!
    11-05-2015 07:05 AM
  20. daralu07's Avatar
    Nemanja, aj brate na srpskom ne znam dal imas isto g3 telefon, meni ne dopusta uopste da izmenim proxy, ne mogu ni da izbrisem. Sve ostalo radi skroz normalno, samo ta app

    Posted via the Android Central App
    11-05-2015 08:56 AM
  21. NemanjaSER's Avatar
    Pozdrav druze.. Nemam LG, nego Samsung, ali dosta ljudi iz mog okruzenja je odradilo to na njihovim telefonima koji su razni.. Ako ne mozes da ga izbrises, ti izbrisi sve APN-ove i napravi nov, ali da se podudara sa trenutnim:
    APN - Access Point Name: - [isto stavljas kao sto je trenutno]
    Login - Username: - [isto stavljas kao sto je trenutno]
    Password: [isto stavljas kao sto je trenutno]
    Proxy: [ostavljas prazno]
    MCC: [isto stavljas kao sto je trenutno]
    MNC: [isto stavljas kao sto je trenutno]

    Nadam se da ce tako uspeti. Pozdrav i javi sta si uradio..
    11-06-2015 03:47 AM
  22. NemanjaSER's Avatar
    Here is on English for all who have LG G-series.
    Try deleting all APNs, create a single APN to match the correct settings without the proxy.

    Internet Setting:-
    APN - Access Point Name: [same as now]
    Login - Username: [same as now]
    Password: [same as now]
    Proxy: [leave blank]
    MCC: [same as now]
    MNC: [same as now]
    11-06-2015 03:52 AM
  23. daralu07's Avatar
    Finally solved, i got new parametres from my provider, now proxy are NOT set, and i am able to tap on it if want to change. App is on, again

    Posted via the Android Central App
    11-07-2015 10:12 AM
  24. Trovac's Avatar
    Ty dude!
    11-11-2015 01:12 PM
  25. jsykarenee's Avatar
    I have the same problem. I use straight talk with a AT&T phone. So I have specific settings for my data to work. If I change the ports and proxy nothing works. It worked fine until a few days ago. It's really annoying.
    Do you happen to have a Samsung Galaxy S5 Active? Because I am in the same situation and I was wondering if you were able to fix this issue?!
    12-07-2015 03:13 AM
42 12

Similar Threads

  1. Things my Note 4 did that I cannot find on my Note 5
    By heraldo in forum Samsung Galaxy Note 5
    Replies: 3
    Last Post: 11-02-2015, 10:35 AM
  2. NFC turning itself on
    By yourfamilybank in forum Samsung Galaxy Note 5
    Replies: 11
    Last Post: 11-01-2015, 05:09 PM
  3. How do I delete my saved game data in the google cloud?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 11-01-2015, 01:12 AM
  4. Galaxy Tab S why does the back & recent lights stay on
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 11-01-2015, 01:08 AM
  5. Replies: 1
    Last Post: 10-31-2015, 11:28 PM
LINK TO POST COPIED TO CLIPBOARD