1. GaijinBlade's Avatar
    Hello, this is my first time posting here so I apologize if my formatting isn't perfect.

    I have an issue where my mobile data doesn't work in apps. For example: I open the app and watch the arrows at the top of my LG G5 go back and forth as if it is sending and receiving the data but nothing ever loads or happens except for the occasional "cant load.../error..." message. Oddly enough my browser app works just find, loads data without any issue.

    I have tried every APN setting I can find including the ones found here: https://bestmvno.com/apn-settings/straight-talk-wireless-apn-settings/ (If someone has working straight talk APN settings for an LG G5 that would help in eliminating the APN as the culprit)

    I have also checked every setting I could find that would grant or restrict data access to my phone and they all show everything to be in order.

    I have done a factory reset and nothing changed.

    My phone is NOT rooted but it is unlocked. It was previously on T-mobile judging from the splash screen on boot up. It is now being used on Straight Talk. I have tried every trick I can find but this thing is about to get snapped in half and thrown in the trash.

    If anyone can offer some sage wisdom with this I would be eternally grateful!
    10-15-2017 04:15 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! In the APN settings edit screen, try disabling IPv6.
    GaijinBlade likes this.
    10-15-2017 11:07 PM
  3. GaijinBlade's Avatar
    Hi B. Diddy thanks for responding! That was a good idea I hadn't considered that, but I'm still having the same issue...

    Also as an update I forgot to include that I'm unable to send MMS,it looks like I can receive but not send.

    I'm currently using these APN settings:


    Straight Talk AT&T
    APN Name ATT 4G LTE
    APN tfdata
    Proxy proxy.mobile.att.net
    Port 80
    Username
    Password
    Server
    MMSC http://mmsc.mobile.att.net
    MMS Proxy proxy.mobile.att.net
    MMS Port 80
    MCC 310
    MNC 410
    Authentication Type PAP
    APN Type default,mms,supl,hipri
    APN Protocol IPv4
    APN Roaming Protocol
    Bearer
    MVNO Type
    10-16-2017 07:26 AM
  4. B. Diddy's Avatar
    Can you change to the Straight Talk T-Mobile service instead? Straight talk apn settings – Dummy proof guide
    10-16-2017 09:51 AM
  5. GaijinBlade's Avatar
    I tried that as well, as soon as I change APN to wap.tracfone I lost all data immediately and it persisted after a restart.
    10-16-2017 09:57 AM
  6. B. Diddy's Avatar
    If you go to Settings>Mobile Networks>Network Operators, is the correct network selected?

    Also, what if you change the APN to the AT&T settings in that previous link? I'm not sure how recent that article was, but the settings are a little different from the ones you listed.
    10-16-2017 11:00 AM
  7. GaijinBlade's Avatar
    You may be onto something with the network operators...I did a manual search and got five returns:

    Home
    RAT: LTE

    Home
    RAT: WCDMA

    Home
    RAT: LTE

    Home
    RAT: LTE

    Home
    RAT: LTE

    I'm not sure which of these to choose... However if I choose the "select automatically" option I get a quick message that I am registered on the network but I still cant send MMS or load any app data.

    I tried re entering the T-mobile APN settings but it wont pull any data even after a restart...
    10-16-2017 11:30 AM
  8. B. Diddy's Avatar
    That's an odd list. When I do the search on my Pixel XL (on T-Mobile), I see 4 possibilities -- T-Mobile, Verizon, AT&T, and 312770 (not sure what that is). No mention of "Home" or "RAT."

    Did you also try changing the AT&T APN settings to the one in that previous link?
    10-16-2017 11:44 AM
  9. GaijinBlade's Avatar
    I just searched again with the AT&T settings from the previous link and the search returned three items:

    Home
    RAT: LTE

    Home
    RAT: LTE

    Home
    RAT: LTE

    Should I change my network mode to a specific value? at the moment its set to: GSM/WCDMA/LTE auto.
    10-16-2017 11:55 AM
  10. B. Diddy's Avatar
    No, Automatic should be fine.

    Can you show us a screenshot of that Network Operators menu? http://forums.androidcentral.com/gen...d-central.html
    10-16-2017 10:03 PM
  11. GaijinBlade's Avatar
    10-17-2017 06:16 AM
  12. B. Diddy's Avatar
    I'm not sure what those represent -- I've never seen it look like that. What happens if you try out the different selections?
    10-17-2017 04:01 PM
  13. GaijinBlade's Avatar
    There is no real change unless I choose something like the WCDMA then I lose a data connection.

    I tried support for straight talk on their Facebook page. It wasnt much help they said it was something wrong with my apps as their side of things showed that there was nothing wrong with my account on their end.

    Found something new that was strange, I have been using facebook messenger on mobile data without much of an issue but I noticed that I can send and receive text with no issue. I can even get images with no problem, but I cant send any images. I'm fairly convinced this is some sort of permission or port problem.
    10-19-2017 03:49 PM
  14. B. Diddy's Avatar
    Sorry, I'm starting to grasp at straws here. I'm not directly familiar with using Straight Talk -- does one SIM work for both AT&T and T-Mobile towers, depending on the network you select or the APN you enter? Or are there separate SIMs for AT&T and T-Mobile?
    10-19-2017 11:27 PM
  15. GaijinBlade's Avatar
    I understand how you feel, I have been grasping as well for the past few months.

    My understanding of straight talk is that you need to have a SIM set up for your specific network (AT&T or T-Mobile)

    I have noticed I have partial functionality in some apps. For example I can use the google maps app but the weather and traffic data never load if I am on mobile data. I'm not sold that its a SIM issue at this point. It looks like I have some ports on my phone that are not working correctly. Could re-imaging the phone fix this?
    10-20-2017 06:33 AM
  16. GaijinBlade's Avatar
    Finally! I got it worked out.

    In a nutshell I needed a T-mobile SIM and I had an AT&T SIM. I have no idea why Straight talk customer support couldn't work that out... But everything works perfectly now, lighting fast too. I just wanted to post this in case anyone has the same issue in the future.
    11-13-2017 05:50 PM

Similar Threads

  1. Unable to get Apps on moto G5
    By Android Central Question in forum Moto G
    Replies: 1
    Last Post: 10-15-2017, 11:08 PM
  2. how to get past an abnormal factory reset samsung account sign in?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-15-2017, 04:21 PM
  3. Replies: 1
    Last Post: 10-15-2017, 03:35 PM
  4. I can I schedule a recurring event in the calendar?
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 10-15-2017, 02:28 PM
  5. Replies: 0
    Last Post: 10-15-2017, 02:22 PM
LINK TO POST COPIED TO CLIPBOARD