1. venom0706's Avatar
    I moved from S7E to LG G7.

    However, I noticed that when mobile data is switched on, H+ usage is always on, instead of 4G. On the Samsung before, it always switched to 4G.

    Any idea whether this is normal? I am talking about accessing mobile data from the same location on both devices (at home).

    I went to GSMArena and while most devices show different bands at the 4G section (including my S7E), the G7 only shows LTE. Maybe that has something to do with it - perhaps lower 4G coverage than other devices?

    I would really appreciate it if you can help me.

    Thank you.
    06-07-2018 05:06 AM
  2. B. Diddy's Avatar
    PhoneArena.com has more detailed LTE band coverage: https://www.phonearena.com/phones/LG-G7-ThinQ_id10779. Which carrier are you using? If the phone supports your carrier's LTE bands and you're still only on H+, make sure the APN settings are correct for your carrier.
    06-07-2018 10:28 AM
  3. venom0706's Avatar
    PhoneArena.com has more detailed LTE band coverage: https://www.phonearena.com/phones/LG-G7-ThinQ_id10779. Which carrier are you using? If the phone supports your carrier's LTE bands and you're still only on H+, make sure the APN settings are correct for your carrier.
    Thanks.

    I am using Vodafone. I think the G7 should be covered by it. I went to Vodafone today and requested a new SIM card. The phone now still connects to H+, but it also detects 4G more often than not (usually after a few restarts).

    I also check APN settings and they match exactly the ones that are listed on Vodafone's website.
    06-07-2018 10:48 AM
  4. B. Diddy's Avatar
    Vodafone in which country? (I'm not sure if they use different bands depending on the country.)

    Also, go to Settings>Mobile Networks>Preferred Network Type, and make sure it's set to Global or LTE.
    06-07-2018 11:37 AM
  5. Rukbat's Avatar
    And just fyi, GSMArena sometimes takes a month or two to get the listing for a new phone complete. The phone was just released last month.

    Oh, and the APN has nothing to do with whether the phone will register on 4G, it just can't use the internet or MMS (depending on which part of the APN is wrong) if the APN is wrong. Without having the phone in hand, and access to your account, I can only make educated guesses, but it's either the individual phone (let's hope not), the SIM (probably not, since it's detecting 4G) or your account setup (also probably not, since it's detecting 4G).

    I'd suspect a bad antenna or antenna connection. Try around a Vodaphone tower (they can probably tell you where the nearest one is - don't just go to "a tower" - not all carriers have equipment on all towers), and see if you get 4G. (Not right under the tower - the signal comes off at an angle, so maybe a block away.) If you get 4G near towers, it's the phone. (If Vodaphone does repairs, see if they'll take a look at the phone - if all it takes is pushing the antenna connector more solidly into the jack, any technician can do it.)

    (Why 4G and not 3G? Vodaphone uses 900 MHz for 3G - that gives you good range compared to the 2100 MHz they're licensed for [among other frequencies] for 4G. If the antenna connection is bad it'll show up on 2100 MHz before it shows up on 900 MHz. [And you wonder why 30 year old design engineers are bald? Thinking of things like that is part of a day's work.])
    06-07-2018 02:30 PM
  6. venom0706's Avatar
    And just fyi, GSMArena sometimes takes a month or two to get the listing for a new phone complete. The phone was just released last month.

    Oh, and the APN has nothing to do with whether the phone will register on 4G, it just can't use the internet or MMS (depending on which part of the APN is wrong) if the APN is wrong. Without having the phone in hand, and access to your account, I can only make educated guesses, but it's either the individual phone (let's hope not), the SIM (probably not, since it's detecting 4G) or your account setup (also probably not, since it's detecting 4G).

    I'd suspect a bad antenna or antenna connection. Try around a Vodaphone tower (they can probably tell you where the nearest one is - don't just go to "a tower" - not all carriers have equipment on all towers), and see if you get 4G. (Not right under the tower - the signal comes off at an angle, so maybe a block away.) If you get 4G near towers, it's the phone. (If Vodaphone does repairs, see if they'll take a look at the phone - if all it takes is pushing the antenna connector more solidly into the jack, any technician can do it.)

    (Why 4G and not 3G? Vodaphone uses 900 MHz for 3G - that gives you good range compared to the 2100 MHz they're licensed for [among other frequencies] for 4G. If the antenna connection is bad it'll show up on 2100 MHz before it shows up on 900 MHz. [And you wonder why 30 year old design engineers are bald? Thinking of things like that is part of a day's work.])
    Thanks a lot.

    I think the phone is fine now. It connects to 4G every time after making the network preferences to Automatic and restarting it. I made several hard resets and at first it does the H+ thing but after a few restarts and tweaks it settles to 4G.

    I am sure the phone is fine. It's literally 2 days old and ordered from Carphone Warehouse here in the UK.

    I have OCD and the thought of a bad anthena and bringing it to a store scares me off. I would like to think this isn't the case...
    06-07-2018 03:07 PM
  7. venom0706's Avatar
    After 1 week, I think the phone seems ok now.

    It connect straight to 4G everytime i turn on mobile data.

    The only requirements to be ok, though is that after a hard reset, I need to go and manually set the network to Automatic, then afterwards to choose the PAYG plan on Vodafone and LASTLY to restart the phone in order for the 4G connection to appear.

    From then it works every time.

    Do you think this is normal?

    Thank you and appreciated.
    06-12-2018 07:04 AM

Similar Threads

  1. Move files to folders with the help of folder shortcuts
    By sanmahaan in forum Samsung Galaxy Note 3
    Replies: 1
    Last Post: 06-07-2018, 02:46 PM
  2. why is my battery not charging more than to 28%?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 06-07-2018, 11:02 AM
  3. Why won't my hot mail show up on my notepad all of a sudden
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 06-07-2018, 10:55 AM
  4. why do i get this message when trying to message every number in my phone?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 06-07-2018, 08:05 AM
  5. Replies: 0
    Last Post: 06-07-2018, 04:55 AM
LINK TO POST COPIED TO CLIPBOARD