1. jacob0143's Avatar
    Today, I was upset with an app, it's the Bank of America app. I was kinda upset about it because it didn't have all the features like the desktop version. The mobile website also didn't have all of the desktop features. So I felt like going to Google Play and writing a review. Now, I have one Google account, which is the primary one I use for my LG K7. I have Android 5.1.1 version by the way. I also have some other Google accounts that I mainly just use for anonymous purposes. In my primary account, I'm using my real name (from Google+ profile). I didn't wanna use my real name when writing reviews on Google Play. On my other accounts, they just have anonymous names that don't mean anything. And that's what I wanna use for writing reviews. The problem is I went to the desktop version of Google Play. I logged into my primary account and when I go to the Back of America app, I notice that the button 'Write a Review' is there. Ok, but when I logged into my anonymous Google account, I noticed that the button isn't there. I also noticed that it said 'You don't have any compatible devices!'

    There's more I was gonna write, but I think I wanna stop it there. So why is it that it only works when I'm logged into the primary account? Is it because all my apps are linked to my primary Google account, the one I used to sign up with the phone? And I can't link, or should I say sync, them to my other Google accounts?
    10-23-2016 12:40 AM
  2. SpookDroid's Avatar
    That's exactly why. Google Play won't let you write reviews for an app you don't have installed. And since you've installed them with your primary account, unless you log into your phone with your 'anonymous' account and download the app from there, you won't be able to write a review for it.
    10-23-2016 12:42 AM
  3. jacob0143's Avatar
    Well, that's the thing.
    1) I've already tried going to Settings > General > Accounts > sync > and tried adding my anonymous Google accounts. That didn't work. And now when I wanna remove an account, it says 'Removing this account will delete all of its messages, contacts, and other data from the phone!'. Of course, I don't wanna do that on my primary account. But now I question where I was supposed to put the other accounts on there. I think I did something wrong there.

    2) Then I read some other post on this site (can't find it), but the post said to do a search for Google Account, click on the link by Google, click where it says Find your phone > Get Started, click on the device, and then go to Sign out of phone (although now I don't see the option 'cause I logged back into my primary account). And then go back to Find your phone > Get Started, click on the device, and this time choose and sign in to the anonymous account. I tried it, but I still didn't get the 'Write a Review' button. And also, I noticed that I still had all my apps. I thought that if switch to another account, it'll just give you the default apps and then I'd have to download all my apps again. But that wasn't the case.

    3) Then, with the Google Now Launcher app, I swiped to the right to bring up the Google Homepage, clicked the 3 bar icon, Settings, Accounts & privacy, Google Account, and switched to the anonymous account, but the button still wouldn't show up.

    So I'm not exactly sure how to sign out of the primary account for the phone and then sign in to the anonymous account for the phone, and then install the Google Play app on that account so that I can write a review. I'm wondering if that's even possible.

    Edit 1: I found this: https://support.google.com/googlepla.../2521798?hl=en
    I think I already tried this (look at 1)) but it didn't work. Even when I chose the different account, all of the apps that I installed when using the primary account were already there. So there's no way of me knowing if Google Play is actually installed on the anonymous account.

    Edit 2. I didn't try all of the advice in that link, so I will try it out and see if it works.

    Edit 3: Now Google Play is giving me 'Authentication is required. You need to sign into your Google Account.' I click Retry and it just keeps giving me the same error.

    Edit 4: I searched 'google play authentication is required' and I looked up these links:

    https://www.androidpit.com/how-to-fi...required-error
    I used the 2nd link, but the 1st link (well, in this case it's the embedded video. I'm not sure how to make YouTube videos just display as links.) probably works as well. So yeah, the Play Store and my accounts were corrupted so I just followed the instructions and now everything is working again. Just to make sure I could do reviews on both desktop and mobile, I synced the data in both accounts and now I can do reviews in either account, either on the desktop or mobile.
    10-23-2016 01:21 AM
  4. jacob0143's Avatar
    I already solved the issue. The problem is it will not allow you to write a review upon visiting Google Play in a web browser, even if you are logged in. It only works if you have the Play Store app. Also, my issue was that I could not switch to another google account for writing reviews. What was causing it was corrupt data and caches, so with some research, I had to basically reinstall Play Store (don't have the time to look for the link. You can look for it yourself). And bingo, I could have multiple google accounts for writing reviews, assuming you created a main google plus profile for each one. And by the way, this issue is likely not limited to the K7 (which I would like to replace because it's a piece of ****).

    TL;DR I solved my issue by looking online. I also apologize if my comments were too long. I'm just the type of person that likes to write everything off my mind and I also thought I was helping others. Also, [sarcasm]thanks for making me write this when I should be asleep. Thanks a lot.[/sarcasm]
    04-13-2017 01:58 AM

Similar Threads

  1. Turning in my Note 7 for the V20 I wonder if..
    By soldier45 in forum LG V20
    Replies: 20
    Last Post: 10-24-2016, 07:04 AM
  2. now i can re install rom in htc e9 plus through computer
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 10-23-2016, 12:02 AM
  3. How to at Google Pixel XL ?
    By emilioaponte in forum Google Pixel & Pixel XL
    Replies: 6
    Last Post: 10-22-2016, 11:45 PM
  4. my fingerprint and my backup password is not working
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 10-22-2016, 10:29 PM
  5. Replies: 0
    Last Post: 10-22-2016, 10:27 PM
LINK TO POST COPIED TO CLIPBOARD