1. sparrowhawk13's Avatar
    Got a Lucid 2 on ebay, everything was working fine while I waited for the sim card to come. Rooted with Motochopper, and the root process went off without a hitch, I was able to install apps, make wifi calls, no problems. My sim card comes today, I pull the battery (first time shutting down the phone after root) and install the sim card. Now the phone won't turn on. No power to the charging light while the battery is in and plugged in, the light blinks briefly when plugged in with the battery out, but doesn't stay on. Completely unresponsive. I used a multimeter, and the battery has a charge and the positive/negative inside the phone is passing voltage. Anyone have any idea what could cause this? It seems like the phone doesn't know the power button is the power button...is that something in the firmware that could have been altered when rooting? The phone charged and worked fine up until the power off/sim card install. Any help is greatly appreciated, thanks!
    11-14-2013 07:27 PM

Similar Threads

  1. 4.2.1 Download status bar no longer showing
    By fanatic55 in forum Google Nexus 7 Tablet (2012)
    Replies: 6
    Last Post: 04-18-2014, 10:29 PM
  2. Delayed or NO email notifications at all (went through 2 phones)
    By gutwrencher in forum US Cellular Galaxy SIII
    Replies: 1
    Last Post: 05-06-2013, 02:55 PM
  3. Replies: 8
    Last Post: 02-25-2013, 05:50 PM
  4. GoSMS no longer able to RECEIVE group chats?
    By galaxyjay in forum Sprint Galaxy S III
    Replies: 1
    Last Post: 02-06-2013, 05:25 PM
  5. Updating rooted S3 with ClockworkMod Recovery to Jelly Bean
    By WaylonBrown in forum AT&T Galaxy S III Rooting, ROM's, and Hack's
    Replies: 2
    Last Post: 02-06-2013, 02:10 AM
LINK TO POST COPIED TO CLIPBOARD