1. Jerry Hildenbrand's Avatar
    Piece of cake.

    BOOM. Root.

    EDIT: Appears this was closed on production models. See post 3 from RobinM for details.
    xxmohamedxx likes this.
    05-24-2011 08:03 PM
  2. RobinM's Avatar
    Unfortunately it looks like Gingerbreak cannot root the Optimus 3D. I have had it running for an hour now (!) and it is still trying to apply the exploit.

    It just stays on the rotating circle thingy.
    07-01-2011 10:15 AM
  3. RobinM's Avatar
    Ha-har it would seem that SuperOneClick 1.9.5 has rooted it though.

    Link Here
    07-06-2011 07:53 AM
  4. Jerry Hildenbrand's Avatar
    worked just fine on mine. Must be a change from the pre-production units
    07-06-2011 02:01 PM
  5. RobinM's Avatar
    Very possibly... there was even an update waiting when I got the production release!
    07-06-2011 03:35 PM
  6. Jerry Hildenbrand's Avatar
    I guess it's good they patched the kernel. As long as they don't start trying to block access

    Thanks for the update!
    07-06-2011 04:29 PM
  7. jball32's Avatar
    When try n to run superoneclick it dont give me th option to run as "admin".waiting for device is all it says.
    10-09-2011 09:38 PM
  8. jball32's Avatar
    Got it,just rooted my lg thrill with "superoneclick".
    10-09-2011 11:15 PM
  9. RobinM's Avatar
    I am on O2 (UK) The phone is unbranded in any way. Is anyone else getting a message that there is a firmware update... but once you download it it says 'Invalid Software Package'

    I am on firmware version 10D at the moment.
    10-11-2011 08:30 AM
  10. paobrion's Avatar
    I download the SuperOneClick v2.2 then I try to my LG Optimus 3D to root it, but it turns not working bec its not responding stuck already... what I can do? pls help me how to do it!!! thanks
    11-24-2011 12:13 PM
  11. xxmohamedxx's Avatar
    please how i make update for my phone lg optimus 3d foe ics 4.0.4
    01-04-2013 08:08 AM
  12. Mohamed Mostafa1's Avatar
    does it take alot of time?
    01-13-2013 05:05 AM
  13. Jerome Abellar's Avatar
    yeah i do the same things.. yet still not working
    10-23-2013 11:13 AM
  14. m4l1ce's Avatar
    My software version is p925g30c andriod 4.0.4, I had this phone rooted but then I used the LG auto upgrade to 4.0.4 and the superuser programs dont work and I lost root access. Root Browser still works for some reason. I have tried everything possible to root this phone and I cant figure it out. I cant flash a new rom either because the rom manager wont work without root.
    11-24-2013 05:06 AM
  15. yaser mahdy's Avatar
    12-18-2013 03:25 AM
  16. yaser mahdy's Avatar
    12-18-2013 04:07 AM
  17. Metowlly Salhe's Avatar
    02-20-2014 06:25 PM
  18. Brittany Strong's Avatar
    03-02-2014 05:34 PM