1. darkpower_4's Avatar
    No matter what I do, switch charger, cords or plug into computer my optimus g wont do anything. it would sometimes flash the nav lights and notif lights alternating and eventually i could get it to boot and charge but now its riduculious. it wont do anything. it is rooted but on the previous update. what is wrong with it?
    01-21-2013 03:44 AM
  2. Little Darwin's Avatar
    It is hard to say with any certainty, but it sounds like a hardware issue... possibly the charging port, or a connection inside the device..
    01-22-2013 09:25 AM
  3. darkpower_4's Avatar
    Turns out the way the touch screen sensors are built on the outside of the glass makes it (this is still speculation but i got a new phone to try again), "short out" using ghost armor that popular lifetime scratch proof poly-plastic screen protector. The reason i believe this is, because the guy at best buy needed to take it off to take it back and it finally turned back on! I'm going to let ghost armor know when i have them replace it on my new phone what happened but try one more time to be absolutely sure its them at fault. cause i really want that armor.
    01-23-2013 04:15 AM
  4. 63vert's Avatar
    Same thing happened to me today, put a ghost armor screen on today, they turned it off to put a screen saver on and when I turned it back on, I get the lg logo, then a blank lit up screen. It will stay that way, turn it off it will come back on, then the lg screen then a blank lit up screen.
    This sucks, dont know what to do.
    01-23-2013 06:54 PM
  5. darkpower_4's Avatar
    i dropped lg a line about this issue. although i am rooted and i did have the phone in front of my heater vent in my car so i thought it might of been one of those things (it still was working after this) but now that i have somebody else confirming this issue too, this is serious. I wonder what other screen protector affect the phones like this too. I still have to take my phone to have body armor try one more time. I'm going to tell them not to apply it will all that soapy water they spray on all over it. Maybe it takes a couple of days to not be conductive anymore. i have to do a few more tests to be sure. LG said their engineers are looking into it. I told them I was going to follow up after one more try, If failure happens again I'm going to let ghost armor know.
    01-24-2013 03:32 AM
  6. 63vert's Avatar
    I got my phone to start, I had to use the lgnpst program. After many tries and another computer I got it to start up.
    Lets hope it wont do it again.
    01-26-2013 03:35 PM
  7. darkpower_4's Avatar
    I got my phone to start, I had to use the lgnpst program. After many tries and another computer I got it to start up.
    Lets hope it wont do it again.
    Did you take the cover off?
    01-27-2013 02:24 AM
  8. 63vert's Avatar
    I did open the back and unplugged the battery, but that didnt work at all for me.
    01-28-2013 06:21 PM
  9. Moose Michaels's Avatar
    This happened to me once, on my stock optimus g. Wouldn't respond at all. I held the power button, and both the volume buttons simultaneously. For me, this got the phone to start working the way it normally does.
    Hopefully that works.
    01-28-2013 10:31 PM
  10. darkpower_4's Avatar
    I can confirm that when I went back and had it redone that its working still...on the new phone. It was the phone not ghost armour.
    02-02-2013 12:23 PM
  11. FFSAT's Avatar
    I have a stock lg optimus g from att, it would not turn on nor charge using any cables or charges. I did what Moose Michaels explained by holding down both volume buttons and the power buttons at the same time. When I did that that lg logo cMe on and went back off. I plugged the phone back into the wall outlet and it started to charge automaticly...... I hope this information helps and thanks Moose Mochaels for your post.
    07-07-2013 07:07 AM
  12. agbrickey4's Avatar
    Holding both volume buttons and the power button at the same time worked! Thank you.
    07-19-2013 03:43 PM
  13. albertjoseph005's Avatar

    I am also having the same issue. I bought a LGOG sprint programmed to work in Reliance. It was working fine until I apply Xtreme guard screen protector. When I plugin charger, LG sign blinks and the battery charging indication also will blink. But is is not getting on.
    I tried simultaneous pressing of power and volume keys, but is is not working for me.
    It is a non removable battery.
    any help ,suggestions are highly appriciated.
    08-05-2013 07:49 AM
  14. Daniel Fishbaugh's Avatar
    Holding the power button and volume down button simultaneously worked like a charm!
    Kayla Salmon likes this.
    08-09-2013 09:17 AM
  15. Kayla Salmon's Avatar
    I was really worried when this happened and even more worried when I read what you had wrote about it being related to the sensors.

    I can't guarantee that this will work for anyone else, but I was reading here and it recommended holding down the Power'Lock key and the Down key for 10-20 second. Much to my relief my phone did indeed turn back on! They said on the link it would preform a hard reset, wiping the phone clean, but it has done no such thing and is now registering on my computer and chargers.
    10-07-2013 08:32 PM
  16. Joseph Gordon's Avatar
    thank you so much i was flipping out but the worked
    11-11-2013 10:58 AM

Similar Threads

  1. Htc sensation will not charge or turn on but orange led flashes..
    By JimiVaughanDrix in forum New to the Forums? Introduce Yourself Here!
    Replies: 5
    Last Post: 05-30-2013, 10:19 PM
  2. Installed cm9, now won't charge or turn on
    By Mazus in forum HP Touchpad
    Replies: 3
    Last Post: 12-27-2012, 05:19 PM
  3. Replies: 3
    Last Post: 12-08-2012, 01:14 AM
  4. Replies: 5
    Last Post: 01-01-2011, 01:52 PM
  5. MyTouch 3G Slide Won't Charge OR Turn On
    By cowhugging in forum General Help and How To
    Replies: 0
    Last Post: 12-08-2010, 01:40 PM