1. valeriy mirchev's Avatar
    Hey everyone, I bought a Optimus G from some guy because he said its stuck in Recovery Mode and I have dealt with rooting a phone a while ago. And I wanted a good phone for cheap.

    Anyways.. this phone boots with LG logo and after logo appears second time it goes straight to Recovery Mode, BUT I cant select anything with the power button, I can scroll but cant select. I've tried holding it for a long time and nothing. I've tried many forum posts and installed ADB, I've installed LGNPST and found the right .cab/KDZ file.... but LGNPST cant see my phone(Download Mode works too..). When I plug it in, my comp makes a noise and tries to install the device but it isnt successful. I've downloaded the right drivers...
    Could it be because I have Windows 8.1?

    Please HELP!! I would appreciate anyone's help.

    Thank you in advance,
    Valeriy M.
    05-09-2014 12:45 PM
  2. djw39's Avatar
    There was something... maybe go in device manager to the list of USB devices and find the phone and delete it, then reinstall drivers and try lgnpst again

    Sent from my Nexus 4 using Tapatalk
    05-13-2014 10:55 PM
  3. djw39's Avatar
    If you can get download mode it is definitely salvageable

    Sent from my Nexus 4 using Tapatalk
    05-13-2014 10:56 PM

Similar Threads

  1. 128gb Micro SD Card...Have you tried it in the S5
    By phone-a-holic in forum Samsung Galaxy S5
    Replies: 4
    Last Post: 05-16-2014, 05:01 AM
  2. Car mode app but no way to launch
    By mdkeene in forum Samsung Galaxy S5
    Replies: 5
    Last Post: 05-13-2014, 12:13 PM
  3. Woke up in the middle of the night...
    By RionDunn in forum Samsung Galaxy S5
    Replies: 8
    Last Post: 05-11-2014, 11:32 AM
  4. Nexus 5 doesn't appear in Play Store or ADM
    By kluecke in forum Google Nexus 5
    Replies: 3
    Last Post: 05-09-2014, 12:10 PM
  5. ClimbEso - nice FREE memory game in climbing style!
    By radsku in forum Android Apps
    Replies: 0
    Last Post: 05-09-2014, 10:48 AM