1. Sonofaperson's Avatar
    I know 4.4 Kit Kat isn't available yet for the LG optimus g e970, but when I check for an update, it says "connection failed caused by authentication error"
    How do I fix it? Please help! My device is the LG optimus g e970 (In case you didn't catch that)
    09-14-2014 02:21 PM

Similar Threads

  1. Samsung Galaxy S5 touch screen not working after update
    By AC Question in forum Ask a Question
    Replies: 8
    Last Post: 04-26-2015, 07:56 AM
  2. Replies: 3
    Last Post: 09-17-2014, 03:57 AM
  3. Verizon S5 Can't update
    By Rafael04 in forum Ask a Question
    Replies: 2
    Last Post: 09-15-2014, 05:35 PM
  4. Replies: 1
    Last Post: 09-14-2014, 02:32 PM
  5. Verizon HTC One M7 4.4.3 Software Update Issues?
    By Kpk0911 in forum Ask a Question
    Replies: 1
    Last Post: 09-14-2014, 01:58 PM
LINK TO POST COPIED TO CLIPBOARD