1. LakeofGlass's Avatar
    I realize my phone isn't exactly the LG Optimus L, but they look so darned close that this seemed like the best place for me to post.

    I haven't had a problem with a phone in a long time. In my case I'm still unsure if it's a problem on my end, or just communication between the data on my phone and Net10's service.

    Here's my issue. I had switched from the unlimited international monthly plan (which has a higher data feature) back to the typical monthly unlimited, which is a gig lower. The result is me not having any data when I'm not using wifi. I've checked all the mobile settings for data. Literally, everything. After speaking with Net10's customer support (who tried really hard to help), all they could say is that on their side of things it's showing as if everything is "provisioned correctly." The person I spoke to even tried to adjust the data settings on their end, which showed up on my phone as an alert for "date adjustment."

    This all lead me to believe that when adding my last payment into Reserve, it made my data's settings go wacky. Somehow my phone can't tell that it does in fact have data. Net10 said they're giving it, but my phone's just not picking it up. I've tried using all apps that I know use data, and they all say that I'm not connected to a network.

    I feel like my hands are tied on this one. My gut says to just wait until the end of the 30 days, let it deactivate, and reactivate it. Would that work? I really can't think of anything else that might solve this issue, and I don't feel like making a double payment just to get it to work again.
    05-24-2014 12:52 PM
  2. LakeofGlass's Avatar
    Well, I'm going to take that as a "no." I'm just going with my theory that Net10's the one with the issue, and has a bug with sending out data after switching from 3.5gb to 2.5gb. I don't think my phone's the problem, since I had an old friend who I'd run across having the same problem that I'm having right now. And naturally the customer support, notorious for not being great to begin with, tells me to "click the live chat link" after I've already been there, done that. I sure haven't found any other solution than it being Net10, though I thought I'd try posting here. I did read that some with these phones had a data network issue in the past.
    05-26-2014 11:56 AM

Similar Threads

  1. Google map and GPS display problem on Galaxy Note 10.1
    By BillPhillips in forum Samsung Galaxy Note 10.1
    Replies: 4
    Last Post: 06-09-2014, 10:54 PM
  2. The 'root' of the problem
    By suthern_man in forum General Help and How To
    Replies: 2
    Last Post: 05-24-2014, 09:09 PM
  3. Problem installing apps on SD card on Galaxy S4
    By CROF S in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 05-24-2014, 10:17 AM
  4. Extreme Power Saving Mode
    By AshtonVibe in forum HTC One M8
    Replies: 0
    Last Post: 05-24-2014, 08:36 AM
  5. Synchronization problem with mail app
    By 01Kuzma in forum HTC One M8
    Replies: 7
    Last Post: 05-24-2014, 08:24 AM