1. jimnjoan's Avatar
    Hi Everyone,
    I have a new LG L39 C, or Optimus Dynamic 2. It is a Tracfone. It works well except for one thing, I can't connect to my secured home WiFi.
    It won't even try. I click connect and nothing happens.
    It will connect to my neighbors (don't know who) unsecured WiFi.
    I know my password is correct.
    I've been on the phone with Tracfone's customer support for over an hour and tried everything they had: Tried a hard reset, tried taking the battery out with the phone on, tried turning off 3G data, tried in airplane mode, then out of airplane mode and nothing made any difference.
    It says that my WiFi is secured and saved. When I click "connect", nothing happens, it doesn't do anything.
    Tracfone is sending me a new phone, but I'd like to know if there's a fix for this in case my new one arrives with the same problem....
    The security on my WiFi is: WPA/WPA2 PSK
    My signal strength is good.

    Thanks so much!

    This is my first "smart-phone" and I'm no programmer, so try to keep it basic for me...
    07-07-2014 01:40 AM
  2. jimnjoan's Avatar
    Nevermind....I figured it out.
    Neither the tech support nor the LG manual mentioned touching the menu button (hardware) when in the Wifi screen. When you touch the menu button a WPS selection tool pops up and you can select the WPS button. When you do that the phone pairs with the WIFI.
    I wish the folks at Tracfone knew this info...it could have really been helpful, rather than running my phone through it's proverbial paces..
    Thanks anyway Android peeps.
    07-07-2014 07:20 AM
  3. Bil B's Avatar
    Just got my LG l39c yesterday, and activated it, but have the same problem of getting on my home wifi. It keeps telling me that there's a "authentication problem" even though I have a very strong signal. Tried pressing the wifi push button on my router a couple of times, but still can't access my wifi. Any suggestions? Thanks....Bill
    09-30-2014 01:39 PM
  4. Sandcal's Avatar
    10-16-2014 05:22 PM
  5. MJAnspacher's Avatar
    +1. Thanks for this, the TracFone folks don't have a clue...
    03-12-2016 03:53 PM

Similar Threads

  1. is the us celluar s3 supposed to be on 4.4?
    By 0pk in forum Samsung Galaxy S3
    Replies: 2
    Last Post: 07-09-2014, 02:47 PM
  2. Can I download directly to sd my card?
    By wikedkid101 in forum General Help and How To
    Replies: 4
    Last Post: 07-07-2014, 12:39 PM
  3. Trying to run Miracast on Android x86 platform
    By Pankaj Baranwal in forum Ask a Question
    Replies: 0
    Last Post: 07-07-2014, 01:10 AM
  4. Replies: 0
    Last Post: 07-07-2014, 01:10 AM
  5. Unable to connect to server
    By challenged_101 in forum AT&T Galaxy S III
    Replies: 0
    Last Post: 07-06-2014, 10:06 PM