1. hackemall5's Avatar
    I have a Sprint Optimus S that I cannot get to show on my adb interface.It shows on my computer as far as the usb stuff goes.Ive tried to use LG updater and I get to 100% and it fails on the library call and tells me to retry,which I have,many times.Ive tried kdz to no avail.And LGNPST,and the LG utilities 500 thing.This phone was fine,rooted etc.But someone tried something with it(dont know what)heres the deal:it wont charge so I charge it on a device that charges any battery,screen shows nothing,but its the one that if Rom Mgr is used goes black.I use screencaster but it wont work because of the adb issue.Ive been in this biz for 7yrs and HATE to be defeated by a phone.Could somebody please give me some advice before I use this phone for a snowtire?Thanks guys.
    02-16-2012 05:51 PM
  2. garwynn's Avatar
    Just curious:

    1) Does USB come up? (How about any unknown devices or error devices in Device Manager?)
    2) What OS? (I had issues with Win 7 x64 until I got the right driver)
    3) Have you tried with a different baseband?

    Just spitballin'.... maybe one of these will stick.
    Good luck!
    02-16-2012 05:57 PM
  3. hackemall5's Avatar
    Yeah,it shows all 3 usb things but nowhere does it say adb sooner device in my device mgr.Im running xp pro svc pk 3.
    02-16-2012 07:09 PM
  4. me2151's Avatar
    navigate to the folder you have adb in(in your command prompt) and type adb.exe devices

    Post if it works(mainly the navigate to folder part :P)
    02-16-2012 07:31 PM
  5. jonny5449's Avatar
    how do i use this thing it says adb unrecognized command
    02-16-2012 07:36 PM
  6. jonny5449's Avatar
    i typed that with phone on usb debug and now my phones in a forever boot loop with cm7. i i i
    02-16-2012 07:40 PM
  7. me2151's Avatar
    i typed that with phone on usb debug and now my phones in a forever boot loop with cm7. i i i
    boot recovery and wipe cache.
    02-16-2012 07:42 PM
  8. hackemall5's Avatar
    It says list of devices attached and thats it,I think I need adb driver but Ive looked everywhere,installed/uninstalled them ALL and nothing works.I just used the kp500 again and now my backlight is on but nothing else?
    dobbs69 likes this.
    02-16-2012 09:25 PM
  9. garwynn's Avatar
    Can you send a screenshot of the adb devices result or copy/paste from Command Prompt?
    If the device is showing up then you're good and can continue with what you need to do.
    If this is the only phone connected you should only see one device.
    02-17-2012 09:51 AM
  10. hackemall5's Avatar
    It says list of devices attatched but there are NO devices listed.D:\Android\android-sdk\platform-tools is all that appears on the next line.
    02-17-2012 04:57 PM
  11. garwynn's Avatar
    I'm going to pull from an older post as I think it may help. It's hard to get USB debugging enabled if you can't see anything and I suspect that's where you're at.

    LG changed the LCD component midway through the product cycle. The new LCD requires new drivers which aren't present on older ROMs. If you run an older ROM with the new LCD, it'll work, as in the buttons work, you can swipe the touch screen, etc., just there will be no visual feedback.

    Most likely what happened is the seller "restored" the phone to stock ROM using a guide that had an older ROM. They may or may not have checked to make sure the phone works after restoring stock ROM.

    If all this is true, then you can get your phone working again. What you should do is run the ZVD update.zip from this thread:


    Skip step #2 as you probably have stock recovery (though it is not assured)

    There are pictures on how to perform the operations "blind". You need to look at the pictures and visualize the button presses interacting with the menus in the pictures. I listed the # of button presses needed at each point also.

    After you are done, you should be able to boot into Android. If it gets stuck at the Android logo for more than 7 minutes, do the procedure listed in Step 3, Note #1.
    Link to original: http://forums.androidcentral.com/spr...optimus-s.html

    Will continue to keep putting options out there so long as you're willing to use it yet for a snowtire
    hackemall5 likes this.
    02-17-2012 05:26 PM
  12. garwynn's Avatar
    A couple of other links that may offer assistance:


    And you said you tried KP500, did you try going back to ZV9 or ZVD? Think you may have tried with ZV9 as it was a known issue. Getting the ZVD image - I think I have it somewhere - may fix it. I'll look and see if I still have it as I had to do it at one point myself before going to ZVH.
    hackemall5 likes this.
    02-17-2012 05:34 PM
  13. garwynn's Avatar
    02-17-2012 05:54 PM
  14. hackemall5's Avatar
    Well Im trying KDZ again at the moment.Ill be posting the log file maybe then we can figure out whats up It goes CDMA:wparam=20 iparam=2721 then Model Dll msg not found(20,2721).Does the same thing at (20,2085)and (20,1529),(20,983)
    02-17-2012 06:15 PM
  15. hackemall5's Avatar
    I have ALL of the LS670 cabs from Zefies,and tried them all.Im f$&*$#@ stumped!!!
    02-17-2012 06:18 PM
  16. hackemall5's Avatar
    Well this is what occurs at the end of the update.
    16:48:51 : CDMA: wParam = 8, lParam = 0
    16:48:51 : Step : Phone Reset(DLL Cmd)
    16:49:21 : CDMA: wParam = 100, lParam = 92
    16:49:21 : Step : Upgrade Error2 - Error Code : 92
    16:49:21 : ResetStartInfo() Call
    16:49:21 : _DetachDLL Call
    16:49:21 : _DetachDLL Call End
    16:49:21 : FreeLibrary Call
    16:49:23 : FreeLibrary Call End
    16:49:23 : ResetStartInfo() Call End
    16:49:23 : CDMA: wParam = 20, lParam = 0
    16:49:23 : Model Dll Msg Not Found(20, 0)
    16:49:35 : OnModelDllMsg(OnMsgFromModelDll-CDMA) delete m_pLGCyonUpdate
    02-17-2012 06:55 PM
  17. garwynn's Avatar
    May want to try the steps given by lowwang here:


    I'll also recommend posting further issues in that thread instead of creating a new one - you'll be more likely to get help in that thread. Good luck and hope you can get the phone running!
    02-21-2012 12:30 PM
  18. CuriousNoob's Avatar
    The folder with adb in it, hold shift, and right click. Then click Open Command Window Here. You can use adb there, hopefully.

    Sent from my LG-VM670 using Tapatalk
    02-21-2012 02:37 PM
  19. hackemall5's Avatar
    Ok,its time to pick up and try to fix it again.Does anyone know where I could get the ZVH firmware file?Ive been told I need the ENTIRE file,and that its alot larger then the "cab' file.Any help will get you a few beers.Thx
    04-06-2012 11:10 PM
  20. Sindustry's Avatar

    Back2Basics: Do a complete unbrick-factory restore using this thread. If you still have problems uninstall all the computer-side drivers you previously installed, run something like CCCleaner, then re-install and try again.
    04-07-2012 09:10 AM
  21. hackemall5's Avatar
    Thx for the advice,tried it and no dice.What I need is the main cab or scr file.Its really big.Whats happened is somehow the ENTIRE file system got wiped.I can run the unbrick method fine,but what happens is I get the"model dll not found,or dll error"message four or five times during the update.Then at the end it fails on the library call.
    04-07-2012 11:31 PM
  22. Sindustry's Avatar

    These are the cab files. Each is basically a backup of stock android with radio and everything that you update using the LG updater/KP tools/whatever the unbrick/revert/update tutorial requires. Each one represents a different radio basically. ZVC, ZVD, ZVH, etc.

    Also can you paste the exact errors word for word so we can better help diagnose the issue?

    EDIT: Or screenshots
    04-08-2012 11:44 PM