06-06-2012 05:56 PM
105 123 ...
  1. brattt78's Avatar
    Please help!
    I tried rooting my husband's optimus but when i loaded a custom rom, he was unable to send/receive text messages. i tried a few other roms with no fix. restored stock via nandroid backup still no fix. read that i had to unroot the phone to downgrade to froyo to get a radio fix and upgrade back to gingerbread to reroot (my evo was SO MUCH EASIER) but when i tried downgrading i didn't realize i also had to restore the stock recovery so i bricked it. i managed to unbrick it using this method
    >>Un-Brick method for SOME forms of brick - Android Forums at AndroidCentral.com
    but now i'm stuck in recovery with the following errors:
    E:Can't mount CACHE:recovery/command
    E:Can't mount CACHE:recovery/log
    E:Can't open CACHE:recovery/log

    i tried flashing a rom, restoring nandroid backup and flashing update.zip (sprint stock froyo which bricked it again) but i'm still stuck.

    any ideas???

    my keyboard died while typing this up... maybe I should go play lotto, my luck has to turn around somewhere!

    1. download the stock recovery for your phone
    2. rename it "recovery.img" without quotes
    3. mount your sd card using the usb toggle
    4. save it to the root of your sd card
    5. unmount the sd card
    6. open adb
    7. enter the following commands (press enter after each line):
    adb shell
    mount /sdcard
    flash_image recovery /sdcard /recovery.img
    Note: I had to run those commands a few times before it actually installed the recovery image correctly.
    8. reboot into stock recovery
    **if you don't get the # after entering "adb shell", you aren't rooted and i don't know how to help but otherwise you should be good.

    depending on what you plan on doing at that point you may need different instructions. i flashed back to froyo using the official sprint zip and then upgraded back to gingerbread, rerooted and installed a custom recovery and finally a custom rom. if you need any help or clarification just let me know.
    Buddlespit likes this.
    02-20-2012 12:58 AM
  2. Buddlespit's Avatar
    did you try flashing the zvd (froyo) update.zip twice?
    brattt78 likes this.
    02-20-2012 01:03 AM
  3. brattt78's Avatar
    did you try flashing the zvd (froyo) update.zip twice?
    yes, both times i ended up with the lg logo screen and had to run the >>Un-Brick method for SOME forms of brick - Android Forums at AndroidCentral.com<< method to get into recovery. now i'm stuck there instead.
    Buddlespit likes this.
    02-20-2012 01:12 AM
  4. Buddlespit's Avatar
    OK, I think you may have broken root. After e-mode recovery, you should try doing the update.zip flash again. After the first flash, reboot to the rom, then back into recovery and flash update.zip again. Hopefully, you'll just have to re-root the phone and install the custom recovery again afterwards.
    brattt78 likes this.
    02-20-2012 01:20 AM
  5. brattt78's Avatar
    i appreciate your help but after i do the emode recovery, it sends me straight into recovery mode. i can't get into the rom that's where my problem is. i tried doing the update.zip twice already and both times i land in recovery mode on the phone. i'm trying to figure out how to get past that. if i could get into the rom, i would flash stock recovery on the terminal but i'm stuck.
    Buddlespit likes this.
    02-20-2012 01:25 AM
  6. brattt78's Avatar
    sorry, i meant to say that after i run the update.zip i get stuck on the lg screen. then i have to go through that whole process again which isn't easy, it's actually very unfriendly and i'd like to avoid it if possible. i've been at this over 7 straight hours and just don't know where to go from here. i'm hoping i didn't destroy his phone completely!!
    Buddlespit likes this.
    02-20-2012 01:29 AM
  7. Buddlespit's Avatar
    OK, maybe I'm missing something. What recovery are you seeing (stock or custom)? Is update.zip on the root of your sd-card? Can you open an adb shell session?
    brattt78 likes this.
    02-20-2012 01:29 AM
  8. brattt78's Avatar
    sorry i'm confusing myself!
    ok, i started out fine rooting his phone. i installed a custom rom and recovery but the rom seemed to have issues with texting. i tried finding answers online and the best answer i had was to rollback to froyo from gingerbread to update the radio. i did not put all of this together and just ran the update which broke my root but left my custom recovery so basically i have a custom recovery but cant' get into the rom. i tried restoring nandroid and flashing but since i'm no longer rooted nothing is working. does that make more sense?
    Buddlespit likes this.
    02-20-2012 01:35 AM
  9. brattt78's Avatar
    and yes, update.zip is on the root of my sdcard. i cannot open an adb shell session that i know of... i certainly can't open the terminal emulator. i know there's another way to run adb commands but i don't remember what it is. can i run it from recovery mode?
    Buddlespit likes this.
    02-20-2012 01:37 AM
  10. Buddlespit's Avatar
    ya, it does. Where you went wrong was not flashing the update again, before you ran the nandroid. Or you didn't let the system boot fully. OK, so you have update.zip on your sd-card and a custom recovery. Try this, go to "install zip" in the recovery menu (not install update.zip option), then turn off permissions, then flash update.zip again. Boot all the way up to the rom. Then go back to recovery and do the update.zip option.
    brattt78 likes this.
    02-20-2012 01:41 AM
  11. Buddlespit's Avatar
    This is making me wish I had an instant messenger
    brattt78 likes this.
    02-20-2012 01:42 AM
  12. brattt78's Avatar
    ugh sorry! i'm really tired please bear with me. so i just realized no, i can't run adb shell because i'm not rooted.
    Buddlespit likes this.
    02-20-2012 01:42 AM
  13. Buddlespit's Avatar
    no problem. I'm not working tomorrow, so I can hang here for a while...
    brattt78 likes this.
    02-20-2012 01:44 AM
  14. brattt78's Avatar
    lol i know what you mean about the im!
    ok, i do know what you're talking about because my evo has the install update.zip option but the optimus recovery that i'm on (ra thunder gnm) does not so i think that i must have been using the method you described because i don't see any other way to do it. i'm just nervous to do it again because to get back into recovery from the logo screen takes almost an hour
    Buddlespit likes this.
    02-20-2012 01:46 AM
  15. Buddlespit's Avatar
    make sure you turn off sig verifications. I prolly called them permissions earlier, sorry
    brattt78 likes this.
    02-20-2012 01:49 AM
  16. Buddlespit's Avatar
    recovery-ra-opts-3.06-gnm.img is that the recovery you're using?
    brattt78 likes this.
    02-20-2012 01:51 AM
  17. brattt78's Avatar
    this is what my recovery looks like
    Custom Recovery for LG Optimus S
    Buddlespit likes this.
    02-20-2012 01:51 AM
  18. Buddlespit's Avatar
    In "Other", Toggle Signature Verify, then flash the update zip
    brattt78 likes this.
    02-20-2012 01:55 AM
  19. brattt78's Avatar
    back to the lg screen
    Buddlespit likes this.
    02-20-2012 02:00 AM
  20. Buddlespit's Avatar
    let it spin for a few minutes (just to be sure), then pull the battery, press and hold power for 30 seconds, reinstall battery and reboot into recovery.
    brattt78 likes this.
    02-20-2012 02:02 AM
  21. brattt78's Avatar
    it's not spinning at all, it's not the android splash screen, it's just the lg logo. i've let it sit for 15 mins before and nothing.

    i tried what you said with the battery pull but it's still stuck at the lg screen
    Buddlespit likes this.
    02-20-2012 02:05 AM
  22. Buddlespit's Avatar
    is it stuck there with the battery out? You may need to unplug from your computer/wall charger. I'm at a loss now. I'm pretty sure that it's your recovery that's doing you wrong. update.zip has the stock recovery in it, but if you can't fix with kp500 and update.zip isn't working, well.... I'm lost...
    brattt78 likes this.
    02-20-2012 02:10 AM
  23. brattt78's Avatar
    yes, i unplugged the phone before the battery pull but still nothing. i didn't think update.zip had the stock recovery in it. if it does then this doesn't make sense at all...
    well, i'm going to bed, he can live without his phone tonight, i'll start fresh in the am. thanks for trying!
    Buddlespit likes this.
    02-20-2012 02:13 AM
  24. Buddlespit's Avatar
    ok, let's try this.... toggle sig verify to off, flash update.zip, reboot back into recovery, toggle sig verify off again and flash update.zip one more time
    brattt78 likes this.
    02-20-2012 02:15 AM
  25. Buddlespit's Avatar
    good night, and good luck!!!
    brattt78 likes this.
    02-20-2012 02:16 AM
105 123 ...