1. LakeofGlass's Avatar
    Okay, I've tried to find some solution to the wifi issues with the LG Optimus S and Android. It sounds like the new update for 2.3 messed it up, but I can't tell, since I need the wifi to check for a new update.

    I've only had the phone for one day. It's out of the box new. But it doesn't sound like any malfunction with the phone itself, it sounds like the same issues many others have had with this software.

    Only today has it went from working great to the wifi disabling. I'll enable it and it almost immediately shuts off. I can tell it won't connect due to the icon not showing up.

    Now, is there any real solution to this problem? A permanent fix? Even a hard reboot won't work. I've also uninstalled any suspecting apps that may have conflicted but still no result. I'm just really annoyed at this. I don't like knowing I've paid for something that suddenly won't work anymore. I doubt a new phone would make any difference.
    02-23-2012 12:35 AM
  2. eps1lon3's Avatar
    2.3 was indeed a borked update. The official downgrade back to 2.2 would be your best bet if you don't want to root your phone so soon after getting it.

    02-23-2012 01:14 AM
  3. epidenimus's Avatar
    First of all: Welcome to AC and our little corner here! We hope you enjoy your stay and venture into the world of Android.

    This is a bit odd. I'm not ruling out a ZVH issue at all here. It really is hosed. Our devs here have really worked hard to fix the bugs associated with it, but the stock ROM sees none of those patches.

    From a troubleshooting perspective, I do have to ask a couple obvious questions: Is there anything that you have changed or installed recently that may effect this? Did you enable Airplane mode? Do you have wifi configured properly? Has the password for the network somehow been lost (i.e. "forgetting" a network or clearing certain data settings)?

    I have already seen one instance with such behavior and it involved a user using Spare Parts+ and he managed to set his Wifi sleep policy to turn off. However a reboot should allow you to reconnect (until you sleep).

    If all these things check out, why not take it to the store where you got it and let them figure it out?
    02-23-2012 02:45 AM
  4. LakeofGlass's Avatar
    First, this isn't a Sprint phone, but from what I've noticed, both the Sprint version and the Net10 LG Optimus S (LG Optimus Net) seem like clones. The manual for the Sprint version tells me the same features I have on this one. It seems almost identical to the Phoenix my Dad owns. I came here because it seemed like people had the same exact issues with the Optimus from Sprint. I can't get any info on the actual Net10 version, but overall, it's still an Android, It's still an Optimus, and it's doing the same thing.

    This particular phone I ordered & had mailed, so I can't take it to the store. Everything is configured perfectly and none of the current apps have anything to do with Wifi. Even after taking any suspecting apps off, I found out that was never the real case anyway. The only app I had just as it started acting up was a VLC remote. But, it needed to "find" my computer's VLC via wifi so... it wasn't a real issue. If anything, it probably helped me notice there was a problem to begin with.

    I used a wifi fixer (Not Blade Wifi fixer, but one specifically for android phones, period), which helped bring it from completely disabling to constantly reconnecting then disabling until I try to connect it again. It looks more like it's having issues figuring out where the wifi is, lol.

    How exactly would I downgrade to 2.2? Since I can't get it to access the wifi, do I use the developer's software? I have it downloaded because I thought there might be an issue with it reading my SD cards also. I have one that works fine on my old phone but had issues with this one. I tried the brand new one it came with, which worked and then suddenly acted like I had a blank, unformatted card. I'm assuming there's a way via data cable; if it can be debugged that way, that is.

    I'm fairly savvy with technology and I learn fast, so if there's something technical I need to do, just give me a walkthrough to follow and I can probably do it easy enough.

    --Edit-- I meant to ask also: How do I know what ROM I have? I know that technically what I have would be the factory version, but does each one come with either Froyo or whatever "vanilla" version? I know it's possible to change what kind in order to make it run better or fix a buggy version. I just want to know what I'm dealing with so that, in the future, I can know what to do.
    02-23-2012 04:02 AM
  5. drewwalton19216801's Avatar
    You can't downgrade, because you don't really have an Optimus S. The Optimus Net is a close relative to the S but is a different device still.

    Do NOT try to do anything specific to the Optimus S (like flashing the above downgrade zip), you WILL brick your phone.
    02-23-2012 08:24 AM
  6. LakeofGlass's Avatar
    I wasn't going to try that until I knew for sure what I could/couldn't do with it. My gut tells me that no one at the Net10 site would be of any real help since none of them are actual Android/LG developers for this type of phone. I also think that it's so new, no one would have any real fix for this wifi issue yet.

    It doesn't kill me to not have it, since the 3G works fine, but now there are features & apps I'll never get to use. But most of them are probably useless anyway. I'll probably just stick to anything that utilizes BlueTooth. I'm happy with the things that do work, after all.
    02-23-2012 04:43 PM
  7. LakeofGlass's Avatar
    I'm not trying to double post but add to this and bump the thread up for extra help (since no one would see it otherwise).

    I've tried posting on the Net10 forums -- just in case -- but they won't even post my thread. I posted in the appropriate forum, but my gut tells me that since it's more of an Android issue, I won't get my thread posted and I won't get any help.

    If someone knows what I could do with the LG Optimus Net for the wifi issue, let me know. Clearly I can't do anything as Drew said, but if someone has something I can try that won't mess it up, I'd like to know. Anything is worth a shot at this point. I tried a couple more apps that might fix it but they only confirm that my best bet would be downgrading, which of course.... I can't do.
    02-25-2012 04:53 PM
  8. Buddlespit's Avatar
    I just looked at your phone and I can tell you that you have a completely different animal on your hands. Even the wifi is different. Whatever you hear will only be supposition. At this point, I would advise you to contact your sales rep and/or tech support.
    02-25-2012 08:18 PM
  9. Ranji's Avatar
    I've had roughly the same issues with my S. Ever since the push to ZVH, its like the entire phone's gone downhill. Bluetooth randomly drops (if I try to turn it off and on again, it force closes EVERYTHING, forcing me to yank the battery), 3g occasionally drops, necessitating a restart, I can't overclock beyond 729 anymore (back with ZVD and Reborn I could hit 806 and run at it for almost a month, now I'm lucky if I only have to restart/yankbattery my phone 4 times a day), and WiFi absolutely refuses to function. I'm able to connect to the router (and show on active client list), but NO data goes upstream or down.

    I'm due to be getting an upgrade here in the next week or two, and I'm seriously considering the Epic or Epic 2. I hate to leave a phone that I loved for the longest time, but I've had to deal with this for almost 2 months now, and I can't take it anymore.

    That said, as far as the homegrown front goes, which would you all recommend I go to? Granted my recreational use for the phone is primarily reading ebooks and surfing, back on ZVD I loved emulators....
    02-28-2012 03:38 AM
  10. LakeofGlass's Avatar
    Okay! I found the real issue.

    Apparently I could connect to another wifi that was open. It didn't seem to work before, but it does now. How or why? I have no idea. But it won't connect to my home wifi. It's a secured Wifi with a custom name SSID that Cisco gave it, which I can see on the network list. It's WPA2-PSK.

    The thing is, we've reset the wifi a few times, by that I mean A/C reset. Comcast sends a new IP address, which knocks our net off, causing us to reset using the A/C on both the router and that cable internet box. Dumbest thing I've ever known to happen, but it happens.

    So I have successfully updated my phone's software, which I got a push alert for 2 days ago. I'm not sure if anything's changed as far as bugs with apps deleting once they get on the SD card, which I've noted happens to lots of people with Android. I've tested other SD cards and it's the same issue.

    Now, if someone can help me fix this issue with my Wifi being read by my phone, I'll be ever grateful.


    Ranji, your issue was nothing like mine. Mine was only the Wifi connection. Go start a thread on your own because it sounds like you have multiple issues. The phone itself sounds like it was a dud, actually. You're better off asking for a trade, and if that doesn't work, go with one of the phones you're looking at. Look at reviews from others, particularly on Cellphone forums, not official reviews. User word-of-mouth is always best.
    03-08-2012 02:05 PM
  11. garwynn's Avatar

    Not to seem oversimplistic, but if you liked the ZVD and the ZVH baseband is causing so much of a headache, why not downgrade? There are still a lot of great ROMs in dev for ZVD; ZVI may come *one day* but LG doesn't seem too worried about it.

    I believe one of the stickies has the Official Sprint ZVD downgrade. Best of luck whatever you decide!
    03-08-2012 04:45 PM
  12. epidenimus's Avatar
    It sounds as though it's an issue with entering the PSK in the client device incorrectly.
    03-08-2012 04:53 PM
  13. glenesis's Avatar
    Did you try a factory reset?

    03-08-2012 05:17 PM
  14. LakeofGlass's Avatar
    No, I found out that the real issue is that we have an encrypted Cisco router, and it requires using a USB on the computer that needs to use the Wifi. I can't just plug in the USB to the phone. I did see a place on my phone to load encrypted certificates, but I know that isn't the same thing. The phone has Android OS and the key/usb is for PC only, as far as I know.
    03-12-2012 02:01 AM