1. shockdude's Avatar
    Disclaimer: I am not responsible if something goes horribly wrong as a result of you reading this tutorial.

    This is my first tutorial; hopefully I've done everything right.

    So why would anyone want to root ZVJ by downgrading to ZVH instead of ZVD?
    Well, I personally have never downgraded to ZVD as I never upgraded to ZVH, but I do recall that one of the prerequisites for downgrading was to perform a data wipe/factory reset, and that issues would often occur if such a reset was not performed.
    Now recently I needed to root my sister's phone so that she could have more internal storage & install Beta Swype, but she had stock ZVJ and I didn't want to wipe her data by downgrading to ZVD.
    So instead, I downgraded to ZVH, and then used sfhub's automated rooting tool to root ZVH & ZVJ all without wiping data.

    Basically, by downgrading to ZVH instead of ZVD, you don't have to wipe your data when rooting ZVJ!*

    This is assuming that you have stock ZVJ w/ ZVJ recovery; if you have anything else, you're looking at the wrong tutorial

    1. Download stock ZVH (alternate link, be sure to rename "LS670ZVH" as "update"), and copy it onto the root directory of the SD card (i.e. on the card but not in any folders or anything).
    2. Reboot into Recovery (turn off phone, hold down the HOME & VOLUME_UP keys, and hold down the POWER key until the Recovery menu appears) and use the volume keys & the menu key to install update.zip.
    3. Wait about 5-10 minutes for the update to install and for the phone to reboot itself.
    4. Use sfhub's automated rooting tool to root ZVH, and then root ZVJ. Download, install, run Option A, follow the instructions, run Option B, and follow the instructions. More details in the thread. Alternate download link here (thanks vector84an!).
    5. Enjoy!

    If when installing the update.zip the Recovery tells you there is no update.zip, make sure that the file isn't in any folders and that it's actually called "update.zip".
    If installing the update.zip outright fails, then redownload it and try again.

    *If any glitches (i.e. force closes) arise as a result of the downgrade to ZVH, ignore them for now; they should theoretically be gone after reupgrading to ZVJ.
    If you still have glitches after rooting ZVJ, then you should ignore them; after all, you're already rooted and can back up everything and install custom roms and stuff.
    If for whatever reason these glitches cannot be ignored, then you might be one of the unlucky few who has to wipe data in order to properly root ZVJ. Sorry.

    Much thanks to sfhub for the links to the ZVH update.zips and his awesome rooting tool.
    05-22-2012 09:29 PM
  2. uvstr36's Avatar
    10-31-2012 03:54 PM
  3. cole2kb's Avatar
    Stickied, thanks.
    shockdude likes this.
    10-31-2012 04:47 PM
  4. hursta's Avatar
    worked like a charm!
    11-02-2012 10:10 PM
  5. Va1ha11a's Avatar
    Nice writeup!
    11-10-2012 09:07 AM
  6. jerry43812's Avatar
    I love the convenience of forums... pulled out my Optimus that I've had for a couple years now and wanted to re-root it (running stock ZVJ right now) and boom, all the info I need is right here. Thanks!
    12-05-2012 05:25 PM
  7. squashxxxem's Avatar
    I cant find the automated root program. All i have found is optiauto-sfx.exe and it has nothing about rooting zvj. where am i going wrong?
    12-22-2012 07:54 PM
  8. shockdude's Avatar
    I cant find the automated root program. All i have found is optiauto-sfx.exe and it has nothing about rooting zvj. where am i going wrong?
    sounds like you have an older version of optiauto.
    the instructions above contain a link to the thread with the latest optiauto. the download link itself is in step 2 of that thread.
    12-25-2012 11:26 PM
  9. Joshua Rauth's Avatar
    Thanx man. been using my old optimus as a media player for a year now, now i can customize it to my hearts content
    04-30-2013 11:48 PM
  10. Beam Brand's Avatar
    Can't download the rooting package. The links don't work. any ideas?
    06-06-2013 11:06 PM
  11. xpsychotron's Avatar
    Having the same issue. It appears the Rooting package links are dead. Can someone please re-update? Thank you!
    06-28-2013 11:37 PM
  12. shockdude's Avatar
    Vector84an reuploaded the rooting tool, so props to him! Added his download link to the post.
    07-21-2013 01:32 PM
  13. David Oakley1's Avatar
    Im getting an error in the signature. I renamed it to update.zip, and put it in the right area of the sdcard. still not working. any ideas? I tried wiping data and cache still nothing.

    And i tried the ZVD and ZVH so far.
    07-22-2013 06:17 AM
  14. shockdude's Avatar
    How many options do you see in your recovery menu? If you see more than 4 options you already have a custom recovery, and you can go ahead and install custom roms. Otherwise, you have a different issue.
    Try renaming it "update" instead of "update.zip". By default, Windows hides the file extension (the .zip part of update.zip), so if you rename the file "update.zip" you might accidentally be renaming it as "update.zip.zip".
    07-24-2013 12:20 AM
  15. Michael Lautzenheiser's Avatar
    Your links are broken.
    09-12-2013 06:40 AM
  16. vinny16's Avatar
    How do I open the file it won't let me?
    09-23-2013 08:38 PM
  17. agenda21's Avatar
    Thanks for posting this guide, I used it to root my LS670 ZVJ phone. My screen is broken and luckily USB debugging didn't disable itself, probably since I didn't wipe the phone to downgrade ZVH or to upgrade back to ZVJ. I am using droid@screen to view the phone from my computer.

    FYI... Part B->B of the automated script took maybe 6 tries to boot into recovery successfully. It did boot into recovery on the second time but the log from the automated tool said the sd zip access denied while copying and I guess it couldn't write the file that time so I had to do reboot to android and try again several times.
    03-29-2014 09:57 PM