1. klassixx's Avatar
    I know MANY people have got this working on various Froyo devices. I've tried several build versions, and I'm 99% sure that the root of the problem is the libaudioflinger.so file. The stock file must be tweaked for the DSPManager.apk to do anything at all, and any libaudioflinger.so files I find online will either cause the phone to not boot past the Sprint logo, or, if it boots up, the audio ceases to work. (ie., Pandora will just continue to skip through songs).

    I've heard nothing but amazing things about DSP and I'm hoping to get it working on the Optimus! I'm hoping I'm not the only one out there. Any help would be GREATLY appreciated, and I'm no developer by any means, but could it be super difficult to tweak that one file?
    01-15-2011 05:01 AM
  2. lallen's Avatar
    Hi klassix.

    I tried this on my Sprint Optimus, I got the same result that you did.

    What's worse is that I accidentally erased my original libaudioflinger, now I have no sound at all.

    Could you possibly post an original copy of the library? I'd be ever so grateful.
    01-23-2011 03:54 PM
  3. beezy's Avatar
    Hi klassix.

    I tried this on my Sprint Optimus, I got the same result that you did.

    What's worse is that I accidentally erased my original libaudioflinger, now I have no sound at all.

    Could you possibly post an original copy of the library? I'd be ever so grateful.
    Its attached,you'll have to take it out the zip cause can't upload a lib.so file.
    01-23-2011 04:05 PM
LINK TO POST COPIED TO CLIPBOARD