1. farfromuman's Avatar
    I can access files in the system folder and all of its sub folders with ES File Explorer and Android Commander, but the data folder is empty. On my rooted Hero I was able to access all the folders with these programs.
    Using adb shell I can access the data folder and list files but I cannot pull files form it. Pulling from system works fine.

    I am on the stock ROM and rooted.

    Thanks for any tips.
    01-20-2011 04:06 PM
  2. beezy's Avatar
    I can access files in the system folder and all of its sub folders with ES File Explorer and Android Commander, but the data folder is empty. On my rooted Hero I was able to access all the folders with these programs.
    Using adb shell I can access the data folder and list files but I cannot pull files form it. Pulling from system works fine.

    I am on the stock ROM and rooted.

    Thanks for any tips.
    On stock i don't think there is anything in data/app unless you downloaded a sprintid. In command prompt do
    adb shell
    ls /data/ <--does it list anything?

    On stock rom you don't have remount. You could do
    adb devices
    adb pull /data/
    That should pull all the non-protected files from data.
    01-20-2011 04:24 PM
  3. hamagc's Avatar
    on my mostly stock system, my /data is filled with all kinds of goodies, /data/app has all of my apps installed.

    i use root explorer to access this section. weird that adb won't pull it for you. you are using su correct?
    01-20-2011 04:29 PM
  4. farfromuman's Avatar
    I can list files in data, it just will not pull any. All the apps are in the data/app directory. Pulling from System works fine.

    e:\android\sdk\tools>adb pull /data/
    pull: building file list...
    0 files pulled. 0 files skipped.

    # ls /data/
    ls /data/
    tombstones
    anr
    app
    data
    dalvik-cache
    local
    app-private
    disk
    misc
    amit
    dontpanic
    dbcheck
    radio
    backup
    inc_data_path
    property
    system
    lost+found
    #
    01-20-2011 04:50 PM
  5. hamagc's Avatar
    I can list files in data, it just will not pull any. All the apps are in the data/app directory. Pulling from System works fine.

    e:\android\sdk\tools>adb pull /data/
    pull: building file list...
    0 files pulled. 0 files skipped.

    # ls /data/
    ls /data/
    tombstones
    anr
    app
    data
    dalvik-cache
    local
    app-private
    disk
    misc
    amit
    dontpanic
    dbcheck
    radio
    backup
    inc_data_path
    property
    system
    lost+found
    #
    ok try this:

    e:\android\sdk\tools\adb pull /data/app e:\data

    that looks identical to what i just did. only differences are i have adb in my windows folder so i can call it direct, and it's on my c drive.

    adb pull /data/app c:\data\app\
    01-20-2011 04:55 PM
  6. farfromuman's Avatar
    Getting 0 files pulled with the exact command.

    e:\android\sdk\tools\adb pull /data/app e:\data
    01-20-2011 05:03 PM
  7. hamagc's Avatar
    and your positive your rooted? thats the only thing i can think of that would not let you pull these files.

    when i did it, i forgot the \data after c:\ so i ended up with a mess in my c-drive lol.

    but everything pulled without issue. my setup should be the same. stock rom. i do have the oc kernel.
    01-20-2011 05:14 PM
  8. beezy's Avatar
    Getting 0 files pulled with the exact command.

    e:\android\sdk\tools\adb pull /data/app e:\data
    I'm just wondering what you need from data maybe i can pull it for you? I tried to use ES file manager and had the same problem you did. I know there's a way to get it to but i dont' remember how. I personally don't like ES i use root explorer and astro.lol
    01-20-2011 05:19 PM
  9. mrinehart93's Avatar
    just do an "adb pull / C:\pulledapps". That'll get you a dump of your whole phone, minus protected files.
    01-20-2011 06:35 PM
  10. farfromuman's Avatar
    It seems I can now pull the files out of data folder, the only thing that changed is that I installed the ThundeROM 1.6 on top of the stock ROM, quite nice BTW.

    Thanks for all the help.
    01-22-2011 04:22 PM
  11. hamagc's Avatar
    Could this be kernel related?

    Sent from my LS670 using Tapatalk
    01-22-2011 08:46 PM
  12. beezy's Avatar
    Could this be kernel related?

    Sent from my LS670 using Tapatalk
    Nope i just figured it out you have to enable root in ES file explorer then everything in /data/ shows.lol Just a tip i used "hiAPK" you'll know what i mean once you get to it.
    farfromuman likes this.
    01-22-2011 09:19 PM
  13. hamagc's Avatar
    Lol thanks beezy but I meant not being able to adb pull on the data partition

    Sent from my LS670 using Tapatalk
    01-23-2011 12:33 AM
  14. beezy's Avatar
    Lol thanks beezy but I meant not being able to adb pull on the data partition

    Sent from my LS670 using Tapatalk
    It finally hit me how i pulled all the files,sorry it's just been awhile since i had to do this but you have to use this command to mount the system "Rw" instead of 'Ro' (mount -o remount,rw -t yaffs2 /dev/block/mtdblock5 /system) then you should be able to pull /data. Sometime this worn out brain just has to think for a long time.lol

    Edited to reflect the right command
    01-23-2011 02:46 AM
  15. hamagc's Avatar
    huh? why would you need to mount read only to pull? i'm on a stock system with the oc kernel. i didn't have to do anything special to pull. just adb pull /data c:\data.

    the only thing i can think that would be different bewteen me and the op is the kernel. once he flashed to thunderom, it flashed him the oc kernel and he had no problems.

    just a thought. does the stock kernel need to be mounted ro to pull? also i think i pulled it in ubuntu, not windows.
    01-23-2011 03:34 AM
  16. beezy's Avatar
    huh? why would you need to mount read only to pull? i'm on a stock system with the oc kernel. i didn't have to do anything special to pull. just adb pull /data c:\data.

    the only thing i can think that would be different bewteen me and the op is the kernel. once he flashed to thunderom, it flashed him the oc kernel and he had no problems.

    just a thought. does the stock kernel need to be mounted ro to pull? also i think i pulled it in ubuntu, not windows.
    First thing i messed up i went back and edited it.It should be rw not ro.lol. It will work on windows i used windows to pull all my data when i was still running stock non-root.I actually pulled it three different times twice on windows and once with linux.
    01-23-2011 03:43 AM
  17. beezy's Avatar
    We'll know for sure if you can pull with windows on a stock rom with no special commands or anything in about 5minutes, it's driving me nuts wondering so im flipping back to stock to see.lol
    01-23-2011 03:51 AM
  18. hamagc's Avatar
    Lol sorry beezy. Didn't mean to make you go through all this.

    Sent from my LS670 using Tapatalk
    01-23-2011 03:53 AM
  19. beezy's Avatar
    Lol sorry beezy. Didn't mean to make you go through all this.

    Sent from my LS670 using Tapatalk
    Don't worry about it. Im just curious and it's been driving me nuts. Ive done it several times it's not hard at all to flip back to stock and reroot. Its like a personal challenge to myself.lol
    01-23-2011 03:59 AM
  20. beezy's Avatar
    Okay i was able to pull without anything extra.Here's exactly the commands i typed.
    adb devices
    adb remount
    adb pull /data

    I know the first two commands are not needed and remount errors on stock,but it's force of habit. So not sure why op had a problem,might have been he just needed to kill all adb process on the pc and then restart them,but hey we all have something give us problem sooner or later,i know i sure do.lol Glad thats figured out i can sleep good tonight now.

    Edit just wanted to make sure i cleared up that i didn't do adb pull /data c:\data cause i already have sdk in my path so i just cd into a folder i had already made and then did the adb pull /data.
    01-23-2011 04:17 AM
  21. hamagc's Avatar
    Lol thanks for clearing that up for us!

    Sent from my LS670 using Tapatalk
    01-23-2011 04:31 AM
  22. beezy's Avatar
    Lol thanks for clearing that up for us!

    Sent from my LS670 using Tapatalk

    Haha no problem it as a good little challenge.
    01-23-2011 04:51 AM
LINK TO POST COPIED TO CLIPBOARD