1. drewwalton19216801's Avatar
    Kernel/Recovery/ROM developers: Is there an easy way to automate the flashing of ROMS/Kernels/Recovery kernels/Other ZIP files via command line? I looked at using /cache/recovery/command or something like that but it always fails to find the ZIP file.
    03-18-2011 11:54 AM
  2. zefie's Avatar
    Kernel/Recovery/ROM developers: Is there an easy way to automate the flashing of ROMS/Kernels/Recovery kernels/Other ZIP files via command line? I looked at using /cache/recovery/command or something like that but it always fails to find the ZIP file.
    i noticed the new edify based zips extract update-binary to /tmp/update_binary then run something like /tmp/update_binary 2 20 /sdcard/path.zip but everytime I tried it just segfaulted lol. flash a zip and watch the process list try to see if you can figure it out.

    its funny because it wants more and more args

    if you run /tmp/update_binary it says it wants 1 arg
    if you run /tmp/update_binary 2 it says it wants 2 args
    if you run /tmp/update_binary 2 20 it says it wants 3 args
    .. lol
    03-18-2011 12:36 PM
  3. drewwalton19216801's Avatar
    Something must have changed between Xionia 1.2518.4 and 1.2518.6 because now /cache/recovery/command works...sort of.

    Here's the commands that echo the correct arguments to the command file:
    echo 'reboot-recovery' > /cache/recovery/command
    echo '--update_package=SDCARD:Debug-FormatSYSTEM.zip' >> /cache/recovery/command
    echo '--update_package=SDCARD:update-cm-7-03172011-NIGHTLY-thunderc-Xionia-signed.zip' >> /cache/recovery/command
    echo '--update_package=SDCARD:gapps-gb-20110307-signed.zip' >> /cache/recovery/command
    In THEORY this should work just fine when rebooted into recovery, but it ends up only installing the gapps ZIP, leaving me with a rooted VD system that has a bunch of Google apps that don't work.

    I would be willing to go so far as to say that single-ZIP ROMs will work, but ones that require multiple ZIP flashes (CM7 and Lego ROM) won't.

    Am I missing something, or have I found a bug?
    03-18-2011 01:04 PM
LINK TO POST COPIED TO CLIPBOARD