1. nealoc187's Avatar
    I am in Canada halfway through a 6 month work contract. Since data roaming on sprint is expensive, I do not use it up here. I have "Data Roaming" unchecked (off) and "Data Enabled" unchecked (off) and yet every time my phone loses a signal (such as when I was on a sailboat this weekend or when I'm flying in an area with spotty cell coverage) and then reacquires it, the *******ed data roam guard pops up. Why is this thing asking me if I want to roam when I have disabled data roaming, and disabled data entirely?

    When the roam guard pops up, I always hit "Decline". I have tried checking the "Do not Ask Anymore" option on the popup box, and I have tried leaving that box unchecked. It makes no difference.

    I even noticed one time when the box was popped up on my screen (it makes a noise when this box pops up so I become aware of it immediately) that the 3G icon was on very briefly in the notification bar. Again this is with DATA and DATA ROAMING both turned off ( I have only noticed this once, but if I have one cent of data roaming charges on my next bill I will know that something with this phone is overriding my selection to have no data roaming).

    This is really starting to annoy me especially when I'm in a remote area with spotty cell coverage. Sometimes I have this damned box popping up every couple minutes even though Data and Data Roaming have been switched off for months.

    The only thing I can think of is that when the phone is performing whatever procedures it performs when it reacquires a cell signal, is that it performs the check for whether or not you want the "Data Roam Guard" active BEFORE it actually checks to see whether or not you have "Data Roaming" itself enabled. Plausible? Any insights?
    08-22-2011 02:47 PM
  2. mohamadtoha's Avatar
    I have the same problems!. Waiting for the solution. Thanks.
    08-31-2011 01:01 PM
  3. Sdude1200's Avatar
    Its called DATA roaming. So like 3g and 1x data. It isn't the phone signal its self. To avoid roaming like that, go into airplane mode

    Sent from my LG-LS670
    08-31-2011 02:01 PM
  4. hizzoze's Avatar
    Mine as well as my wife's do this too. The problem is, we're not roaming. We're in our house doing nothing. Also, whenever the 3G signal is very weak, WIFI automatically comes on, when we don't want it to. I've tried everything in the settings but it seems as if this is an changeable feature.
    07-03-2012 08:04 PM