1. SylvianDark's Avatar
    Hasn't worked for a few months now. Not sure when it stopped working since I don't use it regularly but I do know that it used to work. I've tried various Roms and Kernels but nothing seems to remedy the situation.

    I've also fiddled with APKs like GPS Test and GPS Status and reset information but nothing seems to make it work again.

    Really annoying since it's convenient having a phone as a GPS. Anyone think there is a way to fix this or is it just actually damaged? Don't remember dropping my phone and I have a protective case anyway.

    If it helps, I'm currently on 10152011-cm7.1.01-IHO-Kraven with kernel 2.6.32.9-v3.11 jlimer@meebo3 #3
    11-07-2011 01:59 PM
  2. apinkel's Avatar
    My gps went out as well. Google nav said searching for GPS all the time and the app GPS status & toolbox could never lock onto satellites

    I took the phone into a corporate sprint store (after returning to stock) where they checked it out I was able to buy a refurb for $35.

    There's been a few others who have reported the same issue.
    11-07-2011 02:37 PM
  3. SylvianDark's Avatar
    Did you have insurance on the phone? I'd definitely pay 35$ to get my GPS back but I don't have insurance on my phone.
    11-07-2011 05:33 PM
  4. epidenimus's Avatar
    I have found that some GPS apps require you to manually turn your location setting to "On" from '911 Only" in order to function. It works just fine then and you can turn it back off when you are done navimagating.

    Also, you might try installing GPS Status, which has a knack for getting it going and some cool tools, too.
    11-08-2011 08:47 AM
  5. thekraven's Avatar
    Try some of the gps fixes in the first post of the cm7 thread. There's a few fixes you can try. Start with gpsfix2 file and clear cache. Try clearing maps data in settings, applications , maps. This would clear problems if you restored maps from titanium b/u or not wiping data before installing. And test outside. Another option is to dirty flash the cm7 file again. So give these a try before doing a full wipe and reinstall
    11-08-2011 10:10 AM
  6. apinkel's Avatar
    Did you have insurance on the phone? I'd definitely pay 35$ to get my GPS back but I don't have insurance on my phone.
    No, I didn't have insurance. $35 is (or at least was) the cost of a refurbed optimus S from the sprint store I went too. I should also mention that the phone has a 1 year mfr warranty... but I would have had to send it in to LG so the $35 was a cheap way of not having to deal with being without a smartphone for a couple weeks.

    btw... obviously do the troubleshooting everyone else is pointing you to. I tried clearing cache, then data, then I did a full reload of stock/unrooted followed by a full wipe, none of which fixed the issue. When I took it into sprint they tried doing a full re-provision of the phone in addition to a full wipe. None of which fixed the issue for me.
    11-08-2011 10:40 AM
  7. SylvianDark's Avatar
    I have found that some GPS apps require you to manually turn your location setting to "On" from '911 Only" in order to function. It works just fine then and you can turn it back off when you are done navimagating.

    Also, you might try installing GPS Status, which has a knack for getting it going and some cool tools, too.
    I tried GPS status and had no luck. I don't see an option to change it to 'on' from '911 only'. Where is that located?
    11-09-2011 05:21 PM
  8. epidenimus's Avatar
    I tried GPS status and had no luck. I don't see an option to change it to 'on' from '911 only'. Where is that located?
    From a home screen:
    Menu (button) ---> Settings ---> Location & Security --> GPS Privacy Setting
    Be sure it says "Location On" instead of "E911 Only" when using GPS apps.
    Also, tick the 'Use GPS satellites' option

    It may take a few seconds or even a minute to get a lock, but when it does, you should see lat/long coordinates when using the GPS Status compass.
    11-09-2011 05:47 PM
  9. SylvianDark's Avatar
    I guess they've deleted the 'gps privacy settings' part of the menu in CM7. Navigated to Location & Security and that option isn't there. 'Use GPS satellites' is ticked.

    I also tried the gpsfix2 and gpsfix3 agps patches and still no connection to satellites. Guess I'll just try to buy a refurb some time or deal with no gps feature.
    11-09-2011 06:32 PM
  10. sonicbluemustang's Avatar
    I was having troubles a while back and when i wiped and installed the kraven cm7 my gps works fine now.
    11-09-2011 07:21 PM
  11. cruiserandmax's Avatar
    Did you have insurance on the phone? I'd definitely pay 35$ to get my GPS back but I don't have insurance on my phone.
    Sprint should sell you a refurb for $35 (or something close to that). With insurance (TEP) they will give you a new handset for free. I have TEP and my GPS also was not working 100% (couldn't get accuracy of better than about a 1 mile ring), and they just replaced it with a new (refurbished?) handset for free.
    11-11-2011 01:27 AM
LINK TO POST COPIED TO CLIPBOARD