1. smmergrl's Avatar
    Can someone help me please?? I have an LG Optimus S. I've had it probably 9 or 10 months? I don't remember right now. So its been fine until the last couple of days. The battery started draining really fast. The charge wouldn't even last all day. So last night I took the battery out for a few minutes & restarted the phone.

    Now the home button does nothing when I push it. The search button does nothing. There is no sound when I get a text message. I haven't got a phone call yet, but probably is silent too.

    I'm either going to cry or throw this phone out the window. Please help?!?!

    Its not rooted. just stock default.
    12-06-2011 03:11 PM
  2. epidenimus's Avatar
    What baseband/software version are you running? ZVD or ZVH? It's under 'About Phone' in the settings menu.
    12-06-2011 03:26 PM
  3. smmergrl's Avatar
    2.2.1

    ZVC
    12-06-2011 03:34 PM
  4. smmergrl's Avatar
    Ok, so for whatever reason the notifications started ringing again. All day they have been silent & now they are working.
    The home button is still not working and that is aggravating. Having to use the back button to get anywhere is annoying.

    How do I fix the home button???
    12-06-2011 03:58 PM
  5. epidenimus's Avatar
    You may have broken the hardware button; I've not yet heard of a software bug that disables just that button, but I suppose it is possible. Have you installed a button mapping app or a custom lock screen app?

    I suggest that you go ahead and root, upgrade to ZVD, and install at least Xionia Recovery. You will gain more stability in the software as a whole.

    Regarding the button:

    It's either hardware or software related. I've read that there are ways to change out the physical buttons on these devices, but that will involve taking your phone apart and possibly soldering.

    A clean install of a ROM or even just a wipe of all the caches may get rid of some setting that is messing it up, but you can't do that without rooting and using a custom recovery. There is also a way to remap the buttons once your device is rooted, so you could make something like your voice search button function like the home button if it really is busted.

    My take on it is either make a warranty claim on it or just void the warranty and see what the device is capable of doing.
    12-06-2011 04:23 PM
  6. smmergrl's Avatar
    The button is not broken, I can use it turn on the screen from the lock screen. Thats the only thing it will do. Also the search button is not working. Which I don't care, but its not.

    The home button is all I want to work. After searching & googling , I see a lot of people had their home button stop working after one of the updates? I didn't update anything. I just pulled the battery out for a few minutes. Also i read they fixed it by rebooting. Well I have powered off the phone multiple time today & it didn't fix it. Maybe I'm not leaving it off long enough?


    I don't have any idea about rooting. I would have to read up on that and have a step by step guide. We'll see. I just want my home button to work again
    12-06-2011 04:32 PM
  7. epidenimus's Avatar
    If
    I can use [the home button] turn on the screen from the lock screen.
    Then this statement is not accurate:
    Now the home button does nothing when I push it. The search button does nothing.
    Now we know that it is something in how the button press is being handled in the software.
    Have you installed any custom launchers or button remapping apps? You wouldn't need to be rooted to do that. Do you have a launcher bar on your homescreen?
    12-06-2011 04:41 PM
  8. smmergrl's Avatar
    Sorry for being inaccurate. The home button does not do what its suppose to do. And the search button does absolutely nothing.

    ADW launcher is what I have always used. I didn't change anything.
    12-06-2011 04:48 PM
  9. epidenimus's Avatar
    Apologies if my tone came off harsh.

    Ok. Have you installed any funky widgets or apps? It would seem that something is not allowing your homescreen/launcher to run properly. What was the last thing you may have installed or changed before it stopped working? Perhaps a setting in ADW? A theme? These things crap out from time to time, but if a reboot didn't fix it, it's most likely an app or setting getting in the way.
    12-06-2011 05:06 PM
  10. epidenimus's Avatar
    I am shooting a little blind here since I don't often run ADW, but you could try clearing the cache and data for ADW under Menu button >> Settings>> Applications >> All tab, pick ADW. This should reset all of your settings to a default ADW install. Reboot afterwards.
    12-06-2011 05:14 PM
  11. hlxanthus's Avatar
    Try hitting the settings button and choose adwsettings>general behaviour>home button binding. Make sure that does not have none selected.
    12-06-2011 05:29 PM
  12. smmergrl's Avatar
    The clear cache button was greyed out. Nothing to be cleared I guess. I forced it closed & rebooted. Same results.

    I actually uninstalled adw earlier this morning & reinstalled to see if it would make it work & it didn't There are no themes currently with it. I have not installed anything new in weeks. I have no idea why this happened.

    Thank you for your help. I know your trying. I just don't know what the solution could be.
    12-06-2011 05:31 PM
  13. smmergrl's Avatar
    Try hitting the settings button and choose adwsettings>general behaviour>home button binding. Make sure that does not have none selected.
    Yeah, one of the first things I tried. I have it set to move to default desktop. Tried all the others also. Still does nothing
    12-06-2011 05:33 PM
  14. hlxanthus's Avatar
    Then try another launcher maybe.
    12-06-2011 05:40 PM
  15. epidenimus's Avatar
    Is it possible that an ADW update broke something? Maybe another app update even?

    I agree with hlxanthus, maybe try another launcher. I'm loving Zeam, but also really liked GO Launcher if that helps. And almost certainly, rooting, recovery and a ZVD ROM would fix all of this. Reborn rules! CM7 comes out of the box with ADW.... Come to the dark side... Punch and pie...

    Seriously, a PITA bug in the stock ROM is what pushed me over the edge. Cookies and beer...
    12-06-2011 05:51 PM
  16. hlxanthus's Avatar
    If nothing else works, a privacy>factory reset would be my last suggestion. Good luck!
    12-06-2011 07:45 PM
  17. smmergrl's Avatar
    I uninstalled ADW. Tried using launcher. same. Tried using zeam still the same.
    I like the icons I had with adw, so I reinstalled that. Everything is working except home/search So I guess I can live with it until I learn how to root. I don't want to have to do a factory reset. Unless anything else goes wrong.

    Thanks to both of you for trying to help. Much appreciated.
    12-06-2011 08:34 PM
LINK TO POST COPIED TO CLIPBOARD