1. BBguy08's Avatar
    I've rooted my phone, installed the custom recovery and cleared all the things it said to clear and loaded ThundeRom. Occasionally when my phone is plugged in and charging just shuts off, I don't actually see it shut off I just see a black screen when I look over and when I hit the lock button it doesn't do anything. Battery is charging. Could it be one of the programs like setCPU causing this any guesses or is it the custom Rom?
    12-08-2010 02:15 AM
  2. BBguy08's Avatar
    Only turns back on after a battery pull.
    12-08-2010 02:15 AM
  3. Nick7's Avatar
    Are you overclocking the phone or do you have a min speed set below 245MHz?
    12-08-2010 02:26 AM
  4. Jerry Hildenbrand's Avatar
    Next time it happens, plug your phone in to a computer and see if you can get a logcat. If so, give it to the ROM developer.
    12-08-2010 02:53 AM
  5. KSmithInNY's Avatar
    This is happening to some phones, stock, rooted, ROMd or otherwise. If you read around the forums there are reports of this happening since the first day or two the phone came out.

    What I saw someone say works best for them is to hit the power button quickly so the buttons light up, then press and hold the power button. The screen will turn on and you'll be looking at the menu to power off your phone. You can just hit the back arrow to leave the menu and be on the home screen.

    Of course, YMMV
    12-08-2010 06:21 AM
  6. v0mitr0n's Avatar
    my first Optimus was doing this, I called Sprint for an exchange.
    So far, the new one hasn't powered off. I've rooted, un-rooted, rooted again and install TBird. All's good
    12-08-2010 08:53 AM
  7. kcmookie's Avatar
    Mine was doing it and I posted below. When I first got my phone it was wanting me to MOUNT/UNMOUNT my SD card. Apparently some of the SD cards sent with the phones aren't working properly. I just bought a 4GM cards yesterday and so far I am not having the problem. To be clear, mine was also shutting itself off (usually when being charged). So far, 24 hours later, changing the SD card seems to be working.
    12-08-2010 11:17 AM
  8. trees_AC's Avatar
    My girlfriends Optimus S is exhibiting the same or similar behavior. Notifications chime in, incoming calls ring but the screen stays black until the battery is removed and reinstalled. The quick power button tap followed by a hold does nothing for us. I don't have another card handy to try. The sprint store is an hour away and I'd rather avoid a new phone setup, customization and a tedious string of app installs.

    Any other suggestions?
    12-16-2010 06:47 PM
  9. trekkie1701c's Avatar
    If you want to test the card theory without another card handy, try removing the card for awhile. If the problem stops, it's likely the card :P

    If it is, they're not too expensive to replace, I'm seeing 4gb cards around $10-15 at the moment.
    12-16-2010 07:23 PM
  10. trees_AC's Avatar
    Good call, I thought of that shortly after my post. I'll let her run without a card for a few days and see how it goes. If all is well I'll reformat the card and test it. If that doesn't work I'll replace the card.

    Thanks for the suggestion.
    12-16-2010 07:38 PM
  11. shortyjacobs's Avatar
    My dad just called me up this very same day, saying my Mom's Optimus S was doing this, (screen black, still chimed with incoming calls, hard buttons lit up, but "screen is dead"). I asked him if he was sure it was a dead screen, he said yes. Went on a five minute rant on how he tried everything to try to make it turn on. He called Sprint, and talked to "a nice indian man" for a half hour, to no avail.

    I go, "Did you pull the battery?"

    "What will that do?"

    He pulled the battery, and back to life. My Mom's phone is totally stock.

    If it happens again, we're gonna get a new one from Sprint.
    12-16-2010 10:30 PM
  12. solodogg's Avatar
    Stock ROM, not rooted, and mine has done this twice now in 1 month. First time was with the samsung sd card that came with it, now this morn was with an 8gb sandisk card that i purchased at Best Buy.

    Rapid push on the power button did not remedy. Alarm still sounded, but the volume keys would not dismiss like normal, but were instead adjusting the ringer volume up and down without the screen powered on. Only fix was to pull the battery and restart.

    We need a fix for this. It's kind of annoying!
    12-17-2010 06:03 AM
  13. Josh43nity's Avatar
    Had the same problem on my S4 mini. Got it solved..

    It happens when the charging pin in the port gets bent. Bend it GENTLY and it should work fine..

    http://forums.androidcentral.com/sam...phone-off.html
    11-21-2013 10:44 AM
  14. Prashant Sharma10's Avatar
    ]I've rooted my phone, amd then after some tim i unroot the phone . now iam facing problem when I plugged charger in then phone just shuts off, I don't actually see it shut off I just see a black screen when I look over and when I hit the lock button it doesn't do anything. Battery is not charging. Now what should I do to overcome this problem ]
    01-05-2016 08:34 AM
LINK TO POST COPIED TO CLIPBOARD