1. kingdavidbaker's Avatar
    I am unable to get either OpenVPN or VPNC to work on my LG Optimus S so I can connect to my work's network which i generally use a cisco client for on my computer. I have rooted the phone and was originally on thuderom however I switch back to my stock rom and installed xionia kernel which includes the tun.ko module. I used lsmod and verfied the module is loaded. I have superuser installed and functioning properly.

    When trying to install VPNC it says my phone is not rooted, does not have superuser access, and does not have the tun.ko module. I have all of these and verified they work so I'm not sure why this is having issues.

    OpenVPN comes much closer and when I view the log I see the following error:

    mountPoint /dev/block/mtdblock5 on /
    system type yaffs2 [relatime, rw]
    /system is already mounted read-write
    copying openvpn to /system/bin/openvpn
    executing 'su -c cp '/sdcard/openvpn.
    mem57168tmp' '/system/bin/openvpn';
    chmod 555 '/system/bin/openvpn
    STDERR: cp: not found
    STDERR: Unable to chmod /system/bin/
    openvpn: No such file or directory
    exit code 10
    making binary executable
    executing 'su -c chmod 555 '/system/bin/
    openvpn"
    STDERR: Unable to chmod /system/bin/
    openvpn: No such file or directory
    exit code 10

    After searching for "cp not found" everyone suggests installing busybox even though I already have it. So I completed the following steps again:

    mount -o remount,rw -t yaffs2 /system /system
    cd /data/local/tmp
    ./busybox cp su /system/bin
    ./busybox cp busybox /system/bin
    cd /system/bin
    chmod 4755 su
    chmod 4755 busybox
    exit
    exit

    The commands work properly without errors but still no luck with the openvpn installer. Then I read that TitaniumBackup installs the latest busybox so I installed that as well and still no luck.

    Any help would be greatly appreciated!
    02-03-2011 12:43 PM
  2. kingdavidbaker's Avatar
    Got OpenVPN to install after installing the BusyBox app found on the market or on appbrain.

    BusyBox - Android app on AppBrain

    Still working on configuring it to work.
    02-03-2011 01:01 PM
  3. apinkel's Avatar
    Check if the directory that busybox resides in is in your system path. Run "echo $PATH" in a terminal. If you don't see the path for busybox in there you'll need to add it using something like "export PATH=<filepath>:PATH".
    02-03-2011 01:07 PM
  4. kingdavidbaker's Avatar
    OpenVPN takes a bit of configuring so I tried VPNC again after installing the BusyBox app from the marketplace and it works perfectly now. VPN is functioning like a dream!
    02-03-2011 01:17 PM
LINK TO POST COPIED TO CLIPBOARD