1. singh4510's Avatar
    i have the revo...trying to root it and it doesnt connect in adb or in my computer ...and it shows some type of error device not succuessfully installed ...i have already installed the drivers for the phone .....how the h*** do i root this f****** thing annoying MAN!!!!!.......TRYED EVERYTHING ....it on android 2.2.2 and i need a root .....i tried the super one click methond and it gets stuck on waiting for device....it doesnt even read in adb......Can someone PLEASE GUIDE ME THROUGH THIS ????
    09-03-2011 10:27 PM
  2. ragnarokx's Avatar
    Welcome to Android Central. I've edited your post as we do not allow profanity. Also, an exceeding number of exclamation points and all caps usually is not a good way to get a response to your thread. And we have a special section for rooting related subjects, which is where I'm moving your thread. Good luck with your problem.
    09-03-2011 11:16 PM
  3. Smitty_82's Avatar
    You prob just need to switch USB ports. ADB will only work on the #1 port on your computer. Try the directions and switch USB ports until you find the one that works. Then use that one for anything in ADB. On a PC it's likely the top port on the back, on a laptop, your guess is as good as mine.
    09-03-2011 11:39 PM
  4. singh4510's Avatar
    i tryed that it didnt work thanks though .............but in my device manager on the computer it comes up as lg android internet device and as a ''!'' mark on it ......i already installed the drivers and it still doesnt see the device
    09-04-2011 01:22 PM
  5. singh4510's Avatar
    by the way what in the world is lg bootstraper ?? it says use that to install drivers but i used the one i found on the lg website
    09-04-2011 01:24 PM
  6. singh4510's Avatar
    so i tryed the adb methond to root my revo lg and it doesnt change from $ to # and i tryed puting the su and it says suermission denied .....nothins working what do i do??
    09-05-2011 10:44 PM
  7. speedtrap63's Avatar
    You probably have the V6 software. To check, go to Settings-About Phone and scroll to SW Version. If it says VS910ZV6 then you can't root. The latest software has blocked root somehow and no exploit has been found to my knowledge.

    You'll just have to wait for the guys at xda developers to finish their CM7 port or for the Gingerbread update like the rest of us. Whenever that is.
    09-06-2011 02:43 PM
  8. laser318's Avatar
    you need to try to update your phone to 2.3.4 which is the gingerbread
    11-09-2011 01:12 PM
  9. ebauman's Avatar
    AFAIK, Android 2.2.2 Froyo cannot be rooted on the LG Revolution. Someone correct me if I'm wrong, but I've tried almost every root method out there, with no success.
    11-24-2011 02:14 PM
LINK TO POST COPIED TO CLIPBOARD