12-14-2012 07:48 PM
37 12
  1. stetsonaw's Avatar
    Remember, I am not at fault if you brick your phone, now, proceed.

    Connect your phone in charge only mode to install the LG Bootstrapper and drivers, or grab the LG Universal Drivers here or here.

    Change your USB Mode to Internet Connection
    Go into Settings/Applications/Development and ensure USB Debugging is turned on
    If all goes according to plan, you should see the ADB Ladybug icon in your notification bar

    I updated the Rootzwiki page with the same info found below.

    Busybox actually comes installed by LG on the Revo, how awesome is that??

    Download the rageagainstthecage binary
    Download the SU binary
    Move these files to the same directory your adb.exe is in.

    The > and # characters below illustrate the prompt 
    you should have, if you have the $ when you go into adb shell, 
    exit out and type 'adb usb' then go back into adb shell and 
    you should see the #
    Open Command prompt (either use the Windows Key+R and type cmd or start/run, then type cmd)
    32-bit users: >cd c:\program files\android\android-sdk\platform-tools
    64-bit users: >cd c:\program files (x86)\android\android-sdk\platform-tools
    Or >cd (whatever directory adb is in)

    >adb devices (verifies you are connected)
    >adb push rageagainstthecage-arm5.bin /data/local/temp/rage
    (if the above command fails due to read-only, type 'adb usb' then 'adb root' to validate root status, then 'adb devices' again to verify connection)
    >adb push su /data/local/temp/su
    >adb shell chmod 777 /data/local/temp/rage
    >adb shell ./data/local/temp/rage
    >adb shell (If this gives you a $ prompt instead of a # prompt, type 'su', if that fails, 'exit', 'adb usb' like above.)
    #mount -o remount,rw -t ext3 /dev/mmcblk0p12 /system
    #busybox cp /data/local/temp/su /system/bin/su
    #chmod 6755 /system/bin/su

    Verify the file is in place w/correct permissions

    #cd /system/bin
    #ls -l *su
    -rwsr-sr-x root root 26248 2011-05-29 01:09 su
    (permissions name access filesize date time filename)

    At this point, you may way to remove the files you put in /data/local/temp (optional):
    #rm /data/local/temp/su
    #rm /data/local/temp/rage

    continue with commands

    Download and install SuperUser from the Market

    Thanks Zennmaster, _mrbirdman_ for finding the linux routes and birdman for helping me out, and droidx8971 for helping me find all the information possible!

    Now go bug XDA to create a Revo forum!
    jackdjr1524, seancojr and Rex126 like this.
    05-29-2011 05:45 PM
  2. chispa9's Avatar
    worked like a charm!! thanks a million!!
    05-30-2011 03:25 PM
  3. tylerdurden53180's Avatar
    used this method and it worked the first time and as far a glitches...so far so good. Hope more rooting support-patches, mods, etc.-are on the way.
    06-05-2011 12:14 AM
  4. CarbonRink's Avatar
    I think this needs top be a sticky!

    Sent from my VS910 4G using Tapatalk
    06-05-2011 12:24 AM
  5. stetsonaw's Avatar
    here is where the spaces are (obv don't type [space], just make a space.
    06-09-2011 06:35 PM
  6. lazarus2297's Avatar
    ok so i got my revo today and i have tried and tried to get this thing rooted via super one click and the windows adb way... when trying to root this way via adb... after i enter adb shell ./data/local/temp/rage and adb restarts my phone will always show device offline and no matter what i do (other than restart the phone which restarts the process) the phone will not show online.. and when i did the adb usb command to start with it never finds the phone and i have to restart the phone again.. someone please tell me i am missing something easy... i have used adb before in rooting my motorola phones so I am not totally new to this...

    when i try and use S1C with either exploit (psneuter, gingerbreak) the program gets to running psnueter, gingerbreak and completely freezes

    I am about to pull what hair i have left out...
    06-10-2011 10:06 PM
  7. stetsonaw's Avatar
    when it doesn't see your phone anymore, try 'adb kill-server' then 'adb start-server' or something like that... look for it in the '?' menu.
    06-11-2011 12:04 AM
  8. smokerjoker420's Avatar
    thank you very much for explaining so well. Used this method. and work awesome. much thanks..... long live the revolution...
    07-06-2011 11:12 AM
  9. stetsonaw's Avatar
    Sure thing man! You can thank Rootzwiki for getting root in the first place!
    07-06-2011 08:18 PM
  10. tigerck127's Avatar
    So after you root, is the change in speed and everything noticeable?
    07-09-2011 03:06 AM
  11. stetsonaw's Avatar
    Rooting just gives you access to the system directories, etc. Custom roms and such help you to speed up the phone.

    Sent from 1885
    07-09-2011 11:00 AM
  12. free_spoons's Avatar
    So I'm getting a weird error, and I can't figure out what I'm going wrong. I've got my abd, rageagainstthecage and su files all together and command prompt pushes rage without a problem. However, when I type "adb push su /data/local/temp/su" I get an error saying "cannot stat 'su' No such file or directory"

    Any ideas?

    figured it out. for some reason my computer didn't like the su file you had for download, but it did fine with the su.zip file from the pinned rooting thread.
    07-11-2011 12:09 AM
  13. stetsonaw's Avatar
    Glad you got it, so are you rooted now with superuser access?
    07-11-2011 01:50 PM
  14. free_spoons's Avatar
    Yup, every thing's going great now

    Also, I don't know if you want to add it, but I just downloaded the LG drivers from here and everything worked after that - http://www.lgforum.com/resources
    07-13-2011 02:28 AM
  15. stetsonaw's Avatar
    adding now, thanks!
    07-13-2011 06:24 AM
  16. Red Five's Avatar
    Long time lurker first time poster.

    So I ran through this process, and I think it worked. Thanks for all your hard work.

    But I think I was having some troubles with the SU folder during the root process.

    However I seem to have successfully downloaded superuser.

    So superuser tried to update and gave me the following error message:

    An error occurred and su was not update. A zip file (su-2.3.1-bin-signed.zip) has been placed on your sdcard , please reboot into recovery mode and flash to update your su binary.

    If launch recovery mode it says it will delete all user settings etc. Is there another way to flash the update without deleting all my settings?
    07-14-2011 10:23 PM
  17. stetsonaw's Avatar
    Open the zip, pull the 'su' file out of the /system/bin folder, and push it just like you did with the original in the steps from the OP. Make sure you also set the permissions on it. the zip here as well so that i can update the OP with it.
    07-14-2011 10:29 PM
  18. speedtrap63's Avatar
    Having an issue that I can't get around. Your procedure goes fine until I type "adb shell" and get the $. I typed "su" and got "permission denied" then exited out and typed "adb usb" which was fine, then "adb root" and got an error "adbd cannot run as root in production builds".

    I am at a loss as to how to proceed. I've tried reinstalling LG drivers, killing and restarting the ADB server, and restarting the Rev.
    08-06-2011 10:34 PM
  19. stetsonaw's Avatar
    When it says adb cannot run as root in production builds, type su, and you should be good. if that doesn't work, reboot both your phone and computer.
    08-06-2011 10:39 PM
  20. speedtrap63's Avatar
    Tried rebooting phone and computer, no good. It gives me the adbd error at the command prompt, not in the adb shell. Trying to run 'su' within the shell it says permission denied.

    Gotta throw in the towel for tonight and get some sleep, long day. If there are any other suggestions of things to try, I'll get on it tomorrow. Thanks in advance!
    08-06-2011 11:19 PM
  21. stetsonaw's Avatar
    within the shell, if it gives you permission denied, exit out of the shell and do adb usb, thenadb shell again.
    08-06-2011 11:25 PM
  22. hackerxx's Avatar
    man!! I tryed everything and still get he same thing too

    .....hummmm perhaps is not leting me do the rooting because of the verizon update?
    08-07-2011 01:58 PM
  23. stetsonaw's Avatar
    08-07-2011 03:41 PM
  24. hackerxx's Avatar
    tried that too...hummmm Ima try another billion times lol....

    .....hummmm perhaps is not leting me do the rooting because of the verizon update?
    08-07-2011 08:13 PM
  25. speedtrap63's Avatar
    within the shell, if it gives you permission denied, exit out of the shell and do adb usb, thenadb shell again.
    Tried this several times and the link you posted as well. None of it works. this doesn't make any sense, unless the Verizon update screwed with some files used in the process. I had root before the update and stupidly applied the update without thinking!

    I also remember having some trouble with rooting the first time, but I eventually got it using ADB.

    What is the process for doing a factory reset on the Rev, that would restore the software to the pre-Verizon update version?
    08-08-2011 08:41 AM
37 12