10-20-2015 11:38 AM
74 123
  1. Neph's Avatar


    I've decided that this should be in it's own thread as it is relevant to most of the work going on right now and should not be buried inside of another thread.

    Here is instructions on how to flash a new firmware. I take no responsibility if your mess up your phone in the process. If you do something wrong, you will brick your phone, especially if it's during the final steps as flashing the cab actually deletes your recovery partition before flashing the new one.

    Tools needed:

    KP500 (http://androidfiles.massivefilehost....s/LG_Tools.zip) - Personally hosted, so please don't hammer the site

    LG Update tool from LG site (LG Mobile Support: Find the Latest Drivers & Product Guides | LG USA)

    .cab file containing your firmware
    3.02 - http://csmg.lgmobile.com:9002/swdata....P58012.R5.cab
    4.04 - http://csmg.lgmobile.com:9002/swdata....P58012.R5.cab
    6.00 - http://csmg.lgmobile.com:9002/swdata....P58013.R5.cab

    Unified Verizon Drivers from LG Site or from your phone. (I went to grab the link from the site, but the Verizon drivers are no longer listed there. Putting your phone into charge only mode will activate a special area of the phone and Windows will show up a new drive containing the USB drivers)

    An Internet connection on the computer you are flashing with. If your fire wall asks if you want to give the LG tool access to the internet, then let it. It will fail to flash otherwise.


    Charge your battery to full, not just 80% or so.

    Run the driver package and let it run its course. Then set phone to Debug mode and make sure all additional drivers install correctly. If you have adb on your PC, you can test your connection buy running ADB shell and seeing if your phone connects correctly

    Go into your Windows Device Manager and disable the device under Modems -> LGE AndroidNet for VZW USB Modem

    Remove your battery and remove your memory card.

    Reboot your phone in "Download Mode" (re-insert your battery and replace the back plate. Hold down vol up + vol down. Plug in usb cable while holding both buttons.)

    I highly recommend using the official cable that came with the phone when doing a flash and not being on and USB hubs.

    Extract KP500 tool into a directory (i.e. C:\KP500)
    Move your .cab file to the same directory

    Run your KP500 file as administrator
    Choose I "Flash with assistance (file .cab)
    Phone Model = VS920
    Input the full path to your cab file including .CAB at the end (i.e. C:\KP500\VS920Z3_02.S3_02.P58012.R5.cab)
    Input the full file name of your cab (aka version) without the Cab (i.e. VS920Z3_02.S3_02.P58012.R5)

    Watch as the LG update tool pops up.

    It will most likely tell you that your phone is disconnected. This is normal and to be expected

    Click Restart.

    It will find your phone and go thru extracting the cab file and then extracting a .bin file.

    At this point if you did something wrong with driver setup or not disabling the modem driver, you will get a page error. If you did it right, you will get a percentage indicator that goes past 15%. Every so often a message will go by about "model dll message not found". This is normal.

    Wait for your phone to finish flashing and let it reboot on its own. I did not do a factory reset and everything came back as it was, but with a new firmware version. You may wish to do a factory reset just to be safe.

    Enjoy the fact that you can now recover your phone if you do something wrong (in most cases)
    02-10-2012 01:37 AM
  2. WaVeS's Avatar
    So what's the next step? Root?
    Let me know if you need any file hosting.
    02-10-2012 09:22 AM
  3. Neph's Avatar
    At this point, this is not a good way to try and inject root. The reason behind this is that during the flashing process the LG update tool first extracts the cab file into 3 files. A dll (instructions for how to flash your connected phone), a wdb (main file) , and a wdh (manifest). From there it extracts the wdb file into a bin file (raw information for your phone). While I have been able to find a suitable file to extract and replace with su in this bin file, I have not found a way to "unhook" the bin from LGupdate and then "rehook" the new file. Attempts to do anything without unhooking the file give you an error message about the file being in use.

    On that note thou, I had started to map out the different files within the 4.04 firmware update. I'm not very far, but I figured if I could map out what files we do know (from the system dump that was done) then we should be able to see the insides of some of the files we don't know about. This may lead to root, but it is still unlikely.
    02-10-2012 09:57 AM
  4. bL33d's Avatar
    damn. well good effort might end in reward. good luck.
    02-10-2012 10:08 AM
  5. WaVeS's Avatar
    Neph, sent you a PM.
    02-10-2012 12:42 PM
  6. kip101's Avatar
    hate to to be a noob but i rooted my phone no problem. but then installed ics launcher , then decided to get rid of it now the phone only boots to the 4glte screen . an ive lost the lg launcher , will flashing this help get back to stock . thanks in advance for any help u can give
    02-22-2012 12:33 AM
  7. Neph's Avatar
    If you can get into "download mode" you should be ok. Just remember to be careful when changing/removing launchers afterwards. Also, if you mess up the flash, your phone is bricked with no repair possible.
    kip101 likes this.
    02-22-2012 12:39 AM
  8. kip101's Avatar
    thanks i will give it a shot . personally ive never used a home launcher before. . did a quick check an can get into dl mode . but i have no way to know about how much battery life i had before
    02-22-2012 08:26 AM
  9. Neph's Avatar
    Pull your battery then replace it. instead of holding down any buttons just insert the usb cable. this will put you in charge mode. you'll be able to tell because a large battery indicator will be on the screen. wait till it stays solid green, no flashing, then try the firmware restore.
    02-22-2012 01:10 PM
  10. kip101's Avatar
    the battery is fully charged . thanks .everything goes good till about 85% then a lg screen pops up an says system update not available an to log on to their site . got no real idea , lol . got the drivers got the cab files moved em over to the tool folder
    02-22-2012 04:55 PM
  11. kip101's Avatar
    disabled modem also
    02-22-2012 04:56 PM
  12. kip101's Avatar
    says cab file error
    02-22-2012 05:48 PM
  13. paulwcarlton's Avatar
    I'm trying this - everything starts but the LG Phone Update window sticks at 25% "Checking for whether the LG PC-Sync program is running" I have the phone in download mode. Pretty sure I've done everything perfect - any suggestions?
    02-22-2012 10:37 PM
  14. Neph's Avatar
    Kip, are you running the LG update tool or running the KP500 loader? I remember that error message well and I only got it when trying to use the LG update tool on it's own. Can you screen shot the final error message or copy the last bit of the log at the bottom of the screen?

    Paul, I do not recommend flashing your phone unless you absolutely need to. This is not something that should be taken lightly as you will brick your phone if you do it wrong. On that note, are you using the official USB cable that came with your phone? That tends to be the biggest hiccup. Also, not disabling the LGmodem under windows will cause issues.
    02-22-2012 11:21 PM
  15. paulwcarlton's Avatar
    After rooting my phone I ran into some problems. I did a factory reset, and now it freezes/reboots over and over at the activation screen. I can't do anything else, or go into any settings. The most I can do is go into download mode, and or the factory reset screen. That doesn't help. Not quite sure what happened here. I'm using the cable that came with the Spectrum. Any thoughts?
    02-23-2012 12:47 AM
  16. Neph's Avatar
    Define "ran into some problems". Also, what are you running that you're at 25% when it starts to check for PC-Sync? Flashing of the phone starts at around 12% which is well past checking for sync.
    02-23-2012 01:14 AM
  17. Neph's Avatar
    Ok, so I just tried the flash program again to try and find your error message, and apparently having root on the phone changes the game a little, but in a good way. I was actually in the OS and ran the tool with debugging enabled. I've never had it go straight into Download Mode from this screen, but some how it threw an SU command at the phone and did it.

    Any ways, here are screen shots of exactly how your setup should be when you run the KP500 software, keeping in mind that I am flashing 3.02 in this example.

    If you did it right, the second screen will come up. Notice at the bottom of the window it says _IsConenctedPhone . If you have a 1 or a 2 there you're computer sees your phone. If you have a 0, it does not. This is either because you are running off of a front USB port on your PC or you are using a bad cable or you did not install your drivers correctly. No matter what the situation, you need to get the LG tool to be able to see your phone.

    Once it sees your phone, let it work it's magic. If you get a page fault, you forgot to disable the LG modem driver in windows.
    02-23-2012 01:33 AM
  18. jayyftw's Avatar
    I have no idea how I ended up logging in as PaulwCarlton but this has been me posting. Here's the log from KP500 and the LG Phone update is stopped at 25% Saying "Checking for whether the LG PC-Sync program is running"

    12:24:54 : [C:\LGMobileUpgrade] 디렉토리 삭제 시도
    12:24:54 : RemoveDirectory1 Error(2):C:\LGMobileUpgrade
    12:24:54 : Start Date : 2012-02-23 12:24:54
    12:24:54 : -------- Buyer Test mode ---------
    12:24:54 : [C:\ProgramData\LGMOBILEAX\Phone] 디렉토리 삭제 시도
    12:24:54 : RemoveDirectory1 Error(2):C:\ProgramData\LGMOBILEAX\Phone
    12:24:54 : *****CheckOS Start********
    12:24:54 : Microsoft_Windows_Vista Home Edition_
    12:24:54 : *****CheckPCSyncPrograms Start*****
    12:24:55 : PCSyncPrograms Not Found
    12:24:55 : SetEmerModeAT()
    12:24:55 : _IsConnectedPhone Call
    12:25:13 : _IsConnectedPhone(1)
    12:25:13 : 0 - NotConnected.
    12:25:13 : 1 - Normal connect success
    12:25:13 : 2 - Emergency connect success
    02-23-2012 12:27 PM
  19. Neph's Avatar
    Ok, by the logs the prigram is seeing the phone but it does not appear thatt you are in download mode when it is happening. i find that had to believe thou and think that your system is givin g a false reading. typically at that stage a window should pop up saying you phone is not connected(restart or quit). you need to click restart when that happens. it will scan for your phone again and find it this time. it will then read your phone id and flash the firmware. let me know if this works for you.
    02-23-2012 01:27 PM
  20. jayyftw's Avatar
    13:57:45 : [C:\LGMobileUpgrade] 디렉토리 삭제 시도
    13:57:45 : RemoveDirectory1 Error(2):C:\LGMobileUpgrade
    13:57:45 : Start Date : 2012-02-23 13:57:45
    13:57:45 : -------- Buyer Test mode ---------
    13:57:45 : [C:\ProgramData\LGMOBILEAX\Phone] 디렉토리 삭제 시도
    13:57:45 : RemoveDirectory1 Error(2):C:\ProgramData\LGMOBILEAX\Phone
    13:57:45 : *****CheckOS Start********
    13:57:45 : Microsoft_Windows_Vista Home Edition_
    13:57:45 : *****CheckPCSyncPrograms Start*****
    13:57:45 : PCSyncPrograms Not Found
    13:57:45 : SetEmerModeAT()
    13:57:45 : _IsConnectedPhone Call
    13:58:20 : _IsConnectedPhone(1)
    13:58:20 : 0 - NotConnected.
    13:58:20 : 1 - Normal connect success
    13:58:20 : 2 - Emergency connect success
    13:58:36 : Checking the connection with the cell phone...
    13:58:36 : dwWaitResetTime(40000 ms)
    13:58:37 : Phone Mode(1)
    13:58:37 : *****GetPhoneType Start*****

    It stops at 30% now. "Checking the connection within the cell phone"

    It won't go any further than this. if I unplug again it brings up the "emergency connect" window which promps for the IMEI and Serial number. After putting these in another prompt comes in asking me to "Input File URL" Anymore thoughts?

    I'm honestly just thinking of going to the Verizon corporate store and trying like hell to play dumb and see if I can just get a replacement. Hopefully they can't tell it was rooted at all, it's only been 3 days since I've had the phone lol.
    02-23-2012 02:02 PM
  21. Neph's Avatar
    At this point it may be you best bet. they should be able to flash your firmware which automaticly removes root. just tell them that you accepted an ota update andd now it wont reboot right. if possible don not go to the same store you bought from especially if they applied the v4 update in store like they did for me.
    02-23-2012 04:15 PM
  22. Neph's Avatar
    On another note, if it is asking for a url, try putting in the link for the cab file from verizons site. It may be trying to pull the cab file down itself. i say this because i had to use a tool that asked for my serial and imei to get the link to the cab in the first place.
    02-23-2012 04:18 PM
  23. jayyftw's Avatar
    After searching Verizon for the last half hour I can't see a link anywhere with the .cab file. I figure tomorrow I'll head to the store. Appreciate all the help! I'll be a bit more careful next time after rooting.
    02-23-2012 05:03 PM
  24. Neph's Avatar
    Sorry, that should have been the lgmobile site, not verizon.

    EDIT : I'm a noob and should have been suggesting you flash 3.02 all this time.

    Here is the link for 3.02

    02-23-2012 10:29 PM
  25. Neph's Avatar
    Grand... 4.04 no longer flashes for me. 3.02 flashes just fine. Try downloading 3.02 and flashing it using the instructions you have figured out so far. I have a feeling that is going to be your glitch that I was not seeing. I've been using 3.02 all this time and never had this many issues.
    02-23-2012 10:32 PM
74 123