1. ansa82's Avatar
    My wifi speeds are good, but all of a sudden google is stuck again, any search goes 1/4 of the way and just sits there taking forever. I've cleared cache with no luck...also reset my modem even though speedtest is saying average 124. Ive also forgotten my wifi and reset it up again, is there anything else I can do??

    Posted via the Android Central App
    04-13-2016 04:21 PM
  2. Rukbat's Avatar
    Check exactly the same sites with a computer. It can be "getting stuck" in the phone, the router, the modem or further down the line. Make sure you have a good "non-stuck" path at least as far as the router. If a computer also gets stuck, it's not the phone, it's probably some backbone common to all the sites you're getting stuck at. (124mbps to a server near your provider doesn't mean 124mbps to a server across the country.)
    04-13-2016 04:56 PM
  3. ansa82's Avatar
    Check exactly the same sites with a computer. It can be "getting stuck" in the phone, the router, the modem or further down the line. Make sure you have a good "non-stuck" path at least as far as the router. If a computer also gets stuck, it's not the phone, it's probably some backbone common to all the sites you're getting stuck at. (124mbps to a server near your provider doesn't mean 124mbps to a server across the country.)
    Ok thanks!

    Posted via the Android Central App
    04-13-2016 08:21 PM

Similar Threads

  1. Replies: 1
    Last Post: 04-14-2016, 02:24 AM
  2. Replies: 2
    Last Post: 04-13-2016, 05:02 PM
  3. Replies: 1
    Last Post: 04-13-2016, 04:58 PM
  4. Emoji clicking noise won't turn off, how can i get it off?
    By AC Question in forum General Help and How To
    Replies: 2
    Last Post: 04-13-2016, 03:33 PM
  5. Galaxy S4 Google Play edition LED setting missing?
    By AC Question in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 04-13-2016, 03:17 PM
LINK TO POST COPIED TO CLIPBOARD