1. AC Question's Avatar
    Recently the clock alarm screen does not pop up when the alarm rings, even if it's a puzzle alarm I need to interact with to turn off. The only way I can get the screen to pop up is to scroll through my notifications, find the one for the alarm that's ringing, and touch the notification. Now the alarm displays on the screen.

    Do Not Disturb is OFF.

    I notice that in Settings/Apps the Clock notification says "Silenced / Do Not Disturb Override" but I think this pertains to the alarm sound, and my alarms do sound. They just don't *show*.

    Ideas?

    LG V20
    Android 7.0
    08-15-2017 05:49 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Moved from the Nougat forum to the V20 forum. Are you using the stock Clock app, or a 3rd party alarm clock app?
    08-15-2017 01:38 PM
  3. kazar's Avatar
    Welcome to Android Central! Moved from the Nougat forum to the V20 forum. Are you using the stock Clock app, or a 3rd party alarm clock app?
    Hi B Diddy -- I am the OP now signed up for the forum so I could reply. I am using the stock Clock app. The alarm screen with the, sleep and dismiss options does not pop up whether phone is locked or unlocked, whether the screen is sleeping or awake, and regardless of alarm settings (puzzle?, sleep option, etc).

    I just shut one off a few minutes ago when my wake-up alarm rang -- I have to unlock phone, swipe notification list down, locate the Alarm notification among a dozen or more others and tap it. Then the Alarm screen pops up with whatever sleep/dismiss, puzzle and text options. So it's a double-puzzle :-)

    This is not worth a factory reset, because of the time it would take me to get all settings, preferences, apps and home screens back that way I want them, but I was just curious if anyone could help me solve without a full reset. I did some web searches looking for an answer but so far nothing that seems to apply.

    thanks for your reply
    08-18-2017 06:40 AM
  4. SupraLB's Avatar
    You need to turn that notification back on in the app's settings, as you describe in first post. Thats preventing it. Same thing happened to me a few weeks ago. I believe I had mistakenly turned the notification setting off, because it gives you that option by holding it down.
    08-18-2017 10:57 AM
  5. kazar's Avatar
    You need to turn that notification back on in the app's settings, as you describe in first post. Thats preventing it. Same thing happened to me a few weeks ago. I believe I had mistakenly turned the notification setting off, because it gives you that option by holding it down.
    Thanks, SupraLB, but I can't figure out how to change that setting. When I go into:
    Settings/General/Apps/Clock/Notifications this is all that's available (this forum's image upload doesn't work on my Mac/Chrome Browser):

    Show Silently -- turned OFF
    Don't make sound, vibrate, or peek these notifications into view on the current screen
    On the lock screen
    Hide sensitive only

    In spite of the "Show Silently" option being OFF, when I return to the Apps list, Clock still says "Silenced / Do Not Disturb Override". So where do I change that if not in Apps/Clock/Notifications?
    08-18-2017 11:32 AM
  6. IHateMyTreo's Avatar
    Same problem here. I gave up trying to fix it and installed another alarm clock app, which works OK.

    Supra, can you be more specific on your fix? For my stock clock app, in the app settings menu, there are only options for (i) snooze or stop, (ii) volume key behavior, or (iii) puzzle lock type. Nothing to hold down to change settings or notifications.

    If I go to general phone notification settings, it is set to show all notifications on the lock screen.
    kazar likes this.
    08-18-2017 11:37 AM
  7. SupraLB's Avatar
    Thanks, SupraLB, but I can't figure out how to change that setting. When I go into:
    Settings/General/Apps/Clock/Notifications this is all that's available (this forum's image upload doesn't work on my Mac/Chrome Browser):

    Show Silently -- turned OFF
    Don't make sound, vibrate, or peek these notifications into view on the current screen
    On the lock screen
    Hide sensitive only

    In spite of the "Show Silently" option being OFF, when I return to the Apps list, Clock still says "Silenced / Do Not Disturb Override". So where do I change that if not in Apps/Clock/Notifications?

    Change the "On the lock screen" to Show all Notifications. That should be it.
    below is mine.

    you should also see that little clock icon at the top (if you have an alarm set).

    Android 7.0 alarm screen does not display-phone.jpg
    08-18-2017 03:50 PM
  8. SupraLB's Avatar
    Same problem here. I gave up trying to fix it and installed another alarm clock app, which works OK.

    Supra, can you be more specific on your fix? For my stock clock app, in the app settings menu, there are only options for (i) snooze or stop, (ii) volume key behavior, or (iii) puzzle lock type. Nothing to hold down to change settings or notifications.

    If I go to general phone notification settings, it is set to show all notifications on the lock screen.
    Don't go through the Clock settings from the clock app. Instead, go Settings > Sound & Notification > Apps > Clock. Then make sure On the Lock Screen is sets to Show All Notifications.
    08-18-2017 03:55 PM
  9. IHateMyTreo's Avatar
    that's how mine is set under the general notifications settings. still not working.
    08-18-2017 06:11 PM
  10. Niv77's Avatar
    This happened to just recently. I entered safe mode and found out that it's an app that I downloaded that's messing with it.
    so I uninstalled the app and now works fine.
    08-19-2017 01:48 AM
  11. IHateMyTreo's Avatar
    which app?
    08-19-2017 11:08 AM
  12. MiniTux's Avatar
    I'm having the exact same issue! Did you ever fix it? I'm going crazy! I've tried turning on the "show silently" then a power off and restart. then turning it back off and doing another power off and restart. Nothing works. No matter what I do, this is all I get.

    Android 7.0 alarm screen does not display-capture-_2017-09-14-10-23-47.png
    Attached Thumbnails Android 7.0 alarm screen does not display-capture-_2017-09-14-10-23-21.png  
    09-14-2017 10:30 AM
  13. MiniTux's Avatar
    After what seems like forever, I found the setting to fix this stupid issue! Its hidden! I tried the settings for it in the normal places and none of them worked.

    1) Pull down your notification panel
    2) Long press on your alarm notification
    3) Select "Don't silence"
    4) Select "Done"

    Whew. What a pain in the rear that was!
    Attached Thumbnails Android 7.0 alarm screen does not display-18177.jpg  
    10-25-2017 05:42 AM
  14. generic-user's Avatar
    I checked all my settings and they looked correct. So I went into Safe Mode to check for conflicting apps. It worked fine in Safe Mode so I restarted ready to start uninstalling apps. I tested again before uninstalls and it started working again. FWIW.

    EDIT: Well, that didn't last long. It worked the rest of the day but not this morning. I uninstalled a couple recent apps, went into safe mode, restarted. The only other things I remember doing from when this last worked was 1) start Android Auto and 2) clean up my app library. I also noticed that Smart Lock is not working with my 1 location. This is so frustrating.
    04-11-2018 09:25 AM
  15. David Sanchez7's Avatar
    Recently the clock alarm screen does not pop up when the alarm rings, even if it's a puzzle alarm I need to interact with to turn off. The only way I can get the screen to pop up is to scroll through my notifications, find the one for the alarm that's ringing, and touch the notification. Now the alarm displays on the screen.

    Do Not Disturb is OFF.

    I notice that in Settings/Apps the Clock notification says "Silenced / Do Not Disturb Override" but I think this pertains to the alarm sound, and my alarms do sound. They just don't *show*.

    Ideas?

    LG V20
    Android 7.0
    06-25-2018 10:56 AM
  16. David Sanchez7's Avatar
    I toggled the show all notification, tested it and it worked, sent a text to myself and it showed as well. switched back to "hide sensitive only" and it seemed to have resolved the problem - hope that helps
    06-25-2018 11:00 AM

Similar Threads

  1. Does the smaller port on usb 3.0 works for charging purposes?
    By AC Question in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 08-17-2017, 08:55 AM
  2. whole screen refreshing every minute.
    By AC Question in forum Android Auto
    Replies: 4
    Last Post: 08-16-2017, 11:21 AM
  3. Replies: 1
    Last Post: 08-15-2017, 01:45 PM
  4. Android gets mute
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-15-2017, 01:40 PM
  5. Honor 8 home screen style
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-15-2017, 05:02 AM
LINK TO POST COPIED TO CLIPBOARD