1. Alpha Wolf's Avatar
    LG V20 Phone just won't show up on PC when connecting with USB.
    I have 2, V20's, on one of them when I drag the settings menu down the USB charging shows up but there is no way to change it from charge to transfer.
    On my other V 20 the USB does not show up at all anywhere.
    Android 8.0.0 up to date.
    11-08-2019 05:27 AM
  2. Galactic Zoo's Avatar
    1. Make sure you have the appropriate drivers installed on your PC
    2. You'll need to turn on the Developer Option and then scroll down to Select USB Configuration > MTP > ok
    Laura Knotek likes this.
    11-08-2019 08:02 AM
  3. B. Diddy's Avatar
    Welcome to Android Central! Have you tried a different USB cable? On the phone where you see the USB notification in the notification panel, what happens if you tap it?
    11-08-2019 12:59 PM
  4. Mooncatt's Avatar
    Have you tried rebooting the computer? I had almost this same thing happen last night during a large file transfer. The transfer got hung up, so I cancelled it, which then gave me an error pop-up on the phone and it no longer was detected by my laptop. Rebooting both the phone and computer got it going again.

    This is also a prime example of why you should always copy and paste when transferring files. This is what I do, so no info was lost. I say this because we get a lot of questions about recovering lost data due to a corrupted "move" function.
    11-10-2019 10:24 AM
  5. Alpha Wolf's Avatar
    I tried rebooting with no luck. I grabbed the LG phone suite, no luck.
    Galactic Zoo, suggest turn on the Developer Option and then scroll down to Select USB Configuration > MTP > ok
    You do mean on the PC correct, or is that on the phone, and do you mean administrator rather then developer?
    Thanks for the suggestions everyone.
    11-11-2019 03:51 AM
  6. Mooncatt's Avatar
    I tried rebooting with no luck. I grabbed the LG phone suite, no luck.
    Galactic Zoo, suggest turn on the Developer Option and then scroll down to Select USB Configuration > MTP > ok
    You do mean on the PC correct, or is that on the phone, and do you mean administrator rather then developer?
    Thanks for the suggestions everyone.
    Sorry the PC reboot didn't help.

    What Galactic Zoo was referring to is on the phone. It sounds like you're not familiar with the developer options, so I'll start from scratch.

    Go into the phone's settings menu, then select system > about phone > software info, then tap on the "build number" box repeatedly. After about 7 taps, you'll get a notice to the effect of "you're now a developer." Now back out to the system menu and you'll see the new developer options. Go into that and scroll down to the networking section. Select the "select USB configuration" option and switch it to MTP (Media Transfer Protocol).

    Assuming the phone even recognizes that it's being plugged into a computer and vice versa, this should default it to the ability to transfer files. If you are still having issues, then I would suspect a hardware problem preventing the phone and computer from recognizing each other. At this point I'd look at trying a new cable and making sure the ports are good.
    Laura Knotek and Galactic Zoo like this.
    11-11-2019 01:21 PM

Similar Threads

  1. Flashing Upload to Cloud icon on notification bar?
    By Tiana_watts in forum General Help and How To
    Replies: 2
    Last Post: 11-08-2019, 01:07 PM
  2. How to screen cast from one android device to another without wifi
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-08-2019, 12:54 PM
  3. Replies: 1
    Last Post: 11-08-2019, 02:11 AM
  4. When I try to upload pictures from my S9+, there is no Instagram option.
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 11-07-2019, 11:46 PM
LINK TO POST COPIED TO CLIPBOARD