1. robert1523's Avatar
    Hi,

    I recently purchased a sealed LGv20 in UK. I noticed that it was set up for AT&T so probably the seller had it from US. The phone worked just fine with my UK sim card so it was not locked.
    I rooted the phone and went through all the steps successfully and ended up with the V10r firmware.
    All was working fine however I had no network access. I tried adding the APN settings of Virgin Uk that I found online and nothing happened.

    When I go into settings--> network it says
    Service state: radio OFF
    Mobile Network state: Disconnected



    I tried flashing the initial modems with the command "fastboot flash modem modem" and I get error: cannot load 'modem'

    This is the first time I rooted a phone so I am new at this. All works perfect except the network so basically I ended up with a nice media player . I have been trying to find a solution for the last 2 days. If someone can point me in the right direction I would greatly appreciate it.
    12-12-2019 02:40 PM
  2. Mooncatt's Avatar
    From what I've dabbled in when rooting, the steps can be highly specific for each model. For example, the root method for an unlocked V20 may not work for an AT&T V20. So the first thing I'd do is make sure you used the right how-to and files. The XDA forums are more technically minded than here, so I'd suggest digging around there for info, including how to undo what you have done so you can start over.

    In the off chance you used a rooting app (aka one click rooting) with something like Kingroot, I'd first suggest you research how to undo that, even if it means flashing the OEM firmware. Those apps are known to install malware while doing their thing. Because it's working at the system level, it can bury stuff deeper than your average attack and be almost impossible to remove. Even un-rooting can leave the malware intact.
    12-12-2019 03:04 PM
  3. Rukbat's Avatar
    Did you follow the steps in this thread? If not, flash the stock AT&T ROM, then follow the steps in that thread.

    Any further questions should go to runningnak3d in that thread.
    aximtreo likes this.
    12-12-2019 03:04 PM
  4. robert1523's Avatar
    Hi. I will answer to both of you here. I actually followed the same post to root There were a couple of people there with similar problems however the solutions offered did not work and at this moment I have a lot of info in my head which is starting to become clutered.

    Later edit. I think I managed to solve it. I tried flashing the modem again and this time I flashed some additional files and have also written them differently. All 5 files were a copy from the dump folder and added into the adb folder

    fastboot flash fsg fsg_COM21
    fastboot flash misc misc_COM21 this was new and I did not try it initially
    fastboot flash modem modem_COM21
    fastboot flash modemst1 modemst1_COM21
    fastboot flash modemst2 modemst2_COM21
    12-12-2019 03:23 PM
  5. B. Diddy's Avatar
    I moved this from the More LG Phones forum to the V20 Rooting/ROMs forum for more specific traffic.
    12-12-2019 06:05 PM

Similar Threads

  1. ASUS Chromebit CS10 - No sound via HDMI
    By SJMaye in forum ASUS Chromebooks
    Replies: 7
    Last Post: 12-14-2019, 02:38 PM
  2. Replies: 7
    Last Post: 12-13-2019, 08:29 PM
  3. Did I make mistake in trying to root my tablet
    By Android Central Question in forum Ask a Question
    Replies: 4
    Last Post: 12-12-2019, 05:05 PM
  4. Can you track a stolen device after it has been factory reset?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 12-12-2019, 12:34 PM
  5. Replies: 1
    Last Post: 12-12-2019, 05:22 AM
LINK TO POST COPIED TO CLIPBOARD