1. Android Central Question's Avatar
    Hello,

    I have an LG V30+ US998. I have updated the software to android 9 via LG UP. Now it's stuck on logo "LG V30+ ThinQ". I tried power off (power and volume down pressed for 10 seconds). The logo disapears and for 5 seconds I have a circle and under the circle it's written "erasing". After 5 seconds the logo appears again and the phone is stuck on the logo again. Any help would be appreciated. Thank you.
    07-13-2020 06:13 PM
  2. mustang7757's Avatar
    Try factory reset in recovery

    I'll leave a Link to register so you can communicate here as a guest account you can only post questions but can't reply.https://forums.androidcentral.com/sh...d.php?t=409154
    07-13-2020 06:45 PM
  3. BergerKing's Avatar
    [Thread moved to LG V30 subforum.]
    07-13-2020 07:19 PM
  4. laureion's Avatar
    Hi,

    The phone doesn't allow me to enter recovery mode.
    07-13-2020 08:39 PM
  5. mustang7757's Avatar
    Hi,

    The phone doesn't allow me to enter recovery mode.
    Hi welcome!
    Then you'll need to go to a repair center .
    07-13-2020 09:03 PM
  6. B. Diddy's Avatar
    Welcome to Android Central! Are you able to use LG Bridge to reinstall the firmware? https://www.lg.com/us/support/help-l...-1438110404543
    07-13-2020 09:10 PM
  7. laureion's Avatar
    LG Bridge says no mobile device connected.
    07-14-2020 02:21 AM
  8. laureion's Avatar
    I solved it by pressing volume down while connecting to USB and the phone ran into update software mode. After that LG UP recognized my phone and I used it to downgrade back to Android 7 official software.
    tube517, B. Diddy and ManiacJoe like this.
    07-14-2020 05:02 AM
  9. B. Diddy's Avatar
    Great! I'm glad you figured it out.
    07-14-2020 10:47 AM

Similar Threads

  1. US Unlocked S20 Ultra extremely slow to Send Email on AT&T LTE.
    By DUTCH VanAtlanta in forum Samsung Galaxy S20 & S20+ & S20 Ultra
    Replies: 22
    Last Post: 07-24-2020, 06:59 AM
  2. Can't transfer files from Redmi 7a to PC, freezes up, causes other errors.
    By RogellParadox in forum Xiaomi Android Phones
    Replies: 8
    Last Post: 07-21-2020, 05:50 PM
  3. I have LG Stylo 4, my USB tethering option on the phone is grayed out?
    By Android Central Question in forum LG Stylo 4
    Replies: 4
    Last Post: 07-13-2020, 09:20 PM
  4. Replies: 2
    Last Post: 07-13-2020, 05:58 PM
  5. LG Stylo 6 Camera not playing well with RSA Token App.
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 07-13-2020, 05:47 PM
LINK TO POST COPIED TO CLIPBOARD