1. Robert Bree's Avatar
    I have tried the Root With Restore By Binary v 31. Followed all instructions. I have the drivers and it does not work.

    Heres my phone Software information
    Help Rooting LG VIPER 4g LTE-2013-10-12-11-02-31.jpg

    Heres what happens when i try root
    Help Rooting LG VIPER 4g LTE-cmd-root.png

    Please help. it keeps saying im rooted but im not
    10-12-2013 12:15 PM
  2. Robert Bree's Avatar
    ?self Bump.... Anybody?
    10-12-2013 02:17 PM
  3. troark97's Avatar
    Root zvi and use voodoo ota rootkeep to get zvk rooted

    Sent from my LG-LS840 using AC Forums mobile app
    10-12-2013 02:25 PM
  4. Robert Bree's Avatar
    So downgrade to zvi?

    Posted via Android Central App
    10-12-2013 10:50 PM
  5. troark97's Avatar
    Yeah. No root method for zvk so far besides using voodoo or superuser

    Sent from my LG-LS840 using AC Forums mobile app
    10-12-2013 11:02 PM
  6. miribus's Avatar
    So, after a long battle, and many forum searches I finally compiled all the information together to actually successfully root the LS840.
    The short answer is, Bin4ry's script for Windows (and presumably Linux) does work, what isn't as clear is that it doesn't work on the latest firmware. This thread points it out, and this is the most recent posted thread regarding the subject anyway.
    I don't take credit for this and if I'm forgetting someone I apologize in advance. This post is simply to be a one-source location to pull together the bits and pieces to successfully root this damn thing while opening as few tabs as possible

    1.) Confirm your firmware: About Phone -> Software Information -> Software Version: If the last letters are ZVK, and if you've had nothing but trouble up until now, it probably is... you have to flash to something older. ZVI for example. If you have ZVD or ZVI... jump to the "rooting" step.
    2.) Flashing to old firmware: This is the post I saw about it & used. It's just about dead on but misses some key pieces of information. Also, some of the links didn't work, but as a guide it is accurate, it filled in the missing piece, but left out where to find the .dll, and puts how to use it a bit out of order as the first thing the LG Flash Tool will ask you is to input that info.... anyway, here we go.
    So thanks to LG, nOve and TJ Sanders for sharing/finding all of this.
    3.) Download the ZVI firmware (It's the ICS directly before ZVK, and rootable): The link in this post, has a working link to the ZVI:
    Official Stock LG Viper 4G Firmware / Rom / Flash File - LG Cell Phones Blog
    4.) Download the .DLL firmware for the LS840, thanks to user "lg-phones" for hosting this... I don't know what post this links from because I had to do a "LS840 viper .dll" for google and this came up.... Thanks "http://www.lg-phones.org/"
    5.) Download the LGFlashTool, I used the link from TJSander's post above. Install it, and copy the .exe from the root directory into the C:\LG\LGFlashTool\ directory, it will break the login and authentication requirements.
    6.) Flashing to old firmware:
    Follow the instructions on the post in step 2, the only thing to point out is that the FlashTool will ask for the .DLL and firmware as soon as you open it. Point the .DLL box to the .DLL file, and point the "software" box to the .tot file in the "ZVI" .zip file. Read the post carefully, it works.

    7.) Rooting the phone.
    Now that you have the ZVI firmware installed (confirm it! you can root it. I found that Superoneclick 2.3.3 & rageagainstthecage exploit didn't work.
    I'm using Win7-64bit Home Premium, and Norton Internet Security Suite (Comcast) and disabled it, but still didn't work... thankfully Bin4ry's "runme" .bat file does work if you mod it slightly to fit your environment.
    8.) Download Bin4ry's script, links & directions in this post: http://forums.androidcentral.com/lg-...-root-xda.html
    Thanks Bin4ry!... note the version I used was ultimately found here: root_with_restore_by_bin4ry_v31 - Download - 4shared - Herry Setyadi
    Thanks to "Herry S." for hosting the file (that I downloaded via google search for the filename)
    Specifically, you want: Root_with_Restore_by_Bin4ry_v31.zip so you may have to google it if the link dies, or traffic is an issue.
    9.) Extract to somewhere on your drive, I put it in C:\stuff folder.
    10.) Open runme.bat (Right-click, edit) and, go to "Edit -> Replace" from menu bar, and:

    Find what: stuff
    Replace with: c:\stuff

    If you moved the directory of the files to somewhere else, then replace "stuff" with whatever the path is.
    Also, make sure when you do the find-replace your cursor starts at the TOP of the document, the find search doesn't loop back.
    11.) find-replace again... cursor at top of .bat again...
    Find what: del ric
    Replace with: del c:\stuff\ric
    Save & Close the .bat file.
    12.) Install the LG united mobile drivers from LG's website (if you haven't already)
    13.) Put your phone in "usb charging" mode, and enable "usb debugging" in System Settings -> Developer Options
    14.) Double-click the runme.bat file, choose option 1, follow directions to the letter.... when the phone reboots it's last time, check your app drawer for Superuser app. If it's there, congrats, you're nearly done.

    15.) Open the google play store, find the "ota rootkeeper" by Voodoo. Install it, do a backup of your root from there. In the "Superuser" app, I also ticked "ota root survival". Both may not have been necessary, but I did it anyway.
    16.) Enable data, wait for sprint to tell you there is a firmware update, let it update.
    17.) Check your firmware, should be .ZVK now (the latest)
    18.) Open "ota rootkeeper" re-enable root.
    19.) Reboot phone, go back to "ota rootkeeper" there should be a checkbox next to the phone root detection... your done.

    Now the real question is.... what do you do with a rooted Viper and no working custom roms that I see. Weeks of searching found rumors of roms in development that never seemed to emerge and a few that were abandoned. Can anyone tell me different, I hope?
    The other problem with that, is from what I can tell Clockwork Recovery doesn't work on the LS840, I found some mention of a hack that did, but the link didn't work, and again, no roms so what's the point? I wonder if the Flash Tool could just do it, for the likely one and only rom that is or ever will be out there.

    At any rate, the phone is rooted now, for any other purpose... hope this still matters to someone
    The only reason I kept at it for so long was mostly because if I start something I'll finish it, and failing at rooting for the last 6 months was vexing me. I bought this one refurbed from Sprint as my old phone died and had a year left until upgrade.
    getto946, grayem and roundaway like this.
    11-02-2013 01:46 PM
  7. grayem's Avatar
    Thanks, it finally worked, I have root ZVI not maybe it will work OTA!

    IT WORKED!!!!
    ZVK root!
    12-27-2013 01:58 AM
  8. grayem's Avatar
    Updating to say this technique works, still rooted 12 days later! So happy to be able to freeze visual voicemail spam etc!
    01-09-2014 03:54 PM
  9. roundaway's Avatar
    Success! Wish I had remembered to backup the call log, sms/mms, and bookmarks before uploading. Thank you miribus for post #6.
    07-13-2014 08:08 AM

Similar Threads

  1. rooting 4.2
    By dadathepanda in forum Samsung Galaxy Note 8.0 Tablet
    Replies: 1
    Last Post: 08-30-2014, 12:58 AM
  2. Recovery Help
    By Sarah Brandon in forum General Help and How To
    Replies: 2
    Last Post: 10-13-2013, 08:17 AM
  3. Replies: 2
    Last Post: 10-12-2013, 02:13 PM
  4. Help: saved, secured but not connected
    By Syakirin Aziz in forum Samsung Galaxy Note 3
    Replies: 1
    Last Post: 10-12-2013, 11:57 AM
  5. Smart Phone Flash Tool Root problem
    By Adnan Shole in forum Legacy Android & Other OS's
    Replies: 0
    Last Post: 10-12-2013, 10:05 AM