1. kbboykin's Avatar
    I have noticed that since I went from Oreo beta to OTA, the watch will just shut off after about 5-6 hours of usage and lately anytime and will not come back on until it is put on the charger for a few minutes. Usually the watch battery is % is variable. I have never had issues with this watch before. It is the unlocked (W280A) version. I have even factory reset it and paired it to another phone and removed it from the beta program. It sounds that anytime I go into or use Settings, it is mostly triggered, but other times, no set pattern.

    I am on OWR1.170919.018, AW2.7.0.178645119, Google Play Services 11.9.51 (530-177350961) Security Patch October 1, 2017.

    This is driving me insane!!!

    HEEEELLLLLPPPPPPP!
    12-26-2017 01:26 PM
  2. EL CapiTRAN's Avatar
    Bad battery? You're still under warranty right? If so factory reset didn't help I'd go with replacement.
    12-26-2017 01:40 PM
  3. kbboykin's Avatar
    Not sure, I bought this as MINT on swappa. Not sure if I can.
    12-26-2017 01:58 PM
  4. EL CapiTRAN's Avatar
    Not sure, I bought this as MINT on swappa. Not sure if I can.
    The watch hasn't been out a year yet. I'd contact LG support. They must ask for the IMEI and serial. It should still be under warranty
    12-26-2017 02:00 PM
  5. kbboykin's Avatar
    okay. thanks
    12-26-2017 02:20 PM
  6. kbboykin's Avatar
    LG has issued me an RMA and instructions on how to return for repair service.
    EL CapiTRAN likes this.
    12-28-2017 03:43 PM
  7. EL CapiTRAN's Avatar
    LG has issued me an RMA and instructions on how to return for repair service.
    Are they doing an advanced exchange or are you sending it to them first?
    12-28-2017 03:49 PM
  8. kbboykin's Avatar
    I have to send it t them
    12-30-2017 11:42 AM
  9. kbboykin's Avatar
    Watch was sent. Turns out they had to replace the mainboard. Currently enroute back to me. Fully covered under warranty. Thank @EL CapiTRAN
    01-18-2018 07:18 AM
  10. kbboykin's Avatar
    Works like a charm now. But they kept my box!!! Sent it back in bubble wrap.
    01-23-2018 06:29 AM
  11. welshdalek's Avatar
    having exactly the same problem. mine is now on it's way back for repairs.
    03-25-2018 05:38 PM
  12. Neil Ellington's Avatar
    I know this is an old thread, but

    Mine just started doing this. But, of course I have had it 14 months. I'm assuming it's out of warranty. This is crazy that this happened on a watch I maybe wear 8 days a month. Oh well. Anyone know the cost to replace out of warranty?
    08-30-2018 06:59 PM

Similar Threads

  1. Swiping isn't smooth on the Mate 10 pro
    By Trinomic in forum Huawei Mate 10 & Mate 10 Pro
    Replies: 2
    Last Post: 12-31-2017, 08:43 AM
  2. Replies: 7
    Last Post: 12-29-2017, 07:54 PM
  3. Gear S3 : Remove quick setting grey spot on top screen
    By Android Central Question in forum Samsung Gear S3
    Replies: 3
    Last Post: 12-29-2017, 10:14 AM
  4. How to fix sound issues on lg stylo 3 plus
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-26-2017, 01:24 PM
  5. Note 8 from samsung.com/carrier apps? Support carrier HD voice and VOLTE?
    By johnsonroda27 in forum Samsung Galaxy Note 8
    Replies: 10
    Last Post: 12-26-2017, 01:13 PM
LINK TO POST COPIED TO CLIPBOARD