1. Liquid_Chaos87's Avatar
    So I've come up with a weird problem...just this morning, my watch decided to display the incorrect date and time. It was saying it's Wed Dec 31 at 5:00pm (and it was 5:00AM). I've turned it off for the time being, but I've tried resetting it, which didn't work and I've tried doing a factory reset and repairing with my phone. That also didn't work. I have emailed support and still waiting on an answer. I'm not sure if there is anymore I can do, since I alrea5dy tried doing a factory reset. A replacement? I don't know...but it's strange that I've only had this watch for 3 weeks and I'm already having problems...
    09-11-2015 10:26 AM
  2. mjxplant's Avatar
    Any luck on this? This morning my watch is a head by an hour. That may prove helpful at the end of the day.
    09-16-2015 11:30 AM
  3. sandrshe's Avatar
    i am having the same problems. any idea's?
    09-29-2015 05:16 AM
  4. Zanetti2000's Avatar
    I have the same problem on my brand new Urbane watch.
    12-16-2015 04:07 PM
  5. JennSTX's Avatar
    It has to do with the phone discharging in my case the phone battery went down and the phone was off. Then I noticed that the watch wasn't working. When I charged up the phone suddenly the watch was displaying the right time again which kind of is an annoying glitch.

    I had hoped that even w/out the phone it could still be a watch but looks like they are intrinsically linked somehow.
    01-06-2016 01:25 PM

Similar Threads

  1. Replies: 3
    Last Post: 04-05-2018, 03:11 AM
  2. No "Anything but Apple" contest this time? :(
    By jean15paul in forum The Android Central Lounge
    Replies: 1
    Last Post: 09-11-2015, 05:56 PM
  3. Replies: 0
    Last Post: 09-11-2015, 09:12 AM
  4. Replies: 1
    Last Post: 09-11-2015, 07:52 AM
LINK TO POST COPIED TO CLIPBOARD