1. Issemann's Avatar
    Just installed the latest version (3.1.3) of the Market app and it takes a very long time for things to appear. For example, just getting to the home page upon launch takes 20-30 secs. The list of My Apps will take 5-10 secs to appear (not that horrible), but selecting one of my apps that needs updating is another 20-30 secs wait.

    What gives? Is it just me? I'm using a wifi connection and I'm sitting right next to my router!! Anyone else having this problem?
    08-24-2011 04:16 PM
  2. glittergirlnz's Avatar
    I have the same problem.
    Im using a Nexus S and it didnt even give me the choice to download it, it just appeared the other day. But if Im not connected to the wifi it just doesnt load the apps. I can get to the main screen and I can get into categories but once I click something from there.......Loading............ URGH! So frustrating
    08-31-2011 06:02 AM
  3. UpstateDiva82's Avatar
    I have a Wildfire S and same problem! Please fix it!
    09-08-2011 10:35 PM
  4. Go Android!'s Avatar
    I've always wondered the same. Even when sitting next to my router with 15mbps, it still takes forever to load. I like the design but it's just so buggy. How ironic that it's made by Google.
    09-21-2011 08:27 PM
  5. ch_mac's Avatar
    Check out the OldMarket app(find out by google search engine) .

    Bring your Market to old version.(2.3.6)

    It's simple and fast and bug free.
    10-14-2011 07:36 PM
  6. billionaire.dreams's Avatar
    Yea the new market is no good I tried to upgrade to it but I ended up downgrading within the a day
    10-14-2011 07:45 PM
LINK TO POST COPIED TO CLIPBOARD