1. HYDE's Avatar
    I didn't see another thread on this today, so I am not sure if it is just something wrong on my end. I have tried to purchase iSyncr today and it keeps getting stuck at "authorizing purchase". I have cancelled it and tried to install it again but no luck. I was able to download a couple of free ones.

    Any suggestions?
    07-13-2010 11:40 AM
  2. EvilMonkey's Avatar
    I've had that happen a few times. I just left it (in "authorizing purchase" mode) and it ended up going through eventually. I think once it took like 2 hours or something ridiculous like that.
    07-13-2010 12:01 PM
  3. alexlevy117's Avatar
    I bought Vlingo yesterday and I'm still stuck on authorizing purchase. It shows the transaction was made but I can't install the application. I wanted to try it for the 24 hour trial period and refund it if I wasnt happy with the app. I'm wondering when does the 24 hour clock start cause clearly I don't have use of the app at the moment. I've seen several posts on others being stuck on authorizing purchase and have yet to find one post from Google with a fix. Help anyone??
    07-17-2010 10:37 AM
  4. eyesparky's Avatar
    First purchase can take a long time to authorize. After that, purchases are pretty instant.
    07-17-2010 11:10 AM