1. TvTechGuru's Avatar
    Has anyone else been experiencing problems with the Play Store today? Since last night I have not been able to download apps at all. I have 4 app updates waiting but when I click update it shows the screen like they are downloading but nothing happens. I have tried it over AT&T and on 2 different Wi-Fi networks.

    Also, lately apps have been deleting from my phone by themselves! Latest one just happened overnight. And of course I can't re-download it right now.

    I have many in-app purchases, will they still be recognized when I re-download the app? I don't want to have to contact the app developer.
    01-18-2013 08:33 AM
  2. TvTechGuru's Avatar
    Well I just tried the play store on my tablet and it worked fine. Downloaded the app updates without problems.

    Sent from my SAMSUNG-SGH-I727
    01-18-2013 09:21 AM
  3. Slender Troll's Avatar
    Have you tried restarting your phone?

    Sent from my Nexus 7 using Tapatalk HD
    01-18-2013 10:27 AM
  4. TvTechGuru's Avatar
    Play Store is working again. I then swapped out batteries and powered the phone back on and that app magically reappeared. I don't understand.

    Sent from my SAMSUNG-SGH-I727
    01-18-2013 12:36 PM
  5. Pedtran Peter's Avatar
    I have bought an Edition Tablet and i am trying one week now to connect to play store and i can't. What am i doing wrong?
    I have deleted cache, i updated Play Store app to 3.10.10 and still can' t connect. Anyone can help?
    01-18-2013 06:03 PM
  6. TvTechGuru's Avatar
    I have never heard of that tablet. I can't help you sorry. Hopefully someone else can.

    Sent from my SAMSUNG-SGH-I727
    01-19-2013 09:58 AM
  7. Samee Mahbub's Avatar
    I am also having a bit of an issue on my nexus 10. When I go to the play store its completely blank,I can't see any apps if I force it by going to an app link, it says the app is b unavailable in my country. This has happened to me before and in was able to fix it by simply going to accounts on the playnstore . my nexus 10 runs 4.2.2 all apps work fine I ju just can't download any its completely blank. Plz help
    02-20-2013 05:57 AM

Similar Threads

  1. Google Play Store Not Working
    By aje99999 in forum Samsung Galaxy Tab 10-inch
    Replies: 327
    Last Post: 09-29-2016, 03:03 PM
  2. play store not working
    By nfisheremti in forum Sprint Nexus S 4G
    Replies: 8
    Last Post: 06-21-2015, 09:10 PM
  3. play store not working getting error 403 n 927
    By brahmaji1234 in forum Samsung Galaxy S II
    Replies: 2
    Last Post: 07-13-2013, 10:33 AM
  4. play store not working at all?
    By mrwestphal in forum Verizon Galaxy Nexus
    Replies: 4
    Last Post: 07-19-2012, 02:12 AM
  5. Play Store not working with market launcher
    By king_of_lakemoor in forum Droid RAZR
    Replies: 3
    Last Post: 03-09-2012, 10:24 AM