1. minidreamin's Avatar
    I'm trying to download the Multicon Widget from the app Market. When I go to the downloads screen, it shows that it's downloading. But the progress bar never moves. When I try to cancel the download, it causes a force close. I would really like to have the widget, but I'm a bit baffled as to how to fix this. Any ideas?

    Edit: This is for an Evo 4G.
    08-18-2010 08:25 AM
  2. sniffs's Avatar
    I have the same issue with Linpack.. if I try and update it on my droid, it sits there and does nothing.. if I click on it and click Cancel Download, the market FC's.. =(
    08-18-2010 12:31 PM
  3. minidreamin's Avatar
    I asked this same question on another forum and was give a good solution.

    Go to Settings >Applications > Manage Applications >All and find the Market app. Click "Clear Data."

    When you relaunch the Market everything should be cleared out. Try redownloading your apps again (the ones that would not download, everything else will be normal). All mine worked after that and I had four that were hung up and would force close the Market if I tried to cancel them.
    08-18-2010 01:15 PM
  4. sniffs's Avatar
    Did it work?
    08-18-2010 01:39 PM
  5. minidreamin's Avatar
    08-18-2010 01:53 PM
  6. CGWaters's Avatar
    Worked for me, too.

    Users in a few other threads (which mentioned 'clearing data' for the Market app) reported temporary loss of the download status for all of their apps. I didn't experience that.
    10-04-2010 03:47 PM