1. sjniii's Avatar
    I ran into the issue where Play Store exits when I open the app.

    I have seen many offering on fixes and have tried some with no luck.
    One suggestion is go to the application manager and at the bottom enable download manager.
    I do not have an app called download manager. I think I am supposed to have Google Play Services but I do not see that app. Since Play Store is not working, I cannot download it.

    Anyway, here are the specifics and what I see:

    Samsung Stratosphere SCH-I405
    Firmware 2.3.6

    I went into Applications
    Manage applications, clicked on All.
    Located Google Play Store and clicked on Clear data.
    Force Stop
    Went back to home screen and clicked on Play Store.
    Play Store opened and I saw the screen where you need to agree to terms.
    It exits and at the top or the phone in the msg area is a message that says 27 updates are available.
    I scroll down to the message and click on the updates,,,
    Play Store opens to a gray screen and immediately disappears and a small black window with some message flashes by and it exits (sorry the application,.)
    I go back and try Play Store again and it opens to the Play Store gray screen than disappears and the message flashes by,,

    So, I am not sure if it is because Google Play Services is not installed or something with Play Store.

    I really dont want to do a hard reset,,,

    Any other ideas?
    02-28-2014 10:19 AM

Similar Threads

  1. Galaxy S4: Problem in 4.4.2 update with email
    By accactg in forum Samsung Galaxy S4
    Replies: 56
    Last Post: 07-10-2016, 12:41 AM
  2. Galaxy S4: Touchwiz problems after KitKat update
    By jsice9 in forum Samsung Galaxy S4
    Replies: 6
    Last Post: 04-25-2015, 08:09 PM
  3. Firmware recover update via KIES & IMEI problem
    By Vitor Costa2 in forum Sprint Galaxy S III
    Replies: 3
    Last Post: 03-06-2014, 03:03 PM
  4. problem with installation of Universal Naked Driver using Windows Vista
    By JohnKay66 in forum General Help and How To
    Replies: 2
    Last Post: 02-28-2014, 09:32 PM
  5. Problems After Data Transfer with Kies
    By verde15 in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 02-28-2014, 04:57 AM