1. dbgenerations's Avatar
    alright so randomly yesterday while i was browsing the play store it "lost connection" right in the middle of looking through the games. thought maybe it was my wifi so i reset my router, tried again still nothing opened up the firefox browser on the phone, internet is working fine, check my date and time settings, it was already right and set to automatic so i switched it over to manual just in case, still no good. switched it back to automatic. tried turning airplane mode off and on, nothing. force stopped it and cleared the cache, nothing. reset the play store to original version, nothing. went and looked at my google account options in settings and it is saying there is a sync error but everything says it is currently synced and when i unsync it it always resyncs. I even logged out and logged back in, still nothing. my gmail is working, as well as my calendar and google drive. but i cannot get the play store to function at all. I really dont want to do a factory reset over this, there has to be something im over looking. anyone have any ideas on what it is. i greatly appreciate it. thanks.
    01-07-2016 05:49 AM
  2. beagle82's Avatar
    Have you also tried clearing the cache of Google services framework and google play services and then rebooting?
    01-07-2016 06:32 AM
  3. dbgenerations's Avatar
    yes i tried that also still to no avail, i did however getting my playstore to work again but doing so will probably be frowned upon, i rooted my phone, that didnt work, so i started trying to think of what i did around that time that might of caused the issue, only thing i could think of was i bought episode 1 of minecraft story mode, and i remembered that when i went to buy the other episodes it would always hang when trying to communicate with google and crash. so obviously i didnt want to uninstall something i paid for so i started looking around for apks online that might fix it, couldnt find anything so i ended up deciding screw it, ive already purchased minecraft story mode on my xbox one for my kids to play im just gonna manually install the other episodes if google wants to be a pain in my ****. so i installed the latest version of freedom apk..and low and behold upon reboot after installing it my playstore and everything else google related is working flawlessly. somehow freedom apk fixed it
    01-12-2016 06:20 AM

Similar Threads

  1. Help please, samsung s5 screen flicker
    By BLismoe in forum Samsung Galaxy S5
    Replies: 10
    Last Post: 01-14-2017, 03:49 PM
  2. Sm-g900p root help please :/
    By Bearbalue31 in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 01-07-2016, 06:24 AM
LINK TO POST COPIED TO CLIPBOARD