1. Genielorene's Avatar
    Never had a single glitch with this phone until Saturday. The phone prompted me for the update (apparently there's a big new update on the Echo that just came out), I told it to go ahead and left it the hell alone and now it won't boot up. It goes to the screen with the Kyocera name and logo on it and won't go any further. It won't turn off either. If I try to turn it off the screen goes black but the menu lights stay on.

    I've tried removing the battery and restarting.
    I've tried removing the SD card and restarting.
    I've tried holding the power button and the volume down button simultaneously to start it up, same thing happens.
    I've tried holding the power button and the volume up button simultaneously to start it up, same thing happens.
    I've plugged it into my computer dead and started it, nothing. I've plugged it into the computer with the power on, nothing.
    Now I've got the phone's SD card plugged into the computer--not that I know what to do with it. But the SD card is working.
    I tried putting the original 1GB card in it and starting it up, same thing happened except instead of a red or green power/charging light--I got an orange light. ???

    Anybody else having issues with the new update???
    04-23-2012 05:12 AM
  2. Castorshells's Avatar
    Did you ever have USB debugging enabled in your settings?
    05-04-2012 11:54 PM
  3. IAmBroom's Avatar
    Same exact problem, since mid-day yesterday (May 4 2012), and I have USB debugging enabled.

    Phone won't boot.
    05-05-2012 12:40 AM
  4. Castorshells's Avatar
    If you have ADB setup on your PC you should be able to get it to reboot.


    That will show you how to set it up. Its fine that it is for the Xoom, you just need the drivers for the echo.

    You can get the drivers for the echo from the kyocera website. You always need the drivers for any device your trying to use ADB with.

    During the endless reboot, that the phone does, the PC will see it for about 2 seconds. This already happened to me and was able to restore my phone. I don't know if you were rooted but if not your going to end up wiping the phone. I was able to boot into my custom recovery and do a restore of a backup I made.

    ADB is easy to use, just knowing what the commands are and what they do is all you need to know, at least when your not developing.

    Check those sites and let me know of any questions you have.
    IAmBroom likes this.
    05-06-2012 07:56 PM
  5. IAmBroom's Avatar
    Wish I'd read that first, Castorshells. Spent $35 at Sprint; got a new phone out of it, but lost everything - and I was rooted!

    05-07-2012 10:07 AM
  6. Castorshells's Avatar
    Well I recommend rooting again, installing a recovery, and making a backup.

    Unless your going to just stay stock.
    05-07-2012 02:05 PM
  7. IAmBroom's Avatar
    Going to, thanks. Sat was a big party, and I didn't have time to attempt untried recovery methods, but receiving calls was mega-important.

    Rock, hard place, stuck.
    05-07-2012 02:12 PM