1. Allen Turing's Avatar
    I am trying to root my VM K-rise by following the [GUIDE] Root your Kyocera Rise!,

    but I already stumbled on a roadblock at "Step 1 - Install the drivers for your RiSE" ...

    I got the driver file from Kyocera Wireless Support: Phone Drivers. My system is win 7 - 64bit, so I first got the 64-bit driver. The driver page only says "Sprint" Rise, they didn't mention VM but I hope this isn't a problem. In fact, I ran and installed the driver without problem.

    But when I connected my phone to the PC via the USB cable, the pc wouldn't recognize USB correctly.

    a screen capture from "Device Manager"

    My phone setting
    PC Connection: Charge Only
    USB debugging: on

    I did the reboot after each driver install, I've rebooted and reconnected many times to see if it will correct the problem, but to no avail.

    I already uninstalled the 64bit driver, and tried the whole process with the 32bit driver. Still the same story, no luck.

    So what did I do wrong? Wrong driver version? Wrong phone settings? or driver files are Spring Rises only but not Virgin Mobile Rises?

    Many thanks in advance!

    I got it working buy manually update the driver ... see my other post
    12-12-2012 03:30 AM
  2. zedorda's Avatar
    Try changing the PC Connection: Charge Only to USB mass storage.
    Allen Turing likes this.
    12-12-2012 11:46 AM
  3. cole2kb's Avatar
    Try a different usb port. If that doesn't work, right click on it in Device Manager and manually install the driver, it should be located in your Program Files or Program Files (x86) folder. If you can't find it, let me know.

    Sent from my Motorola RAZR MAXX using Tapatalk 2
    Allen Turing likes this.
    12-12-2012 01:00 PM
  4. Allen Turing's Avatar
    Thanks guys!

    I got it to work by using manual update, here are my settings:

    64bit driver for Windows 7-64 bit

    Airplane mode: ON
    Auto Sync: OFF
    GPS: OFF
    PC Connection: Mass Storage
    USB Debug Mode: ON

    1) Before installing the 64bit driver, uninstall any old Kyocera USB driver, then reboot
    2) Install the 64bit driver, reboot
    3) Connect Phone to PC, but still the same old "driver not found message"
    4) Go to "Device Manager", find the Kyocera USB device with yellow mark warning sign, and update the driver
    5) on the "update driver" menu, select the "Browse my computer for driver software"
    ---> "Let me pick from a list of device drivers on my computer"
    --->"USB Controller"
    ---->"Kyocera Corp"
    ---->"Kyocera USB Modem KC02S"

    Those step worked for me, my phone is connected to the PC with the driver working.

    I then followed the rest steps in the root guide, and everything worked out as described!

    Voila, I know have root!

    Thank you very much for the help, zedorda & cole2kb!
    cole2kb and keypawf like this.
    12-12-2012 01:23 PM

Similar Threads

  1. No media found on my Galaxy Nexus!
    By demonmz in forum Google / Samsung Galaxy Nexus
    Replies: 7
    Last Post: 08-20-2012, 06:22 AM
  2. no pictures found on the sd card please help
    By sropedia in forum Sprint Nexus S 4G
    Replies: 6
    Last Post: 12-06-2011, 10:45 PM
  3. Nexus S - no driver found - adb 2.3
    By turinreza in forum T-Mobile Nexus S Rooting, ROMs, and Hacks
    Replies: 2
    Last Post: 01-14-2011, 01:32 PM
  4. Watching Movies on My Droid-404 Not Found
    By sidekra in forum General Help and How To
    Replies: 1
    Last Post: 10-18-2010, 08:04 AM
  5. "No Driver Found" Windows 7 (64 and 32 bit)
    By jordo_99 in forum Verizon Fascinate
    Replies: 1
    Last Post: 09-20-2010, 11:09 AM