1. joseph jassen's Avatar
    Hello everyone
    I asked this question before but hadn't created account.
    My pictures and videos are not showing in gallery. The show in files though!!
    My phone is HUAWEI Y-336-U02.
    I have tried a lot in many forums but non has worked. I come here hoping to get these answers.

    Theres one way I haven't tried; That which involves clearing media storage data. This is because I can't find media storage in the app manager.
    When I asked this question before creating an account, I got an answer that told me to check the menu on apps manager and select "show system". I can't find that option either.
    Help please!! What do I do now.
    05-05-2017 03:35 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Are these photos and videos taken by the Camera app, or by some other app? Or did you transfer them to the phone from a computer, or download them from the web?

    Which directory are the files located in? Using your file manager, see if there is a file called ".nomedia" in that directory. If so, delete it.

    Also, go to Settings>Apps​, select your gallery app, and make sure it has permission to access your files/storage.

    When you get a chance, head over to the Introductions forum and tell us something about yourself! http://forums.androidcentral.com/introductions/
    05-08-2017 11:53 PM
  3. joseph jassen's Avatar
    Hello!
    The photos and videos don't show in gallery regardless of the source they come from. They are located in files>SD card>DCMI.
    I searched for the nomedia from my files but they were not there. I tried searching for them using fx explorer but only a few showed and non of them was a photo so the problem is still there.

    My gallery has permmision to read contents in SD card.
    Help please if you got ideas.
    05-14-2017 04:18 AM
  4. B. Diddy's Avatar
    Are you using the stock Gallery app, or a 3rd party one? Also, if you move the photos to the /DCIM/Camera directory of Internal Storage, do they show up in the gallery app then?
    05-14-2017 12:56 PM
  5. joseph jassen's Avatar
    Its the gallery that comes with the phone that I use. I'm not good at the stock gallery and third party vocabulary!!!

    The pics still don't show even when cut or copied and pasted in internal storage.

    Perhaps its time to also include the video issue!! When I record videos, I find them in files>SD card>DCMI. but when I try playing them the phone tells me "can't play this video". The videos don't show in gallery too.
    Sometimes I clear gallery data and cache. When I want to open the pics I'll have to choose what app to open them with. Even though I choose gallery I won't find them there!!

    Perhaps the more problems you find out the easier the solution becomes.

    If I were to tell all the problems the phone has got we may shift from the topic. Let's first deal with gallery.
    05-16-2017 03:17 AM
  6. B. Diddy's Avatar
    It sounds like the phone is set to save photos and videos to the SD card by default, not Internal Storage. If the card is bad, then files that are being saved there might immediately become corrupt.

    Install SD Insight to see if the card is genuine or counterfeit. Counterfeit cards are programmed to report more storage than they actually have, and if you try saving more than the card can actually hold, then files can start getting corrupt.

    If it's a valid card, then go to Settings>Storage, Unmount the card, remove it, and insert it into your computer. Can the computer read these files, and if so, do the images and videos display correctly? Backup as much as you can right now, then run chkdsk to look for bad sectors: http://forums.androidcentral.com/amb...d-sd-card.html. If the card looks like it's corrupt, then try a new card.
    05-16-2017 11:48 AM
  7. joseph jassen's Avatar
    I used SD Insight to check the SD card's storage. It reports that the card is 2016 MB. And the card itself is labbleled 2 GB. I therefore don't think the card is the problem!!

    Afterall even before I bought the card, the pics and videos didn't show and were stored in internal storage.

    I guess the problem is with the gallery because as I take photos they move to that little icon below in camera app and suddenly disappear!!
    Viewing them from files however works good and clear. Aah, unlucky me that I have to access the gallery for pics and videos when making a movie!!
    05-16-2017 07:03 PM
  8. B. Diddy's Avatar
    Ok sorry, I must have missed that earlier about the images not showing up when they were in Internal Storage to begin with.

    Have you also tried using a different gallery app, like Google Photos? Do they photos show up there correctly?
    05-17-2017 03:02 AM
  9. joseph jassen's Avatar
    When I open them with Google photos in files, yes they show but opening the app individually no photos found there.
    05-17-2017 06:25 AM
  10. joseph jassen's Avatar
    Which gives me another thought that the gallery may not be the problem.
    The photos maybe the problem.
    05-17-2017 06:35 AM
  11. B. Diddy's Avatar
    When I open them with Google photos in files, yes they show but opening the app individually no photos found there.
    What do you mean by "opening them with Google photos in files"? Are you referring to a file manager app, or the actual Google Photos app? If the photos show up when you use the Google Photos app, then your initial concern about the stock Gallery app may be valid.
    05-17-2017 11:17 AM
  12. joseph jassen's Avatar
    What I mean by "opening it with Google photos in files" is that I open file manager>SD card>DCMI then when I select the photo I then have to choose an app to open it with like gallery, Google photos or pics art. Perhaps you got that.
    05-18-2017 04:13 AM
  13. joseph jassen's Avatar
    And yes the initial concern about gallery has to be valid!!
    05-18-2017 04:14 AM
  14. B. Diddy's Avatar
    Sorry -- what I meant about that "valid" comment was that the Gallery app itself might be the issue, and not the photo files. I wasn't suggesting that anything you said was not valid.

    When I mentioned the Google Photos app as another gallery app to try, I meant this: https://play.google.com/store/apps/d...s.photos&hl=en. What you're describing to me is the file manager, where you're going directly to the photo file and trying to open from there. I'd like to know if another gallery app like Google Photos recognizes your photos and displays them properly. If it does, that would mean the stock Gallery app is the problem. If the photos don't get displayed properly in the Google Photos app, then it might be an issue with the files, or with the system's Media Scanner (which scans all storage areas for images, and adds them to the database used by gallery apps).
    05-18-2017 05:17 PM
  15. joseph jassen's Avatar
    Google photos too didnt work B!!

    The pics might be the problem right?
    05-19-2017 07:08 AM
  16. B. Diddy's Avatar
    This is a strange problem. Do any picture files in the /DCIM directory (either on Internal Storage or the SD card) show up properly in the gallery apps, or is it only a select few pictures that aren't showing up?
    05-20-2017 06:03 PM
  17. joseph jassen's Avatar
    All don't show!!

    And never have they shown.
    05-21-2017 05:48 AM
  18. B. Diddy's Avatar
    Try media.Re.Scan to see if that forces the system's Media Scanner to find the images.

    Also, using your file manager, check the topmost directory and make sure there isn't a ".nomedia" file there either. A .nomedia file in a directory instructs the system not only to ignore that directory, but any subdirectories as well. So if you had a .nomedia file in the topmost root directory, that would make the system ignore all image files.
    05-21-2017 11:44 PM
  19. joseph jassen's Avatar
    I deleted all nomedia files in my file manager but it didn't work!!

    I then used the media rescan app which i downloaded to rescan the files but it doesn't finish the rescan. It does 380 out of 386!
    I tried to get some help and was told to select the "media storage" button at the bottom of the page and then clear data and cache but when I select it a dialog appears telling that "Unfortunately settings has stopped"
    I think its because there is nothing like media storage in settings!!!

    I'm so puzzled
    05-22-2017 01:46 AM
  20. B. Diddy's Avatar
    Does this happen in Safe Mode as well? The steps here ought to work on your phone as well: How to turn on safe mode on Huawei Ascend Y330

    If that doesn't help, then try wiping the system cache partition (which is different from clearing the app cache): HUAWEI Y336-U02 - Recovery Mode - HardReset.info
    05-22-2017 12:30 PM
  21. joseph jassen's Avatar
    The problem still persists in safe mode!!

    And about wiping cache partition, I did that when I was restoring the phone sometime before I had joined abdroidcentral and still the problem was still there.
    05-23-2017 03:03 AM
  22. B. Diddy's Avatar
    I'll be honest, I'm not sure what else to try next. It might be a problem with the phone's firmware, but I don't know how easy or hard it is to reinstall the firmware for that phone. Try looking around the forums at XDA-developers.com, which is a good resource for this kind of thing.
    05-23-2017 11:02 AM
  23. joseph jassen's Avatar
    Thanks a lot for all this help!!
    B. Diddy likes this.
    05-24-2017 01:22 AM

Similar Threads

  1. Replies: 1
    Last Post: 05-08-2017, 11:58 PM
  2. Replies: 1
    Last Post: 05-08-2017, 11:55 PM
  3. why apps not installing
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-05-2017, 06:26 AM
  4. Why does my screen not rotate and heart rate sensor not work?
    By AC Question in forum Samsung Galaxy Note 4
    Replies: 0
    Last Post: 05-05-2017, 03:20 AM
  5. Replies: 1
    Last Post: 05-05-2017, 03:20 AM
LINK TO POST COPIED TO CLIPBOARD