1. FranBunnyFFXII's Avatar
    I'm not too worried about this atm, but I picked up a Moto E from a grocery store kiosk as a direct replacement to my old(2011) phone. When I checked specs GSMarena noted the moto e had dual sim slots, but I look at the phone itself and there's no sim slots.

    Chassis alteration to hide them? How would I check to see how the phone is operating SIM wise?

    I barely use the phone side of it, and use it mostly like a mini wifi tablet, but I was looking to get a tmobile 20$ a month unlimited data thing, or something for a data connection.
    11-17-2014 10:14 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! According to the specs, it looks like the NET10 version is CDMA/3G only, which means no GSM--and that means no SIM. Manufacturers have to make different versions of the same phone for different carriers, because Verizon and Sprint have historically used CDMA, while AT&T and T-Mobile have used GSM.
    11-18-2014 03:39 AM

Similar Threads

  1. No More Silent Mode
    By RG129 in forum Android 5.0 Lollipop
    Replies: 65
    Last Post: 04-20-2015, 05:12 PM
  2. Replies: 0
    Last Post: 11-17-2014, 05:47 PM
  3. Replies: 0
    Last Post: 11-17-2014, 03:08 PM
  4. Why don't I have a signal on my LG G2 D802?
    By Survivor0007 in forum LG G2
    Replies: 0
    Last Post: 11-17-2014, 01:46 PM
  5. No LED indicator while charging?
    By daihard2008 in forum Android 5.0 Lollipop
    Replies: 4
    Last Post: 11-17-2014, 01:17 PM
LINK TO POST COPIED TO CLIPBOARD