Black Friday deal team is live right now!

Check out the hottest Black Friday Deals!

Expand Minimize
  1. alexondrums's Avatar
    I'm having trouble copying Titanium Backup files from my phone to my PC (Android 4.4.2 / Windows 7).

    I'm connected via USB, with developer mode turned on, using MTP connection.

    I've accessed the internal memory on the phone in Windows Explorer:

    Computer\XT1032\Internal storage\TitaniumBackup

    ...and just want to copy and paste all the backup files to my PC hard drive, to back them up.

    Although I can see all the files in Windows Explorer on the phone memory, when I try to copy / paste them to the hard drive, either nothing happens or only 1 file copies over. There are 482 files to copy over. I don't understand why it's not working.

    I tried select all > copy / paste (and keyboard shortcuts), dragging and dropping, but neither work. The copy function IS available in the context sensitive menu, as is paste, so it's available to use, but just doesn't work.

    Hope someone can help?
    Attached Thumbnails Copy Titanium Backup files to PC via USB-copy-files.png  
    04-21-2014 01:58 PM
  2. neu smurph's Avatar
    Seems like an odd problem. Might be worth trying to hit the refresh button on the windows address bar for the folder you are copying too.......

    I've always found MTP a bit flakey, and connecting in mass storage mode on my tablet causes problems for that device as-well (resets wallpapers and widgets) so I long ago gave up connecting either device directly to the PC and now use ES explorer to connect via Wifi via a standard SMB/Windows Share. Transfer speed for long copy paste operations generally is about 1Mb/s.
    04-22-2014 12:59 AM
  3. alexondrums's Avatar
    Bringing this up again as I'm having the same problem again.

    I'm transferring from a Moto G to a Moto G 4G.

    The old phone is rooted on 4.4

    I have created a backup with titanium backup, and all the files exisit in \Computer\XT1032\Internal storage\TitaniumBackup - but when i copy and paste them to a folder on my PC via USB, only 1 of the 300+ files copies.

    Any ideas?
    07-11-2014 06:55 PM
  4. Christopher Brodie's Avatar
    I find using mtp in general is a temperamental process, sometimes it works fine and others it just gives up completely, I tried moving my data over using ubuntu linux OS, I figured that the file system is the same so it might help, and it did! it copied everything without a glitch and it did it a hell of a lot faster then windows ever could!

    HOWEVER the kernel that ubuntu is currently using has issues with mtp and when I tried to do it a seconf time it froze my pc completely (grr!) so you can go through a painful process of trying to update your linux kernel in ubuntu or you can try these things in wondows as I am right now as I type this:

    option 1. using es file explorer make a zip file of your titanium backup folder, Ive had much better luck moving one file over mtp then I have several small files, this seems to work fairly well for me but the trouble I have at the moment is that I don't even have enough space on my nexus 5 to make another zip that big

    option 2: Nexus Root Toolkit by wugfresh, I'm not sure if I can post links in here but just google "wugfresh" and it's the first result that comes up, this is commonly used to root and unroot nexus devices with ease and it works very well at doing that, but also you can use it to pull and push files to and from the device using adb (android debugging) *NOTE this feature does not support android 5.0 yet

    option 3: buy a cheap usb-otg drive and move it over that way, again it's painfully slow and it chews your battery like a pitbull on a fresh bone if you have the patience it will get there eventually, using usb-otg requires root access for some stupid reason and you need a good file manager like es file explorer

    option 3.5: similar to usb-otg but a hell of a lot faster is these neat little micro SD card readers you can buy, again I can't post links but google "Meenova"(.com) they only cost $12 (USD) and $3 for international shipping, they look pretty neat actually, I've ordered one and I'm just waiting for it to arrive.

    but all and all mtp completely sucks, all the best and good luck
    11-11-2014 08:21 PM
  5. tobydjones's Avatar
    I have the same problem. I tried dragging a bunch of files and folders from XT1033\Internal storage over to my D: drive, and some copied, but not all, and not all files in a folder either. Some files resist copying even when dragging just that one file.
    Eventually I used SambaDroid to share the internal memory as a network share over wifi.
    Copying my TitaniumBackup folder got up to 4 MB/s.
    Note, SambaDroid doesn't show hidden files (beginning with a dot) so you can't copy them. [edit: actually it does, it's windows that hides the files, change that in Organize>Folder and search options>view>show hidden files]
    02-07-2015 11:07 AM
  6. mtvictor's Avatar
    Just compress then into zip file from your cellphone, and copy that zip to your PC

    Posted via Android Central App
    02-21-2015 07:26 AM
  7. lionsharz's Avatar
    had this issue too. ensure that Titanium is not running on your phone and probably a good idea to shut down all other apps in the cache too in case one of them has some sort of lock on the files. I did that and was able to copy them all over to my windows machine
    04-23-2015 08:53 AM
  8. lshantz's Avatar
    I have come to the conclusion that it is Titanium and how they do permissions on those files. You can copy some files, but not others right? I have found a fool proof work around. I tried doing a chmod on those files, but for some reason the command is ignored. Anyhow, connect your phone up to your computer with the sdk tools. Run adb pull /<directory>/<Titanium directory> and it will pull them all to your computer. I can't figure out easily how to zip the files while on the android device, but this is a quick and dirty way to get those files.
    05-01-2015 11:00 AM
  9. KyBits's Avatar
    It's working for me on an old Pentium 4 Windows 7 machine yet usually I am the one who has unusual failures. I copied 285 files comprised of 234 MegaBytes that were backed up on my Google Nexus 5 (HammerHead). They copied from the Nexus 5 to the Windows hard drive. I don't know why it isn't working for you, but, here are some things that might be different in my configuration compared to yours:

    01>>> I am using the paid version of TitaniumBackup. Doubt that matters, though, but, you never know.
    02>>> In TitaniumBackup, I changed the default backup directory on my phone to simply this: /sdcard/TitaniumBackup. The default location that was originally setup by TitaniumBackup was something else and I don't remember what that was but I believe it was a path that pointed to a directory on the device in a system directory that might have limited access. So, in TitaniumBackup's preferences, select "backup folder location." Next screen has a "detect" box. Hit it. That will tell you where it is currently saving your backups. But, go to the line above where it says "(click to change)." Navigate until you have mapped a path that only says, "/sd card/TitaniumBackup" - without the quotes, of course. Maybe that will work?
    03>>> I have developer options turned on and it is in USB debugging mode
    04>>> I have Google's USB drivers installed on my Windows 7 computer.
    05>>> Like you, I have selected MTP mode for USB.
    06>>> And, of course, in Windows, I've got it set up to show hidden files and to show system files and I do not have extensions hidden.
    07>>> My Google Nexus 5 is rooted (using Chainfire's excellent tool) but it is using the stock recovery and I'm using Android 5.0.1 Build LRX22C Kernel 3.4.0-g88fbc66. (There's an update for lollipop out there but I haven't bothered to update.)
    08>>> At first launch, TitaniumBackup cautioned that I might have problems if I allow "mount namespace separation" to be enabled in SuperSU. So, I unchecked that in SuperSU.
    09>>> At first launch, of course, TitaniumBackup warned that it might not function properly unless USB Debugging mode was enabled in Developer Options so naturally, I enabled that.

    That's all I can think of for now. If something else comes to mind I'll come back to post.
    05-02-2015 11:09 PM
  10. HaPeChe's Avatar
    I encountered the same problem - and after rebooting the phone (and by that closing all apps) it worked well an I could copy all files of the backup with only one action to the PC.
    09-05-2015 07:31 AM
  11. rdonnelly's Avatar
    I could not get it to work with the USB cable using KyBits method, but ES explorer remote manager and Filezilla on my Linux PC worked.
    08-21-2016 08:55 AM

Similar Threads

  1. How can I get my Galaxy S5 to read my texts aloud?
    By JS_racer in forum Samsung Galaxy S5
    Replies: 11
    Last Post: 08-31-2015, 10:27 AM
  2. Benefits to rooting G2?
    By JJ Jones in forum LG G2
    Replies: 17
    Last Post: 06-21-2014, 04:40 AM
  3. PC to Samsung S5 SD Card won't tranfer.
    By Pacific_Skipper in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 04-21-2014, 02:18 PM
We have updated our Privacy Policy and Terms & Conditions. Please check them out.