02-17-2015 09:21 PM
37 12
tools
  1. Jhessica Franchetti's Avatar
    I don't know if this will help you, but I was with the same problem after activating ART mode and manage to restore the functions without the factory reset.

    Here is what I did:

    After given up trying the steps above (didn't work for me), I was trying to do anything but the factory reset.

    So I had the idea to remove the sd card and let the battery discharge completely (just to see if something different happened).

    After that, I plugged the phone to my PC, still without the sd card, and let it charge for a while expecting the same error popup after it booted, but for my surprise the phone went back to normal.

    Don't know what happened, but somehow it went back to Dalvik mode and everything was fine.

    Hope this helps.

    Good Luck.
    08-17-2014 03:20 AM
  2. andres_carbonero's Avatar
    Yes!!! The solution of Sajidr works for me too. It's slow but it works!! Thank you very much mate, you save my life!
    11-05-2014 01:41 PM
  3. mailatsai's Avatar
    Thanks a lot .... it helped me too
    12-14-2014 03:09 AM
  4. LovelyLeslie's Avatar
    Phone is stuck in "Android is upgrading. Optimizing application 1 of 1" HELP!!!!!!!!!!!!!

    i remember i was downloading something from google play store but it took so long so i cleared cache from playstore then i also used clean master and du booster to clean junk but it was taking longer than usual also so i stopped my downloads and everything i was doing.

    i powered off my phone. then turned it on again and it says

    "Android is upgrading, Optimizing application 1 of 1"

    and i already slept for more than 8 hours and its stuck there. I cant do anything except remove my battery,sim and sd card.

    help me please....
    12-20-2014 12:03 AM
  5. gonzalo76's Avatar
    I managed to switch my runtime back to Dalvik. It was painfully slow but in the end I didn't have to do a factory reset.

    There's a fraction of a second after unlocking when the screen responds to a touch or swipe. This happens only right after you see the error message popup - "Unfortunately, the process com.android.systemui has stopped". If you do not see this message after unlock then open up the camera from the lock screen & close it.

    Next, follow these steps to open up the app drawer -
    1. Unlock the phone
    2. Once you see the popup "Unfortunately, the process com.android.systemui has stopped", keep tapping on the area where you think the app drawer icon is. At the same time, using another finger click on the OK button of the systemui message box.
    3. If your timing's good then once the message box is closed, the app drawer should open.
    4. The phone would go back to lock screen but the app drawer would be open. You can validate this by unlocking the phone.

    Repeat the above steps to swipe over to your Settings app. Instead of tapping, do short swipes & then click on the message box OK button. Each time the phone would go back to the lock screen but you should be able to slowly navigate over to change your runtime.

    Once I got the hang of it, it took me about 15 minutes to go to Settings & change the runtime.

    Don't bother trying to uninsintall flipboard from your play store this way. I tried it twice & both times the phone rebooted itself after i clicked the uninstall button.

    If your screen layout shifts vertically after the unlock then tap on the area where you first see the icon & not where it moves to after the shift.

    Good luck.
    I had the same problem like OH ryan, but in my case, I changed Dalvik to ART thinking it was going to be better, faster, battery saver and blah blah blah... but nope, nothing like that happened. I couldn't unlock my Moto G anymore. I have to admit, I thought you're joking when I read your fix but damn... You're right!!!!!! It took me like 20' to fix it but I did!!! This was the only solution that fixed my problem without loosing any data at all! "If it works... DON'T fix it" LOL! Thank you so much for your help!!!!!!
    01-03-2015 11:11 PM
  6. ghost_in_the_pudding's Avatar
    Thanks Sajirdr. Another satisfied customer. I thought I'd bricked my phone. The offending app seems to be Logo Quiz by bubble quiz games.
    01-13-2015 01:43 PM
  7. chandra_wilson's Avatar
    Hey!

    How do I know which app is the offender?
    Because I downloaded an app a couple of days ago and just today I'm getting the error message. I don't know enough about phones to understand the entire process posted above.
    01-20-2015 10:37 AM
  8. Utkarsh Chanchlani's Avatar
    STUD BRO... I tried the same thing, and it worked for me. Thanks a ton for this trick!
    01-22-2015 07:40 AM
  9. hipster03's Avatar
    Folks please help me.

    I am following sajidr's option.
    I can reach till settings with the tapping but cant scroll down to reach the developers tab and then to choose Dalvik runtime. Please help.
    Its more than 3 hrs my phone is continously upgrading and rebooting.

    Cheers
    Mad
    01-26-2015 01:51 AM
  10. Sanghamitra Chakraborty's Avatar
    I was facing the same issue with my Moto E. I tried your solution and after loads of trying reached the menu option from where we can choose the runtime. On clicking it I found only Dalvik runtime was showing and was already checked. Next, I rebooted my phone again and still the same issue is persisting. Could you please let me know what I am doing wrong, or what might help me out of this?

    Any help would be greatly appreciated!!

    Regards,
    Sanghamitra
    02-04-2015 07:29 AM
  11. Javier P's Avatar
    You can try to boot your phone in safe mode. If that doesn't help I'm afraid that factory reset could be your only option.

    Take a look here.

    https://motorola-global-portal.custh...7329/related/1
    02-04-2015 07:50 AM
  12. Nihal Chand Bhati's Avatar
    Hi guys my Moto G right now is completely useless. When I boot the phone is says "Android is upgrading.. Optimizing 1 out of 1 apps" This happened immediately after I installed the latest Flipboard update. After a few minutes, I try to unlock my phone and it just hangs and goes back to the lock screen, over and over. Sometimes it throws me an error as well "system UI stopped working" or something like that.

    I restarted so many times and it still persists. I tried safe mode but its still the same. Should I go into recovery or something? I'm not that well versed in that kind of stuff. I also don't wan't to wipe my data, any help? BTW I'm using ART if that matters.
    02-17-2015 09:21 PM
37 12

Similar Threads

  1. An open letter to the individual in possession of my N7 LTE
    By BizzyGeek in forum Google Nexus 7 Tablet (2013)
    Replies: 14
    Last Post: 06-05-2014, 08:41 PM
  2. Moto G Battery Charging Problem Unable to Fully Charge
    By ADA_Guy in forum Moto G (2013)
    Replies: 3
    Last Post: 05-21-2014, 11:16 PM
  3. Has T-Mobile dumped the "My Account" app for Android?
    By Dayvidpriddy in forum T-Mobile
    Replies: 21
    Last Post: 05-21-2014, 05:55 AM
  4. Replies: 1
    Last Post: 05-16-2014, 10:40 AM
  5. I Think My Phone Has A Poltergeist
    By PsychDoc in forum Samsung Galaxy S5
    Replies: 5
    Last Post: 05-15-2014, 11:23 PM
LINK TO POST COPIED TO CLIPBOARD