1. garfybeds's Avatar
    I have just purchased (and unlocked) a Tesco Moto G - I believe that Lollipop is available for it, but it doesn't appear if I look for an update from within the phone.

    I have tried to download and install Motorola Device Manager from the Motorola home page, using both Internet Explorer and Google Chrome. However, when I click on the red link to download (both Windows and Mac) I get an error page saying

    Network Error (tcp_error)


    A communication error occurred: "Connection refused"
    The Web Server may be down, too busy, or experiencing other problems preventing it from responding to requests. You may wish to try again at a later time.


    Does anyone know what is wrong at Motorola ?
    05-22-2015 07:50 AM
  2. Javier P's Avatar
    Maybe the servers are quite busy. They just released Lollipop for the Moto G in the States.
    05-22-2015 10:19 AM
  3. VeloPike's Avatar
    I had this issue too... simply take the "s" out of the address... instead of https make it http

    hope this helps, it worked for me.
    05-24-2015 02:46 PM

Similar Threads

  1. How can I get my keyboard working correctly?
    By Dodds86 in forum Samsung Galaxy S4
    Replies: 8
    Last Post: 05-27-2015, 06:23 AM
  2. Which is the best app to clear the cache memory of Android device?
    By lisaquach in forum General Help and How To
    Replies: 7
    Last Post: 05-23-2015, 10:24 PM
  3. my googleplay dosnt work it says no connection retry
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-22-2015, 01:11 PM
  4. Why won't my home page load and I have a blue screen?
    By AC Question in forum Samsung Galaxy Tab 3
    Replies: 1
    Last Post: 05-22-2015, 01:00 PM
  5. why downloads mp3 files are not showing in music player ?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-22-2015, 06:57 AM
LINK TO POST COPIED TO CLIPBOARD