1. Roman Rusman's Avatar
    Hello!

    I have such a problem with pairing my devices: automobile audio system Kenwood ddx6023bt and Motorola moto g2 (2014). So Bluetooth is not connecting normally. It shows mistake on the smartphone “incorrect pin or passkey”. Have to mention that 6digit number is correct in both devices. Devices do see each other in “search”. Before I had Samsung Galaxy tab 3, s4 mini, Fly ego art 2 and connection was really good, no bugs. The same pairing problem occurs with Fly Tornado One smartphone. I have tried deleting all data for Bluetooth in smartphone and stereo system. It gives different 6digits (of course they are the same in pairing devices) but devices do not pair anyway. Thank you for your help.
    Have to mention that all smartphones successfully pair with each other. Firmware is updated. Kenwood support answered that i am the first with such a problem.
    11-19-2014 04:06 PM
  2. DJ Brown's Avatar
    This post is about 45 days old and no responses.
    Are you still experiencing problems?

    My Moto G (2014-XT1031; Boost Mobile/Falcon-CDMA, new last week), Arrived with 4.4.3. Two days ago Motorola proactively pushed an update to 4.4.4 over my home WiFi LAN. This phone is not activated as I am still evaluating it. It will require a phone service provider change from Virgin (both Sprint backbone) to activate, so I want to be sure. Virgin is a great company, but all their phones are either pricy or are sporting down-rev Android OS - too expensive or too old. Boost seems to fix both with their moto g offering.
    This phone runs unMODded and is still locked to Boost/Sprint, no SU access.

    Back to BT.
    I have an Adidas miCoach HRM. Their app sees the HRM and provides good solid data connection. Nice exercise monitor tool.
    The only problems is when the phone sleeps during use, that exceeds the longest (30min) display timeout.
    Having to stop and unlock my screen is sub-optimal, particularly on a bike.
    So, I want to use the built-in Settings>>Security>>Trusted Devices to keep the phone Un-Locked while paired.

    Remember miCoach app sees the HRM when its transmitting (An auto-on device when skin connections complete the circuit and sense pulse.)
    So, WHILE the app is functioning - trying to set Trusted Devices complains like yours with a pin failure.
    Also, app-off, the native BT pairing will fail in a "known good HRM operating condition".
    Same complaint: "Couldn't pair with miCoach HRM because of an incorrect PIN or passkey" as when the app is running and Trusted Devices settings are attempted.
    Seems odd to me that it knows WHAT is there; the app sees and uses data from the device - but it won't pair.

    Is this the BTLE "SMART" function? Has the BT consortium defined a way to erect pairing with "other than OEM" applications?
    Or is this just a bug?
    01-08-2015 05:23 PM

Similar Threads

  1. Replies: 6
    Last Post: 12-24-2014, 06:16 AM
  2. Replies: 9
    Last Post: 11-21-2014, 11:29 AM
  3. Replies: 4
    Last Post: 11-20-2014, 10:39 AM
  4. Replies: 1
    Last Post: 11-19-2014, 06:42 PM
  5. Replies: 2
    Last Post: 11-19-2014, 04:01 PM
LINK TO POST COPIED TO CLIPBOARD