1. Omar Zahran's Avatar
    Hello Android world!

    I am a long time Windows Phone user and recently decided to make the switch to Android. Now, I'm on no contract and didn't have a bunch of money to spend on a new phone so I decided to go with the Moto G (2014) because of its price, the fact it already had Lollipop, and how well it was reviewed by the tech media. So a couple of weeks ago I went out to Best Buy and went ahead and bought it for $180.

    At first I was in love, the phone felt great in the hand and the size was perfect for me. But then I started experiencing issues. The phone lags like no other. I would go to launch an app, and it sometimes take 15-20 seconds for the app to even open. Sometimes the phone won't even register that I tapped on something, and the keyboard (have been using Google Keyboard) seems to lag quite a bit and misses entries. At first I thought it was the fact that the phone needed to be broken in a bit, but it hasn't gotten any better.

    I have tried clearing the cache partition, multiple hard resets, even deleted the Facebook app because I have read that that slows down devices. Is this common with this phone? Should I make a warranty claim on the device or get a more powerful device? Thank you for your help in advance!!
    Aniket Mhatre likes this.
    01-28-2015 11:35 PM
  2. UJ95x's Avatar
    Definitely not normal. The new Moto devices are some of the fastest Android phones you can get. I'd make a claim on it
    01-28-2015 11:37 PM
  3. Golfdriver97's Avatar
    Welcome to the forums.
    multiple hard resets
    Are you doing this by going into Settings>Backup and reset?
    01-28-2015 11:39 PM
  4. SactoKingsFan's Avatar
    My Moto G doesn't have a lag issue, but I'm still on KitKat and only use it as a backup. I'd make a warranty claim and see if the replacement device has the same issue.

    Sent from my G2 running SlimKat
    01-28-2015 11:41 PM
  5. Omar Zahran's Avatar
    Welcome to the forums.


    Are you doing this by going into Settings>Backup and reset?
    Yes I am
    01-28-2015 11:42 PM
  6. Omar Zahran's Avatar
    My Moto G doesn't have a lag issue, but I'm still on KitKat and only use it as a backup. I'd make a warranty claim and see if the replacement device has the same issue.

    Sent from my G2 running SlimKat
    The issue was on both KitKat and Lollipop so I dont think its an OS version thing
    01-28-2015 11:43 PM
  7. ColbyJvonBrown's Avatar
    The issue was on both KitKat and Lollipop so I dont think its an OS version thing
    Mine never experienced lag issues or an other issues.

    Posted via the Android Central App
    01-28-2015 11:46 PM
  8. SactoKingsFan's Avatar
    The issue was on both KitKat and Lollipop so I dont think its an OS version thing
    Sounds like you have a defective device.

    Sent from my G2 running SlimKat
    01-29-2015 12:07 AM
  9. Omar Zahran's Avatar
    Ya seems like it, bad luck I guess haha
    01-29-2015 12:09 AM
  10. thisisjason's Avatar
    Lagged a little on the first Lollipop update, but even then not what you're experiencing.
    01-29-2015 09:15 AM
  11. sulla1965's Avatar
    Depends on how you define slow. Keep in mind its not a high end flagship phone. However overall it runs fine with really no noticeable lag
    01-29-2015 04:39 PM
  12. Omar Zahran's Avatar
    I had lowered expectations, I wasn't expecting beastly performance. But I think taking 20 seconds to load an app like Play Store or Snapchat is not normal lol. I processed the exchange yesterday, hopefully it will arrive soon!
    01-30-2015 10:31 AM
  13. Haalcyon's Avatar
    Doesn't the Moto G only have 1GB of RAM?
    01-30-2015 11:57 AM
  14. UJ95x's Avatar
    Doesn't the Moto G only have 1GB of RAM?
    Yes. That doesn't make apps take seconds to open though

    Sent from my Galaxy S4 running Lollipop 5.0.2
    01-30-2015 12:04 PM
  15. Haalcyon's Avatar
    Yes. That doesn't make apps take seconds to open though

    Sent from my Galaxy S4 running Lollipop 5.0.2
    Okay. Still, wish they would've just put 2GB of RAM in the Moto G and been done with it.
    01-30-2015 12:41 PM
  16. UJ95x's Avatar
    Okay. Still, wish they would've just put 2GB of RAM in the Moto G and been done with it.
    It's the best sub $250 phone by far. Gotta shave cost somewhere, and the RAM doesn't seem to be an issue on it.

    Anything above $400 though, should without a doubt have 2GB+
    01-30-2015 12:59 PM
  17. dpham00's Avatar
    Something definitely isn't right. I have the first gen moto g and that isn't normal for sure to take 15-20 seconds to load play store.

    Sent from my Verizon Samsung Galaxy Note 4
    01-30-2015 02:24 PM
  18. dpham00's Avatar
    It's the best sub $250 phone by far. Gotta shave cost somewhere, and the RAM doesn't seem to be an issue on it.

    Anything above $400 though, should without a doubt have 2GB+
    The Redmi Note 4G is $160 and has 2gb ram, and snapdragon 400 processor.


    Sent from my Verizon Samsung Galaxy Note 4
    01-30-2015 02:33 PM
  19. UJ95x's Avatar
    The Redmi Note 4G is $160 and has 2gb ram, and snapdragon 400 processor.


    Sent from my Verizon Samsung Galaxy Note 4
    I'm sure they're also making less profit off of it.

    Sent from my Galaxy S4 running Lollipop 5.0.2
    01-30-2015 03:04 PM
  20. dpham00's Avatar
    I'm sure they're also making less profit off of it.

    Sent from my Galaxy S4 running Lollipop 5.0.2
    No doubt though it is a better deal for most users, who don't care directly about how much profit companies make,only the best device for the money.

    Sent from my Verizon Samsung Galaxy Note 4
    01-30-2015 04:24 PM
  21. HTCTundaBow's Avatar
    Mine is super slow also. I don't know which generation I have, but it has LTE. It seriously makes me want to crush my phone. Everything is slow. There's a lag pressing the power button. Sometimes the screen wont even come on. All apps are super slow to open. TRying to use google maps is near impossible. I bought an SD and put all of my pics on it hoping it would speed up the phone, but no luck. This is horrible.
    01-31-2015 10:47 AM
  22. sulla1965's Avatar
    Mine is super slow also. I don't know which generation I have, but it has LTE. It seriously makes me want to crush my phone. Everything is slow. There's a lag pressing the power button. Sometimes the screen wont even come on. All apps are super slow to open. TRying to use google maps is near impossible. I bought an SD and put all of my pics on it hoping it would speed up the phone, but no luck. This is horrible.
    If it has lte then its not the mote g 2nd gen.Try a factory reset. There's no way the phone should be that slow. The moto g is usually quite snappy and responsive.
    01-31-2015 12:46 PM
  23. Phillip Pugh's Avatar
    My 2nd Gen moto g is very snapped for what it is a budget phone maybe the best budget phone out my main driver is my note edge I wanted to try the pure android on the cheap it's ok I love touchwiz much better t then stock you'd been better off getting a used s4 if it's to be your main driver there about that price used

    Posted via Android Central App
    02-02-2015 10:47 PM

Similar Threads

  1. How is this with people with glasses?
    By dt81 in forum VR Headsets
    Replies: 5
    Last Post: 02-14-2015, 01:33 PM
  2. Is there an app to ?
    By Krystal Rosebrock in forum Samsung Galaxy Ace
    Replies: 2
    Last Post: 01-28-2015, 11:40 PM
  3. How can i install an app from pc to phone?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 01-28-2015, 11:26 PM
  4. Replies: 0
    Last Post: 01-28-2015, 11:21 PM
  5. Sprint S5 on Boost Mobile or another MVNO
    By G6_KidGogle in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 01-28-2015, 11:12 PM
LINK TO POST COPIED TO CLIPBOARD