1. acwe's Avatar
    Ever since I updated to Lollipop. When ever I recharge the battery The phone unmounts the SD Card.

    The SD worked fine on my previous phone and also worked fine on kitkat 4.4 for two months but i have to restart the phone after recharging to get it to recognise that it has an SD card inserted.

    Any Ideas ???
    03-09-2015 03:33 AM
  2. B. Diddy's Avatar
    Does that happen with any SD card, or just that one?
    03-09-2015 10:56 AM
  3. acwe's Avatar
    Does that happen with any SD card, or just that one?
    Things started getting worse, where even restarting the phone wouldn't rectify the problem, after 4 or 5 restarts all of a sudden the SD card would be recognised again. Place it into a computer and it read it fine. Chkdsk found and fixed some errors.

    Purchased a new micro SD card just in case a few days ago and transfered the pics etc to the new card.

    So far so good with the new one.
    B. Diddy likes this.
    03-21-2015 02:14 AM
  4. Wireless Gadget's Avatar
    Check the formatting of the faulty SD card and compare to new card. Now that you have back up, format faulty card with same settings on new card. OS on moto G may not like the way old card was formatted.

    Posted via the Android Central App on my Sony Xperia Z Ultra GPe on Lollipop.
    03-22-2015 08:19 AM

Similar Threads

  1. Why can't I mount or format my sd card?
    By bagley247 in forum HTC Desire
    Replies: 7
    Last Post: 04-18-2015, 09:32 AM
  2. How do I move apps to an sd card on my Samsung Tab S?
    By AC Question in forum Samsung Galaxy Tab S 10.5
    Replies: 1
    Last Post: 03-09-2015, 09:10 AM
  3. Replies: 3
    Last Post: 03-09-2015, 03:08 AM
  4. Data is gs getting automatically lost from memory card. Reasons??
    By leoavi94 in forum Samsung Galaxy Note 2
    Replies: 3
    Last Post: 03-09-2015, 12:03 AM
  5. Replies: 1
    Last Post: 03-08-2015, 01:48 PM
LINK TO POST COPIED TO CLIPBOARD